Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Scrolling using keyboard arrow keys

  • 8 odpovedí
  • 1 má tento problém
  • 53 zobrazení
  • Posledná odpoveď od McCoy

more options

Is there a way I can scroll up and down web pages smoothly, using up and down arrow keys on a keyboard?

Vybrané riešenie

Stab in the dark,   but maybe you inadvertently enabled caret browsing.

Would you please press the F7 key on your keyboard (that key turns caret browsing
on and off)   -   does that make a difference ?

Čítať túto odpoveď v kontexte 👍 1

All Replies (8)

more options

Hello   Tony,

I use those keys all the time .....

Would you do this please :

3-bar menu Options General

Under   "Browsing"  "Use smooth scrolling".

Does that work for you ?

Helpful?

more options

Thank you Mcoy for answering so quickly, Yes I have both, Use autoscrolling, and Use smooth scrolling ticked already. It moves up and down in sections/steps. I have to tap keys to move page up and down. The steps are large on the way down and small on the way up.

Helpful?

more options

Vybrané riešenie

Stab in the dark,   but maybe you inadvertently enabled caret browsing.

Would you please press the F7 key on your keyboard (that key turns caret browsing
on and off)   -   does that make a difference ?

Helpful?

more options

Thank you McCoy, That was exactly what it was. Don't know how that happened. Don't suppose you have an easy answer to change the colour/color of the bookmark folders?

Helpful?

more options

Tony said

Thank you McCoy, That was exactly what it was. Don't know how that happened.

My pleasure   -   I'm glad everything is back to normal now !

How it happened ?
I sometimes find myself in airplane mode after I accidentally "touched" that key;   same thing could have happened with your F7 .....

Don't suppose you have an easy answer to change the colour/color of the bookmark folders?

No, I'm sorry .....

I don't use any bookmark folders;   hardly use any bookmarks at all   -   use Top Sites instead and only bookmark pages that don't have a proper URL.

But I'm sure that someone will come to your rescue here :

https://support.mozilla.org/en-US/questions/1287863

Helpful?

more options

You can set this pref to false on the about:config page to disable the F7 keyboard shortcut to toggle caret browsing.

Helpful?

more options

Thank you cor-el, McCoy has already solved this for me. I did have a look at your method, but I am not very technical and would have needed further guidance, as there were 24 occurrences of caret in Advanced Preferences. But thank you for replying to my question.

Helpful?

more options

Hi again Tony,

Cor-el's post makes it possible for you to disable caret browsing completely;   that way you won't have to be afraid that you'll accidentally hit F7 again.

If you want to do it;   here's how (piece of cake, really) :

Type in the address bar   about:config   and press Enter.
(ignore the warning)

Type in the search bar and look for the preference :

accessibility.browsewithcaret_shortcut.enabled

and set its value to   false

(if you use a mouse I should say "double click" on the value,   but as I don't use a mouse, I just tap on my touchpad twice)

After you've changed the value, close and restart Firefox.

I don't have to change that value, as I would need to press the Fn key + F7 to toggle caret browsing (all depends on your keyboard)
When I accidentally hit that key, I wind up in airplane mode   (that happens when I dust my keyboard too enthusiastically ..... )

Have a nice weekend !

Upravil(a) McCoy dňa

Helpful?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.