Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Microphone in Linux does not work correctly.

more options

Ever since I can remember I have never got the microphone to work correctly in Firefox 76.0 under GNU/Linux (x64_x86). After many years I now tried a site where I can record from my mic and I noticed that the sound is mostly heard at the beginning of words and static when I do not talk. It is if there is noise reduction or some kind of threshold ( inverted gate/expander) killing everything above a certain level.

In other apps it works without changing a single parameter in ALSA or Pulseaudio and letting them use the exact same settings as when trying it out in Firefox.

All Replies (3)

more options

To clarify, this was a problem way back and not only in version 76.

Helpful?

more options

Hi firefox_28440401,

You can check microphone permission,

  • First click on menu icon.
  • Then, click on options.
  • You will find privacy & security menu.
  • In this menu, you will find permissions option.
  • Here you will find microphone.
  • Click on settings.
  • Uncheck if it checked on Block new requests asking to access your microphone.

If it doesn't worked ,then feel free to ask in Reply section. Thanks for raising your question in Mozilla Support forum.

Upravil(a) Shashank Shekhar dňa

Helpful?

more options

Hey, I didn't pick a solution like the site says. This is making me upset when combined with the following:

Of course I have already granted Firefox access to my microphone. How else had I been able to record from the microphone on another site? Please read my question instead of giving a copy and paste answer.

Helpful?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.