Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search suggestions is enabled but not working?

  • 13 odpovedí
  • 1 má tento problém
  • 29 zobrazení
  • Posledná odpoveď od chris228

more options

I'm having similar issues to described here: https://support.mozilla.org/en-US/questions/1090728

The search bar in the "Awesome bar" has stopped offering search suggestions, either from my search history or from Google itself. When I control-click in the search bar, "search suggestions" has a check next to it, and it is also ticked in the Preferences.

This started last week when i migrated to a new iMac.

I went through all of the troubleshooting steps described in the article above but still no suggestions in the address bar.

I'd like to continue using Firefox but this is a deal breaker. What can i do?

Vybrané riešenie

chris228 said

Task: checkIntegrity
- Unable to check places.sqlite integrity: Error: Error(s) encountered during statement execution:

Unfortunately, the error message is incomplete. For example, in some cases Firefox will say "malformed disk image" or give another indication of why it can't work with the file.

I think we have to remove the Places database file and let Firefox generate a new one. Can you try making bookmark backups/exports first:

Assuming you can make a backup, then there are steps for removing the database file in the following article: Fix "The bookmarks and history system will not be functional" error message.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (13)

more options

Hi chris228,

Try refreshing the browser.Steps:-

  • Click the menu icon, then click on “Help”. Click on Firefox's main menu button, represented by three horizontal lines.
  • Click “Troubleshooting Information”.
  • Click on “Refresh Firefox”.
  • Confirm.
  • Click “Finish”.

If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

Pomohla vám táto odpoveď?

more options

Thank you for getting back to me.

I've tried that, as well as restarting in safe mode. Both don't change the issue.

I'm willing to totally erase all of my browser customization if it will fix this issue.

Pomohla vám táto odpoveď?

more options

hello chris228,

Erasing browser data is almost same like refreshing the browser, so i don't think it will work.

Have you tried this.

about:preferences#search

Good luck.

Pomohla vám táto odpoveď?

more options

I've played around with these settings but no luck so far.

See screenshot of how i have it now.

Pomohla vám táto odpoveď?

more options

Any difference if you check the box for showing suggestions in private windows?

For history, bookmark and open tab suggestions, could you check the settings on the Privacy and Security panel. More info in this article: Address bar autocomplete in Firefox - Search your bookmarks, history and tabs -- check the "How can I control what results the address bar shows me?" section.

Pomohla vám táto odpoveď?

more options

Thanks for your help all! I'm really stumped.

No difference when I check the box for showing suggestions in private windows

See screenshot of my Privacy and Security panel

Pomohla vám táto odpoveď?

more options

Do suggestions in the location bar drop-down work otherwise (history/bookmarks/tabs) ?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Pomohla vám táto odpoveď?

more options

Nothing shows up in, or below the location bar drop-down except what i type.

See screenshot of mid entry: https://imgur.com/Rm2817F

  • I was in DEFAULT theme
  • Still happens in Safe mode, or "Restart with Extensions disabled"

Pomohla vám táto odpoveď?

more options

Additional maybe related info:

Firefox is not saving my History at all. Show all History is completely empty.

In preferences i have it set to: Firefox will remember history

Any ideas how to fix this?

Pomohla vám táto odpoveď?

more options

If Firefox isn't saving history, and similarly if you can't bookmark anything new, could you let us know what you get when you run the "Verify Integrity" function. That's here:

Open Firefox's Troubleshooting Information page using any of these methods:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

Near the bottom, there is a section titled Places Database -- that's the file which stores history and bookmarks. Click the button labeled Verify Integrity. There may be a 10-15 second delay before results appear.

If all is well, the report that appears below the button should start with:

> Task: checkIntegrity
+ The places.sqlite database is sane
+ The favicons.sqlite database is sane

Does yours say that, or something else? You can select and copy the report, and then paste it into a reply for review and comment.

Pomohla vám táto odpoveď?

more options

Here's what i get:

Task: checkIntegrity

- Unable to check places.sqlite integrity: Error: Error(s) encountered during statement execution: > Task: invalidateCaches - The task queue was cleared by an error in another task. > Task: checkCoherence - The task queue was cleared by an error in another task. > Task: expire - The task queue was cleared by an error in another task. > Task: originFrecencyStats - The task queue was cleared by an error in another task. > Task: vacuum - The task queue was cleared by an error in another task. > Task: stats - The task queue was cleared by an error in another task. > Task: _refreshUI - The task queue was cleared by an error in another task.

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

chris228 said

Task: checkIntegrity
- Unable to check places.sqlite integrity: Error: Error(s) encountered during statement execution:

Unfortunately, the error message is incomplete. For example, in some cases Firefox will say "malformed disk image" or give another indication of why it can't work with the file.

I think we have to remove the Places database file and let Firefox generate a new one. Can you try making bookmark backups/exports first:

Assuming you can make a backup, then there are steps for removing the database file in the following article: Fix "The bookmarks and history system will not be functional" error message.

Pomohla vám táto odpoveď?

more options

Thank you. Following these steps seems to have fixed both issues!

Part 2 – Create a new database

   (Optional) Create a bookmark backup file.
   Click the Firefox menu at the top of the screen and select Quit Firefox. Wait until Firefox has completely quit.
   In the Firefox profile folder, find and delete (or rename) the favicons.sqlite and places.sqlite files.
       You can rename instead of deleting a file, to keep it as a backup. Click on it once to select it, click a second time on the file name to make it editable, then add .old to the end of its name. 
   Also delete the favicons.sqlite-shm, favicons.sqlite-wal, places.sqlite-shm and places.sqlite-wal files, if they exist.
   Finally, reopen Firefox.
       When Firefox reopens, it will create new favicons.sqlite and places.sqlite database files. Your browsing history will be lost but Firefox will automatically restore your bookmarks from the most recent bookmarkbackups file.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.