Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PayPal checkout popup window loads indefinitely; cannot make a payment

  • 15 odpovedí
  • 4 majú tento problém
  • 563 zobrazení
  • Posledná odpoveď od peteskarbo

more options

When using the "Checkout with PayPal" button on websites the PayPal popup window appears however it's impossible to progress to the checkout.

When OneTouch is activated, the text 'Securely logging you in...' appears overlayed with the spinning wheel in the popup window. This continues indefinitely.

When this is not activated the window doesn't progress further after entering the email as prompted by the window and pressing Next.

It's possible to login to PayPal in a separate tab however that doesn't influence the popup behaviour.


Looking at the console in the popup there are a few 'Unable to find window by ref window.js:148:14' errors.

In the 'host' window where the popup was called from the console displays the 'Failed to execute ‘postMessage’ on ‘DOMWindow’: The target origin provided (‘https://www.paypal.com’) does not match the recipient window’s origin (‘https://www.paypal.com’).' error.


I believe this could be a recent issue because I was able to make several payments last month with all settings the same. I have a separate user.js file that I keep my settings in (I can send it over if required). These settings have not been changed since the file has been created.


The following actions have been tried and didn't improve the situation:

- refreshing the current profile

- disabling all addins

- adding paypal.com into exclusions for 'Block pop-up windows' and Enhanced Tracking Protection

- cleaning History and cookies


I then launched Firefox with a separate 'clean' profile and was able to make the payment successfully. Sure enough, importing my user.js file broke PayPal. I went through the settings commenting them out by groups.

The following setting was causing the issue:

user_pref("privacy.firstparty.isolate", true);

Setting it to 'false' made the PayPal popup window work correctly again.

Thought that this would be helpful for anyone experiencing similar issues. Cheers.

Upravil(a) lupagamidho dňa

Vybrané riešenie

Thank you,

The following setting was causing the issue:

user_pref("privacy.firstparty.isolate", true);

Setting it to 'false' made the PayPal popup window work correctly again.

Thought that this would be helpful for anyone experiencing similar issues. Cheers.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (15)

more options

Glad that you were able to get things working!

Unfortunately, unsolved questions are hidden from search engines (like Google), so the odds of someone finding this question at the moment are slim. However, if you repost your solution as a reply to this thread, you should be given the option to mark it as the solution.

That will mean that the thread will be marked as solved and can be added to search engines so that users can find it.

If, for some reason, the option to mark your reply as the solution doesn't appear for you, just let us know and we can get a moderator to manually mark it for you.

Thanks.

more options

Vybrané riešenie

Thank you,

The following setting was causing the issue:

user_pref("privacy.firstparty.isolate", true);

Setting it to 'false' made the PayPal popup window work correctly again.

Thought that this would be helpful for anyone experiencing similar issues. Cheers.

more options

Sorry, how do I get to this setting to make the adjustment? From the Options tab, presumably?

more options

The settings they mentioned can be found on the about:config page in Firefox.

In their particular case, there was a user.js file in the profile folder, which is where Firefox stores your data. That file was being run each time Firefox opens, so it kept resetting that preference.

See Profiles - Where Firefox stores your bookmarks, passwords and other user data for more information about your profile profile and how to find it.

more options

Sorry I cannot find that setting with information given. Can somebody be more specific on how to find that setting and how to change it?

more options

First you want to open your Firefox profile folder to check if there is a file called user.js in there. There isn't always, so it may not be there for you.

To open your profile folder, go to the about:profiles page in Firefox. If you have more than one profile listed there, one of them will say This is the profile in use... so that's the profile that you are using. In the Root Directory row of that table, there will be a path name along with a Open Folder button. Press that button.

That will open the folder in your computer's file explorer. Look for a user.js file. If you find one, change the file name to user-old.js.

Now, regardless of whether or not you had that file in your folder, go back to Firefox and go to the about:config page. There might be a security warning that you need to bypass. Find the privacy.firstparty.isolate preference and double click it to change the value to false (if it's not already false).

Then restart Firefox and go back to the about:config page. Find the privacy.firstparty.isolate preference and make sure that the value is still false and didn't reset itself when you restarted Firefox.

If it stayed false and you are still having issues, open a new thread with the specifics of your issue so that you can get help with this issue.

Hope this helps.

more options

I am having the same issue. My config setting for privacy.firstparty.isolate is in fact set to false. Any other suggestions.

more options

If your preference is already set to false, my suggestion is to open a new thread with the specifics of your issue so that you can get help with this issue.

Since the thread that you are currently replying to is already marked as solved, it's not monitored by any of the contributors. Only people who have previously replied to the thread will see notifications about the activity here, which is why I can see when you reply. Making a new thread will put your question in front of all of the contributors here and should connect you to the right people to solve your problem.

more options

Thank you,

I will definitely do that!

Happy Easter,

Pete

more options

where is the about:config page? I found the about:profiles page no problem.

more options

in the url line type about:config.

more options

lupagamidho said

When using the "Checkout with PayPal" button on websites the PayPal popup window appears however it's impossible to progress to the checkout. When OneTouch is activated, the text 'Securely logging you in...' appears overlayed with the spinning wheel in the popup window. This continues indefinitely. When this is not activated the window doesn't progress further after entering the email as prompted by the window and pressing Next. It's possible to login to PayPal in a separate tab however that doesn't influence the popup behaviour. Looking at the console in the popup there are a few 'Unable to find window by ref window.js:148:14' errors. In the 'host' window where the popup was called from the console displays the 'Failed to execute ‘postMessage’ on ‘DOMWindow’: The target origin provided (‘https://www.paypal.com’) does not match the recipient window’s origin (‘https://www.paypal.com’).' error. I believe this could be a recent issue because I was able to make several payments last month with all settings the same. I have a separate user.js file that I keep my settings in (I can send it over if required). These settings have not been changed since the file has been created. The following actions have been tried and didn't improve the situation: - refreshing the current profile - disabling all addins - adding paypal.com into exclusions for 'Block pop-up windows' and Enhanced Tracking Protection - cleaning History and cookies I then launched Firefox with a separate 'clean' profile and was able to make the payment successfully. Sure enough, importing my user.js file broke PayPal. I went through the settings commenting them out by groups. The following setting was causing the issue: user_pref("privacy.firstparty.isolate", true); Setting it to 'false' made the PayPal popup window work correctly again. Thought that this would be helpful for anyone experiencing similar issues. Cheers.

I am having the same issue and my setting is set to "false" .

more options

I am having the same issue and my setting is set to "false". What else can I do?

more options

This is the same problem as...

Suddenly can't make PayPal payments on eBay using Firefox

more options

I cleared up my problem by deleting the paypal cookies. I did opt to stay continuously logged on to paypal, that is what started my problem.