X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

NPAPI flash plugin not loading

Pridané

Today I noticed that my custom plugins are no longer working. I decided to try and re-install flash. I removed the plugins from the directory manually then started again. I downloaded the NPAPI version from adobe (pictured). I then extracted the files and copied the plugin (libflashplayer.so) to firefox's plugin path ($MOZ_PLUGIN_PATH, which for me was /usr/lib/mozilla/plugins). I then restarted firefox. However, the shockwave flash plugin is not present in the plugins tab. This is odd as it was a couple of days ago before I redid this. Sites like newgrounds worked perfectly. Back when flash was working, I noticed on some sites that used html5, it would instead try to use flash. For a whille, the openh264 was stuck on "will be installed shortly." Now when I go to those sites, it will show the thumbnail, but not play. Youtube videos still work, however. In fact, it's really the only video site that still works. Was there a dramatic change in the past couple of days or something? I didn't even update firefox myself, this happened seemingly out of nowhere. I'll post my about:support data in the hopes that it might help? https://pastebin.com/6iHkwwjz I would post here, but it said it was too long... :/ According to this article: https://support.mozilla.org/en-US/kb/install-flash-plugin-view-videos-animations-games in theory, it should still work. However, despite installing flash and restarting firefox... no shockwave flash plugin is present in about:plugins

Today I noticed that my custom plugins are no longer working. I decided to try and re-install flash. I removed the plugins from the directory manually then started again. I downloaded the NPAPI version from adobe (pictured). I then extracted the files and copied the plugin (libflashplayer.so) to firefox's plugin path ($MOZ_PLUGIN_PATH, which for me was /usr/lib/mozilla/plugins). I then restarted firefox. However, the shockwave flash plugin is not present in the plugins tab. This is odd as it was a couple of days ago before I redid this. Sites like newgrounds worked perfectly. Back when flash was working, I noticed on some sites that used html5, it would instead try to use flash. For a whille, the openh264 was stuck on "will be installed shortly." Now when I go to those sites, it will show the thumbnail, but not play. Youtube videos still work, however. In fact, it's really the only video site that still works. Was there a dramatic change in the past couple of days or something? I didn't even update firefox myself, this happened seemingly out of nowhere. I'll post my about:support data in the hopes that it might help? https://pastebin.com/6iHkwwjz I would post here, but it said it was too long... :/ According to this article: https://support.mozilla.org/en-US/kb/install-flash-plugin-view-videos-animations-games in theory, it should still work. However, despite installing flash and restarting firefox... no shockwave flash plugin is present in about:plugins
Priložené obrázky

Upravil(a) Zack dňa

Vybrané riešenie

I prefer to place the libflashplayer .so in the plugins folder in /home/username/.mozilla/plugins/

Note the .mozilla is hidden and the plugins folder needs to be created if not already.

Čítať túto odpoveď v kontexte 1
Citácia

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

OpenH264 (Cisco)

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Viac informácií

Užitočné odpovede

Should I edit the question for clarity sake? I haven't had a reply so far...

Should I edit the question for clarity sake? I haven't had a reply so far...

Upravil(a) Zack dňa

Pomohlo vám to? 1
Citácia
James
  • Top 25 Contributor
  • Moderator
1603 riešení 11348 odpovedí

Vybrané riešenie

I prefer to place the libflashplayer .so in the plugins folder in /home/username/.mozilla/plugins/

Note the .mozilla is hidden and the plugins folder needs to be created if not already.

I prefer to place the libflashplayer .so in the plugins folder in /home/username/.mozilla/plugins/ Note the '''.'''mozilla is hidden and the plugins folder needs to be created if not already.
Pomohlo vám to? 1
Citácia

Autor otázky

~/.mozilla/plugins is another spot that MOZ_PLUGIN_PATH can point to. https://developer.mozilla.org/en-US/docs/Plugins/Guide/Plug-in_Basics#How_Gecko_Finds_Plug-ins I'm fine with the default location. Echoing the variable shows that it's currently pointing to /usr/lib/mozilla/plugins . However, the plugin isn't loading open restarting firefox.

~/.mozilla/plugins is another spot that MOZ_PLUGIN_PATH can point to. https://developer.mozilla.org/en-US/docs/Plugins/Guide/Plug-in_Basics#How_Gecko_Finds_Plug-ins I'm fine with the default location. Echoing the variable shows that it's currently pointing to /usr/lib/mozilla/plugins . However, the plugin isn't loading open restarting firefox.
Pomohlo vám to?
Citácia

Autor otázky

Huh, that's odd, moving it to ~/.mozilla/plugins worked. Moving the plugin to /usr/mozilla/plugins should also work, though. If it works, it works. Thanks for the solution.

Huh, that's odd, moving it to ~/.mozilla/plugins worked. Moving the plugin to /usr/mozilla/plugins should also work, though. If it works, it works. Thanks for the solution.
Pomohlo vám to?
Citácia

Autor otázky

The solution works, now I'm just curious as to why it works in ~/.mozilla/plugins but not the default $MOZ_PLUGIN_PATH location... should I report this as a bug?

The solution works, now I'm just curious as to why it works in ~/.mozilla/plugins but not the default $MOZ_PLUGIN_PATH location... should I report this as a bug?
Pomohlo vám to?
Citácia
Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.