X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Would like to always be in private mode. Private window doesn't stay private

Pridané

Hi and thanks in advance for any help. I've tried to designate Firefox as my privacy centered browser and use it on Facebook and so on. However, private mode has been very inconsistent. Occasionally when clicking open new private window Firefox will open in Private mode, but usually not. There is no indication it is private (no mask). When I go to Help, Restart with all addons disabled I still cannot get to a private window. If I do the refresh then all of the settings are reverted, but doesn't help.

Any foolproof steps for always browsing in private mode? Thank you.

Hi and thanks in advance for any help. I've tried to designate Firefox as my privacy centered browser and use it on Facebook and so on. However, private mode has been very inconsistent. Occasionally when clicking open new private window Firefox will open in Private mode, but usually not. There is no indication it is private (no mask). When I go to Help, Restart with all addons disabled I still cannot get to a private window. If I do the refresh then all of the settings are reverted, but doesn't help. Any foolproof steps for always browsing in private mode? Thank you.

Vybrané riešenie

You can tell if it's working by closing the browser after visiting a site, then opening it again and seeing if there is any data saved.

Note that private browsing mode only really protects your privacy from other people on your local machine, not from the websites you are visiting. If you want to protect yourself from tracking by those websites, I'd suggest you use something like https://addons.mozilla.org/firefox/addon/temporary-containers/ combined with Enhanced Tracking Protection in Firefox for desktop

Čítať túto odpoveď v kontexte 1
Citácia

Ďalšie informácie o systéme

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36

Viac informácií

Wesley Branton
  • Top 10 Contributor
591 riešení 5010 odpovedí

Užitočné odpovede

If you go to the History section of the Firefox settings and change the drop-down menu to Use custom settings for history, that will give you access to the Always use Private Browsing mode option.

However, I think that maybe you are misunderstanding what Private Browsing actually does. It doesn't necessarily stop other websites from tracking you, it basically just allows you to browse the internet without saving your history. All your session data is erased when you close Firefox. It does tighten the Content Blocking settings a little.

However, I think that maybe you are looking for the Multi-Account Containers feature (or Facebook Container specifically for Facebook). That would stop websites in one container from tracking the websites that are open in other containers.

If you go to the '''History''' section of the Firefox settings and change the drop-down menu to '''Use custom settings for history''', that will give you access to the '''Always use Private Browsing mode''' option. However, I think that maybe you are misunderstanding what Private Browsing actually does. It doesn't necessarily stop other websites from tracking you, it basically just allows you to browse the internet without saving your history. All your session data is erased when you close Firefox. It does tighten the Content Blocking settings a little. However, I think that maybe you are looking for the [[Multi-Account Containers]] feature (or [[Facebook Container - Prevent Facebook from tracking you on other websites|Facebook Container]] specifically for Facebook). That would stop websites in one container from tracking the websites that are open in other containers.
Pomohlo vám to? 1
Citácia

Autor otázky

Thank you for the suggestions. I did as you suggested and confirmed that Always use Private Browsing mode is active. When I open Firefox or click open new Private Window there is no mask indicating that it is in private mode. There should be, right?

Facebook Container is a good idea, but I'd like to get private mode working if possible. Thanks.

Thank you for the suggestions. I did as you suggested and confirmed that Always use Private Browsing mode is active. When I open Firefox or click open new Private Window there is no mask indicating that it is in private mode. There should be, right? Facebook Container is a good idea, but I'd like to get private mode working if possible. Thanks.
Pomohlo vám to?
Citácia
cor-el
  • Top 10 Contributor
  • Moderator
17472 riešení 157915 odpovedí

Užitočné odpovede

When you use "Always use Private Browsing mode" then you won't get the mask and the is only "New Private Window" present in the File menu and "New Window" is missing.

When you use "Always use Private Browsing mode" then you won't get the mask and the is only "New Private Window" present in the File menu and "New Window" is missing.
Pomohlo vám to? 1
Citácia

Autor otázky

Thank you. So I shouldn't expect the mask when Always use Private Browsing mode is enabled. How does one verify it is working?

I do still see the option for New Private Window.

Thank you. So I shouldn't expect the mask when Always use Private Browsing mode is enabled. How does one verify it is working? I do still see the option for New Private Window.
Pomohlo vám to?
Citácia
cor-el
  • Top 10 Contributor
  • Moderator
17472 riešení 157915 odpovedí

You won't see the purple mask when "Always use Private Browsing mode" is enabled. All new windows you open are Private Browsing mode windows, so you still see New Private Window, but you do not see "New Window" that would open a regular window in non Private Browsing mode.

You won't see the purple mask when "Always use Private Browsing mode" is enabled. All new windows you open are Private Browsing mode windows, so you still see New Private Window, but you do not see "New Window" that would open a regular window in non Private Browsing mode.
Pomohlo vám to? 1
Citácia

Autor otázky

Thank you, but I see both New Private Window and New Window. I attached a screenshot.

I seriously wonder if this is working. When I don't have Always Use Private Browsing mode checked and click on New Private Window I don't see the mask either.

What would be great, is something like Firefox Focus, but for the desktop.

Thank you, but I see both New Private Window and New Window. I attached a screenshot. I seriously wonder if this is working. When I don't have Always Use Private Browsing mode checked and click on New Private Window I don't see the mask either. What would be great, is something like Firefox Focus, but for the desktop.

Upravil(a) dcmccan dňa

Pomohlo vám to?
Citácia
Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 riešení 10669 odpovedí

Vybrané riešenie

You can tell if it's working by closing the browser after visiting a site, then opening it again and seeing if there is any data saved.

Note that private browsing mode only really protects your privacy from other people on your local machine, not from the websites you are visiting. If you want to protect yourself from tracking by those websites, I'd suggest you use something like https://addons.mozilla.org/firefox/addon/temporary-containers/ combined with Enhanced Tracking Protection in Firefox for desktop

You can tell if it's working by closing the browser after visiting a site, then opening it again and seeing if there is any data saved. Note that private browsing mode only really protects your privacy from other people on your local machine, not from the websites you are visiting. If you want to protect yourself from tracking by those websites, I'd suggest you use something like https://addons.mozilla.org/firefox/addon/temporary-containers/ combined with [[Enhanced Tracking Protection in Firefox for desktop]]
Pomohlo vám to? 1
Citácia
cor-el
  • Top 10 Contributor
  • Moderator
17472 riešení 157915 odpovedí

Both new window items in the "3-bar" Firefox menu button drop-down list open a new private window. The File menu only shows the New Private Window item and hides "New Window", but the "3-bar" Firefox menu button drop-down list doesn't appear to hide the "New Window" item.

As posted above, PB mode only disables storing session data in the profile folder. For websites there is not much difference apart from local storage (indexedDB) not working, so website that rely on this feature do not work and may complain or simply fail.

Both new window items in the "3-bar" Firefox menu button drop-down list open a new private window. The File menu only shows the New Private Window item and hides "New Window", but the "3-bar" Firefox menu button drop-down list doesn't appear to hide the "New Window" item. As posted above, PB mode only disables storing session data in the profile folder. For websites there is not much difference apart from local storage (indexedDB) not working, so website that rely on this feature do not work and may complain or simply fail.
Pomohlo vám to? 1
Citácia

Autor otázky

Thank you @cor-el, @Tyler Downer, and @Wesley Branton. In addition to the changes you suggested, I found an extension that will change the theme when in private mode to make it more obvious. Marking this as solved.

Thank you @cor-el, @Tyler Downer, and @Wesley Branton. In addition to the changes you suggested, I found an extension that will change the theme when in private mode to make it more obvious. Marking this as solved.
Pomohlo vám to?
Citácia
jscher2000
  • Top 10 Contributor
8693 riešení 71056 odpovedí

Another method is to visit https://www.washingtonpost.com/ and try to read an article. ;-)

Another method is to visit https://www.washingtonpost.com/ and try to read an article. ;-)
Pomohlo vám to?
Citácia

Autor otázky

I get that on my phone using Firefox Focus. I just leave. If enough people do that they will get the message (hopefully).

I get that on my phone using Firefox Focus. I just leave. If enough people do that they will get the message (hopefully).
Pomohlo vám to?
Citácia
Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.