X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Firefox asks which app to use to play WAVs, ignoring permanent setting (MacOS v.10.12.6, FF v.69)

Pridané

WAVs are set to automatically open in QuickTime player in Firefox preferences. The application ignores the preferences, instead requiring a helper app be selected via a dialog box each time. My voicemail arrives as a WAV so this is pretty frustrating and time-wasting.

WAVs are set to automatically open in QuickTime player in Firefox preferences. The application ignores the preferences, instead requiring a helper app be selected via a dialog box each time. My voicemail arrives as a WAV so this is pretty frustrating and time-wasting.
Priložené obrázky
Citácia

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • Shockwave Flash 26.0 r0
  • uBlock Origin

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:69.0) Gecko/20100101 Firefox/69.0

Viac informácií

jscher2000
  • Top 10 Contributor
8704 riešení 71122 odpovedí

Hi F.L. Office, this can occur if the server is sending a generic Content-Type for the download instead of the specific Content-Type for WAV files, which I think is audio/wav (or sometimes audio/x-wav). Firefox won't store the association for the generic content type because it is used for downloadable program files.

If that is the problem:

As a workaround, you can define a new content type using my extension here:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

Here's how:

(1) Turn on listening by clicking its button (Zzzz disappears and a yellow burst appears on the button)

(2) Start the download again, you can cancel out of the Open/Save dialog

(3) Click the toolbar button and click Add/Edit Content Types

(4) A tab will appear with a table showing your download request. Click Add for the .wav file and assign a content-type -- to take advantage of the current association, try audio/wav or to create a new one, you can use the fictitious type name

The table will show that row is now obsolete. Ignore that.

You can close this tab.

(5) Try the download again and either Firefox should now handle the file properly or you should now be able to define a persistent behavior (check the box).

Does that work on yours?

You can disable the extension when you are not downloading .wav files. Click the button and then click Stop Listening/Clear Log.

Hi F.L. Office, this can occur if the server is sending a generic Content-Type for the download instead of the specific Content-Type for WAV files, which I think is '''audio/wav''' (or sometimes '''audio/x-wav'''). Firefox won't store the association for the generic content type because it is used for downloadable program files. ''If that is the problem:'' As a workaround, you can define a new content type using my extension here: https://addons.mozilla.org/firefox/addon/content-type-fixer/ Here's how: (1) Turn on listening by clicking its button (Zzzz disappears and a yellow burst appears on the button) (2) Start the download again, you can cancel out of the Open/Save dialog (3) Click the toolbar button and click Add/Edit Content Types <center><img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-10-08-22-08-474306.png" width="250"></center> (4) A tab will appear with a table showing your download request. Click Add for the .wav file and assign a content-type -- to take advantage of the current association, try '''audio/wav''' or to create a new one, you can use the fictitious type name The table will show that row is now obsolete. Ignore that. You can close this tab. (5) Try the download again and either Firefox should now handle the file properly or you should now be able to define a persistent behavior (check the box). Does that work on yours? You can disable the extension when you are not downloading .wav files. Click the button and then click Stop Listening/Clear Log.
Pomohlo vám to?
Citácia
Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.