Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hi guys I have a problem seeing Google Ads on Mozilla yet I can see them on Chrome and IE. I have tried disabling the privacy shield for my site @ wenyenchi.com

  • 4 odpovede
  • 1 má tento problém
  • 15 zobrazení
  • Posledná odpoveď od jscher2000

more options

I have Google ads on my site. I can view them on Chrome and IE but not on Firefox. I have disabled adblocking for the my site and added exceptions for Wenyenchi.com, but the ads are still not showing. This is terrible since I rely on ads to keep the site up and running. This blocking is hurting my revenue.

I have cleared my cache and reloaded the site. It didn't work. The funny thing is I was seeing the ads last month but now its a just a huge blank space which has resulted in a negative user experience for my users using Firefox.

How do I resolve it since I have tried all the solutions provided in the forum?

If you use the inspect element tool, you will see that Firefox is blocking the ads even with the exceptions for the site.

Všetky odpovede (4)

more options

Since you mentioned IE, I'm going to flag this post to move to the main Firefox board instead of Android, since more people read that forum.

Is the issue Firefox's Content Blocking feature? Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

more options

I disabled content blocking for my site. The shield icon us greyed with a line across it. I even tried to disable all trackers using the custom option. Still the ads were not showing. I am really baffled because that was not the case. Could it be something with updates

more options

Go to about:config and set network.websocket.allowInsecureFromHTTPS = true.

PS. I don't think that your service worker implementation is working. It throws an error and Google Ad is going 'bye-bye'.

Upravil(a) TyDraniu dňa

more options

My console shows this when testing in a private window with Content Blocking disabled:

"uncaught exception: TagError: adsbygoogle.push() error: All ins elements in the DOM with class=adsbygoogle already have ads in them."

I see a lot of discussion of that one: https://www.google.com/search?client=firefox-b-1-d&q=TagError%3A+adsbygoogle.push()+error%3A+All+ins+elements+with+class%3Dadsbygoogle+already+have+ads