X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Newest version of Adobe Flash does not work with Firefox

Pridané

Last week Adobe Flash stopped actuating/working with Firefox and there is no black box in the address bar or any place else that I see that asks me to activate it. I have it set as Always Activate on the Plug-Ins page but that isn't helping. I checked and have the most recent version. I had to go through several steps to activate it but it does work in Chrome. I run Win 7 and Firefox is my default browser. Please advise how I can get Flash to work again as it is hampering a lot of my activity on the web. Thank you.

Last week Adobe Flash stopped actuating/working with Firefox and there is no black box in the address bar or any place else that I see that asks me to activate it. I have it set as Always Activate on the Plug-Ins page but that isn't helping. I checked and have the most recent version. I had to go through several steps to activate it but it does work in Chrome. I run Win 7 and Firefox is my default browser. Please advise how I can get Flash to work again as it is hampering a lot of my activity on the web. Thank you.
Citácia

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • Shockwave Flash 32.0 r0

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0

Viac informácií

cor-el
  • Top 10 Contributor
  • Moderator
17538 riešení 158581 odpovedí

This is not a Flash game but an HTML JavaScript game, so if it isn't working then this is not a problem with the Flash plugin.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
This is not a Flash game but an HTML JavaScript game, so if it isn't working then this is not a problem with the Flash plugin. *http://zone.msn.com/en/bejeweled/default.htm Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Pomohlo vám to?
Citácia

Autor otázky

Oh, so I have to get Java running to play the game? I wonder why the window isn't appearing when I go to the game. You'd think it would prompt the window to open up.

Oh, so I have to get Java running to play the game? I wonder why the window isn't appearing when I go to the game. You'd think it would prompt the window to open up.
Pomohlo vám to?
Citácia
McCoy
  • Top 10 Contributor
545 riešení 5141 odpovedí

tek360 said

Oh, so I have to get Java running to play the game? I wonder why the window isn't appearing when I go to the game.

No, not "Java" - remember when I asked you earlier about "JavaScript" ?

(we already established that the site does not use Flash .... )

Would you please try Safe Mode, like cor-el suggested ?

''tek360 [[#answer-1249216|said]]'' <blockquote> Oh, so I have to get Java running to play the game? I wonder why the window isn't appearing when I go to the game. </blockquote> No, not "Java" - remember when I asked you earlier about "Java'''Script'''" ? (we already established that the site does not use Flash .... ) Would you please try Safe Mode, like cor-el suggested ?
Pomohlo vám to?
Citácia

Autor otázky

No different. Still get a blank where the game should be but the ads play fine. I have no idea what to do.

No different. Still get a blank where the game should be but the ads play fine. I have no idea what to do.
Pomohlo vám to?
Citácia
McCoy
  • Top 10 Contributor
545 riešení 5141 odpovedí

I decided to check what MSN says that needs to be done when you want to play their games :

Allow cookies :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.


Would you check your Content Blocking settings please :

Options => Privacy & Security => Content Blocking.

(I have mine set to "Standard")


MSN also says to clear the cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache


If none of the above make a difference, then please post a question on the official Microsoft support forum (also suggested by MSN) :

www.answers.microsoft.com/windows

I decided to check what MSN says that needs to be done when you want to play their games : Allow cookies : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. ----------------------------------------------------------------------------------------------- Would you check your Content Blocking settings please : Options => Privacy & Security => Content Blocking. (I have mine set to "Standard") ------------------------------------------------------------------------------------------------- MSN also says to clear the cache : https://support.mozilla.org/en-US/kb/how-clear-firefox-cache ------------------------------------------------------------------------------------------------- If none of the above make a difference, then please post a question on the official Microsoft support forum (also suggested by MSN) : www.answers.microsoft.com/windows
Pomohlo vám to?
Citácia

Autor otázky

Prior to going into safe mode I did disable Content Blocking and allowed audio and video to play in the "i" in the address bar. It made no difference. I changed the cookies to allow.

My FF blocking is like yours, Standard.

I cleared the cache and deleted all cookies.

All of the above didn't make any difference. It only allows the ads to run but not the game to be played. I wrote to zonemaster last week and he finally answered me today asking me about playing in Edge. I just told him I don't have Win10 and asked whether the games will not work with Win7 now. I await his reply. I will let you know what he says.

Thanks for the help. It might just be a Microsoft move to make you use Microsoft products (and I am none to happy about using their browsers as they slow everything down. Is this why you don't use Edge?)

Prior to going into safe mode I did disable Content Blocking and allowed audio and video to play in the "i" in the address bar. It made no difference. I changed the cookies to allow. My FF blocking is like yours, Standard. I cleared the cache and deleted all cookies. All of the above didn't make any difference. It only allows the ads to run but not the game to be played. I wrote to zonemaster last week and he finally answered me today asking me about playing in Edge. I just told him I don't have Win10 and asked whether the games will not work with Win7 now. I await his reply. I will let you know what he says. Thanks for the help. It might just be a Microsoft move to make you use Microsoft products (and I am none to happy about using their browsers as they slow everything down. Is this why you don't use Edge?)
Pomohlo vám to?
Citácia

Autor otázky

Zonemaster says nothing has changed. I wonder if when clearing the cache and cookies last week something else was reset that is causing this. I have no idea what to even look at so I asked him if he has any ideas about it.

Zonemaster says nothing has changed. I wonder if when clearing the cache and cookies last week something else was reset that is causing this. I have no idea what to even look at so I asked him if he has any ideas about it.
Pomohlo vám to?
Citácia

Autor otázky

More..but when I go to Chrome it tells me to activate Flash to play the games and when I click to activate the games play. I think that FF is preventing Flash to play somehow and that's the issue. The page is supposed to ask me to activate Flash but it doesn't. You said the games aren't Flash based but obviously they must be or Chrome wouldn't have asked for it to be activated.

More..but when I go to Chrome it tells me to activate Flash to play the games and when I click to activate the games play. I think that FF is preventing Flash to play somehow and that's the issue. The page is supposed to ask me to activate Flash but it doesn't. You said the games aren't Flash based but obviously they must be or Chrome wouldn't have asked for it to be activated.
Pomohlo vám to?
Citácia

Autor otázky

So now we are back to a FF issue because the games do need Flash. Now that I migrated to regular FF and not ESR, I no longer have the option of "Always Activate" for Flash. I can only click "Ask to Activate". It seems that FF is not asking to activate Flash and that might be what is causing the problem here.

So now I need you help in solving this because it very well might be a FF issue and not a Microsoft one.

Thanks.

So now we are back to a FF issue because the games do need Flash. Now that I migrated to regular FF and not ESR, I no longer have the option of "Always Activate" for Flash. I can only click "Ask to Activate". It seems that FF is not asking to activate Flash and that might be what is causing the problem here. So now I need you help in solving this because it very well might be a FF issue and not a Microsoft one. Thanks.
Pomohlo vám to?
Citácia
cor-el
  • Top 10 Contributor
  • Moderator
17538 riešení 158581 odpovedí

The game can use canvas and WebGL to render the game, so make sure you do not block canvas and that WebGL is working properly.

I get this game in Firefox using canvas:

The game can use canvas and WebGL to render the game, so make sure you do not block canvas and that WebGL is working properly. I get this game in Firefox using canvas: *http://zone.msn.com/bingame/jqst/default_html5/index.html

Upravil(a) cor-el dňa

Pomohlo vám to?
Citácia

Autor otázky

Actually, that is not one of the games I was looking to play although it does come up and I can play it. I am looking for a few less graphic looking games. None of these will play because, I believe, Flash does not activate.

http://zone.msn.com/en/bejeweled/default.htm

http://zone.msn.com/en/mahjongtiles/default.htm

http://zone.msn.com/en/mahjonggalchemy/default.htm

http://zone.msn.com/en/texttwist/default.htm?intgid=hp_populargames_9

Actually, that is not one of the games I was looking to play although it does come up and I can play it. I am looking for a few less graphic looking games. None of these will play because, I believe, Flash does not activate. http://zone.msn.com/en/bejeweled/default.htm http://zone.msn.com/en/mahjongtiles/default.htm http://zone.msn.com/en/mahjonggalchemy/default.htm http://zone.msn.com/en/texttwist/default.htm?intgid=hp_populargames_9
Pomohlo vám to?
Citácia
McCoy
  • Top 10 Contributor
545 riešení 5141 odpovedí

No problem here loading any of those games .....

And as I don't have Flash enabled; the site obviously does not use Flash - if it did, I wouldn't be able to load and play the games.

It works for cor-el, and it works for me - I can't stand not being able to figure out why it won't work for you.

You mention "Zonemaster" - is this where you went to contact them (?) :

https://zone.msn.com/en/support/article/support3500.htm

If everything else fails; would you consider posting your question on the official Microsoft support forum ? (see the link I gave you earlier)

No problem here loading any of those games ..... And as I don't have Flash enabled; the site obviously does not use Flash - if it did, I wouldn't be able to load and play the games. It works for cor-el, and it works for me - I can't stand not being able to figure out why it won't work for you. You mention "Zonemaster" - is this where you went to contact them (?) : https://zone.msn.com/en/support/article/support3500.htm If everything else fails; would you consider posting your question on the official Microsoft support forum ? (see the link I gave you earlier)
Pomohlo vám to?
Citácia
McCoy
  • Top 10 Contributor
545 riešení 5141 odpovedí

As this kept bothering me, I checked the Microsoft support forum to see
if I could find a solution there - to no avail.

Just now I sent an email to zmaster@microsoft.com and gave them a link to this thread .....

As this kept bothering me, I checked the Microsoft support forum to see <BR>if I could find a solution there - to no avail. Just now I sent an email to zmaster@microsoft.com and gave them a link to this thread .....
Pomohlo vám to?
Citácia

Autor otázky

Yes, that's where I wrote. The guy who answers me is Adam.

Meantime, remember you are on Win10 and I am on Win7 and each is very different. Even when I open these games in Chrome it asks for Flash to be enabled in order to be played. In the newer OS something is obviously built in that doesn't require you to download Flash they play automatically.

Also remember I told you I deleted all cookies and cache last week and it might be coincidental but it is about the same time things started going wrong with the games...and some other things I use that utilize Flash. But, as I said earlier, I was a pro with WinXP, not so much with Win7 because so much is hidden and I know not where.

Yes, that's where I wrote. The guy who answers me is Adam. Meantime, remember you are on Win10 and I am on Win7 and each is very different. Even when I open these games in Chrome it asks for Flash to be enabled in order to be played. In the newer OS something is obviously built in that doesn't require you to download Flash they play automatically. Also remember I told you I deleted all cookies and cache last week and it might be coincidental but it is about the same time things started going wrong with the games...and some other things I use that utilize Flash. But, as I said earlier, I was a pro with WinXP, not so much with Win7 because so much is hidden and I know not where.
Pomohlo vám to?
Citácia

Autor otázky

Here's an update: tonight the games will not play on Chrome. I have no idea what's going on.

Here's an update: tonight the games will not play on Chrome. I have no idea what's going on.
Pomohlo vám to?
Citácia
McCoy
  • Top 10 Contributor
545 riešení 5141 odpovedí

tek360 said

Here's an update: tonight the games will not play on Chrome. I have no idea what's going on.

I hope you won't take this the wrong way, but in a way I'm glad, cause that just proves that this isn't down to Firefox .....

But it's weird, though. I hope that the Zone Master will come up with an explanation, and more importantly : with a solution.

''tek360 [[#answer-1249627|said]]'' <blockquote> Here's an update: tonight the games will not play on Chrome. I have no idea what's going on. </blockquote> I hope you won't take this the wrong way, but in a way I'm glad, cause that just proves that this isn't down to Firefox ..... But it's weird, though. I hope that the Zone Master will come up with an explanation, and more importantly : with a solution.
Pomohlo vám to?
Citácia
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 riešení 40244 odpovedí

A few stray comments about your postings in this thread ...

tek360 said

Okay, migrated to V69 and it did not solve the problem. Something else is going bats here and I don't know what it is. I still get the ever-spinning daisy as the page tries to load but can't. Graphics also seem to load slowly at some other sites. I don't have the same issue when going through Chrome. I don't know enough to even hazard a guess.

https://www.mozilla.org/en-US/firefox/69.0/releasenotes/

Changed "As previously announced in the Plugin Roadmap for Firefox, the "Always Activate" option for Flash plugin content has been removed. Firefox will now always ask for user permission before activating Flash content on a website."

Sounds like a step backwards for you.

Also, you talk as if Flash is ubiquitous, the same for all web browsers. Firefox uses the NPAPI Plugin version of Flash; IE uses the Active X version of Flash; where Google Chrome, Edge, and other WebKit / Blink based web browsers use their own PPAPI version of Flash.

Each of the three versions is installed separately and gets updated separately. Typically the major version numbers match (at least over the years), but rarely do the minor "patch" version are equal among the 3 major platforms.

In conclusion, you probably would have been better off installing the latest ESR version, which is now Firefox ESR 68.1 where the "Always Activate" option for Flash plugin content is still available. But it sure sounds like you are "barking up the wrong tree" as to what is really wrong in your Firefox installation.

At any rate, the life for Flash is very limited - December 31, 2020 - is slated to be the last day for Flash support. It's known as EOL - end of life.

A few stray comments about your postings in this thread ... ''tek360 [[#answer-1249003|said]]'' <blockquote> Okay, migrated to V69 and it did not solve the problem. Something else is going bats here and I don't know what it is. I still get the ever-spinning daisy as the page tries to load but can't. Graphics also seem to load slowly at some other sites. I don't have the same issue when going through Chrome. I don't know enough to even hazard a guess. </blockquote> https://www.mozilla.org/en-US/firefox/69.0/releasenotes/ '''Changed''' "As previously announced in the Plugin Roadmap for Firefox, '''the "Always Activate" option for Flash plugin content has been removed'''. Firefox will now always ask for user permission before activating Flash content on a website." Sounds like a step backwards for you. Also, you talk as if Flash is ubiquitous, ''the same for all web browsers''. Firefox uses the NPAPI Plugin version of Flash; IE uses the Active X version of Flash; where Google Chrome, Edge, and other WebKit / Blink based web browsers use their own PPAPI version of Flash. Each of the three versions is installed separately and gets updated separately. Typically the major version numbers match ''(at least over the years)'', but rarely do the minor "patch" version are equal among the 3 major platforms. In conclusion, you probably would have been better off installing the latest ESR version, which is now Firefox ESR 68.1 where the "Always Activate" option for Flash plugin content is still available. But it sure sounds like you are "barking up the wrong tree" as to what is really wrong in your Firefox installation. At any rate, the life for Flash is very limited - December 31, 2020 - is slated to be the last day for Flash support. It's known as '''EOL''' - end of life.
Pomohlo vám to?
Citácia

Autor otázky

I totally get it. I can probably go back to an ESR however I did bite the bullet last week and I ordered a new Dell due to the lack of support for Win7 after the new year. Nonetheless, it frustrates the heck out of me that I can't figure this out! Oh, and thanks for all the help. I hope the zmaster answers you as well!

I totally get it. I can probably go back to an ESR however I did bite the bullet last week and I ordered a new Dell due to the lack of support for Win7 after the new year. Nonetheless, it frustrates the heck out of me that I can't figure this out! Oh, and thanks for all the help. I hope the zmaster answers you as well!

Upravil(a) tek360 dňa

Pomohlo vám to?
Citácia
Kymber 1 riešení 15 odpovedí

I was doing fine with the Flash plug-in until the upgrade to 69.0 last weekend. At first, Firefox acted as if Flash no longer existed and just gave me blank spaces on the page where the Flash content was supposed to be.

I downloaded and reinstalled the plug-in from Adobe and that partially solved the problem. But I still have a big complaint.

About the only sites I need Flash for are the ones at which I play Hidato, Sudoku, Jumble, and the daily crossword. I understand why those are Flash-based ... I doubt there is a way to make games work under any other process. But now, every day, on every site, I get the grey "run Adobe Flash" box. And that leads to the "allow/don't allow" pop-up under the menu bar. And by the time I get past that, the site thinks it has already sent the data for loading into the plug-in, and I have to refresh the page. EVERY. SINGLE. TIME.

Now, I do understand that Flash has been used for a lot of nefarious purposes, and I understand that being the reason for Firefox to have been reconfigured. But even under "Manage Your Plug-Ins" (Add-ons Manager) the only options are "Ask To Activate" and "Never Activate". The developers could have -- SHOULD HAVE -- given us the option to "Always Activate", at least on a site-specific basis. That would mitigate the problem of "bad" sites while allowing us to use Flash on sites we know, from repeated visits, not to be harmful.

Please give us this option, and please do so at the earliest possible update. If I have to go through the above every day for the rest of my life it is going to drive me insane!

I was doing fine with the Flash plug-in '''until''' the upgrade to 69.0 last weekend. At first, Firefox acted as if Flash no longer existed and just gave me blank spaces on the page where the Flash content was supposed to be. I downloaded and reinstalled the plug-in from Adobe and that partially solved the problem. But I still have a '''big''' complaint. About the only sites I need Flash for are the ones at which I play Hidato, Sudoku, Jumble, and the daily crossword. I understand why those are Flash-based ... I doubt there is a way to make games work under any other process. But now, '''every day''', on '''every site''', I get the grey "run Adobe Flash" box. And that leads to the "allow/don't allow" pop-up under the menu bar. And by the time I get past that, the site thinks it has already sent the data for loading into the plug-in, and I have to refresh the page. '''EVERY. SINGLE. TIME.''' Now, I do understand that Flash has been used for a lot of nefarious purposes, and I understand that being the reason for Firefox to have been reconfigured. But even under "Manage Your Plug-Ins" (Add-ons Manager) the only options are "Ask To Activate" and "Never Activate". The developers could have -- SHOULD HAVE -- given us the option to "Always Activate", at least on a site-specific basis. That would mitigate the problem of "bad" sites while allowing us to use Flash on sites we know, from repeated visits, not to be harmful. Please give us this option, and please do so at the earliest possible update. If I have to go through the above every day for the rest of my life it is going to drive me insane!

Upravil(a) Kymber dňa

Pomohlo vám to?
Citácia

Autor otázky

At least you get a dialog box asking you to activate Flash. I don't even get that except in Chrome and that stopped as of last night..or so it seems. I haven't been there today. I try to play the games and either it spins and spins and nothing loads or I let all the ads in and I, like you, get a giant blank space where the game should be. Very frustrating and not a lot of fun.

At least you get a dialog box asking you to activate Flash. I don't even get that except in Chrome and that stopped as of last night..or so it seems. I haven't been there today. I try to play the games and either it spins and spins and nothing loads or I let all the ads in and I, like you, get a giant blank space where the game should be. Very frustrating and not a lot of fun.
Pomohlo vám to?
Citácia
Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.