X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Firefox cannot access Mac Photos to upload picture.

Pridané

When I try to add a photo to facebook (or any application) which requires access to the Mac Photo library, the photos are not shown. Chrome and Safari are fine, just firefox. I've deleted and resintalled firefox but the problem persists.

Closer examination of the console log shows a permission problem (below).

Prompting policy for hardened runtime; service: kTCCServicePhotos requires entitlement com.apple.security.personal-information.photos-library but it is missing for ACC:{ID: org.mozilla.firefox, PID[1658], auid: 501, euid: 501, binary path: '/Applications/Firefox.app/Contents/MacOS/firefox'}, REQ:{ID: com.apple.photolibraryd, PID[1826], auid: 501, euid: 501, binary path: '/System/Library/PrivateFrameworks/PhotoLibraryPrivate.framework/Versions/A/Support/photolibraryd'}

and then:

Unable to convert error to RedDwarf domain: Error Domain=com.apple.lithium Code=60 "This application is not authorized to access your Photo Library." UserInfo={NSLocalizedDescription=This application is not authorized to access your Photo Library., NSLocalizedFailureReason=Client not permitted to make this request, client pid: 1658}

I'm using MacOS 10.14.6 and firefox 68.0.1. If this is a simple fix via settings then great but I don't think I should be having to edit library files to get firefox to work properly.

Thanks

When I try to add a photo to facebook (or any application) which requires access to the Mac Photo library, the photos are not shown. Chrome and Safari are fine, just firefox. I've deleted and resintalled firefox but the problem persists. Closer examination of the console log shows a permission problem (below). Prompting policy for hardened runtime; service: kTCCServicePhotos requires entitlement com.apple.security.personal-information.photos-library but it is missing for ACC:{ID: org.mozilla.firefox, PID[1658], auid: 501, euid: 501, binary path: '/Applications/Firefox.app/Contents/MacOS/firefox'}, REQ:{ID: com.apple.photolibraryd, PID[1826], auid: 501, euid: 501, binary path: '/System/Library/PrivateFrameworks/PhotoLibraryPrivate.framework/Versions/A/Support/photolibraryd'} and then: Unable to convert error to RedDwarf domain: Error Domain=com.apple.lithium Code=60 "This application is not authorized to access your Photo Library." UserInfo={NSLocalizedDescription=This application is not authorized to access your Photo Library., NSLocalizedFailureReason=Client not permitted to make this request, client pid: 1658} I'm using MacOS 10.14.6 and firefox 68.0.1. If this is a simple fix via settings then great but I don't think I should be having to edit library files to get firefox to work properly. Thanks
Priložené obrázky
Citácia

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • Shockwave Flash 32.0 r0

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

Viac informácií

Autor otázky

No-One?

No-One?
Pomohlo vám to?
Citácia

Autor otázky

Solved it. A very convoluted fix involving manually inserting Firefox into the TCC database in the Mac and therefore allowing access to the photos library. I don’t think it’s necessarily a Firefox issue as my notebook Mac worked fine but definitely something odd. Anyway

Solved it. A very convoluted fix involving manually inserting Firefox into the TCC database in the Mac and therefore allowing access to the photos library. I don’t think it’s necessarily a Firefox issue as my notebook Mac worked fine but definitely something odd. Anyway

Upravil(a) Rufusman42 dňa

Pomohlo vám to?
Citácia
Molly G 0 riešení 2 odpovedí

Is there a fix for people who have no idea what an ECC database is or how to insert Firefox into it?

Is there a fix for people who have no idea what an ECC database is or how to insert Firefox into it?
Pomohlo vám to?
Citácia

Autor otázky

I asked the question and received no useful reply either from Mozilla support or the Apple communities. As a result I had to work it out myself. it's the TCC database and not the ECC database (typo) and I started here:

https://macops.ca/modifying-the-tcc-db/

However, depending on how confident you are with Terminal and Command line, this may be a non-starter. You also have to disable System Integrity Protection (SIP) on the mac to access and modify the TCC database.

Luckily, I have two macs, one of which was working correctly with firefox without manual correction and the other was not so I was able to compare the databases between machines. This of course also pointed to it being an apple issue and not a firefox one as one machine was fine.

A pertinent question to ask the apple communites may be why it isn't writing the correct permission to the TCC database when installing the software. I also noted that if I removed the entry for Chrome, and then reinstalled Chrome (on the affected machine), the entry was not replaced so it was definitely something to do with that mac.

Sorry I can't be more help. This is a very odd fault and that may be why the communites have been so quiet with potential answers.

I asked the question and received no useful reply either from Mozilla support or the Apple communities. As a result I had to work it out myself. it's the TCC database and not the ECC database (typo) and I started here: https://macops.ca/modifying-the-tcc-db/ However, depending on how confident you are with Terminal and Command line, this may be a non-starter. You also have to disable System Integrity Protection (SIP) on the mac to access and modify the TCC database. Luckily, I have two macs, one of which was working correctly with firefox without manual correction and the other was not so I was able to compare the databases between machines. This of course also pointed to it being an apple issue and not a firefox one as one machine was fine. A pertinent question to ask the apple communites may be why it isn't writing the correct permission to the TCC database when installing the software. I also noted that if I removed the entry for Chrome, and then reinstalled Chrome (on the affected machine), the entry was not replaced so it was definitely something to do with that mac. Sorry I can't be more help. This is a very odd fault and that may be why the communites have been so quiet with potential answers.
Pomohlo vám to?
Citácia
Molly G 0 riešení 2 odpovedí

Not at all confident :) Thank you for your response! I appreciate it.

Not at all confident :) Thank you for your response! I appreciate it.
Pomohlo vám to?
Citácia
Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.