X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Ever since I installed FF 68.0.1 on my Mac (10.14.6) and signed up for sync, it requires re-installation and re-installs all my extensions.

Pridané

The behavior only occurs on the computer I used to set up the Firefox account. It occurs every time I launch FF on that computer. Once I re-install it, sign in to the account and confirm the sign-in e-mail, FF appears to work properly.

The behavior only occurs on the computer I used to set up the Firefox account. It occurs every time I launch FF on that computer. Once I re-install it, sign in to the account and confirm the sign-in e-mail, FF appears to work properly.
Citácia

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

Ghostery, AdBlock+, https everywhere

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

Viac informácií

cor-el
  • Top 10 Contributor
  • Moderator
17416 riešení 157354 odpovedí

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
Pomohlo vám to?
Citácia

Autor otázky

No love there, I created a virgin profile, set it as default and restarted Firefox and got the same behavior, it re-installed Firefox.

I find it unlikely the problem is with my profile, since I am syncing the profile across multiple Macs, but this problem only occurs on the machine I used to create my Firefox account. This whole problem started with Sync; for years I kept my profile on an external drive that I physically moved between machines, but somewhere in the 60+ range of releases, Firefox started acting unstable and looked like it was being optimized to work with Sync, so I joined the parade.

It sure looks to me like a permissions problem, but I can't find where anything is anymore. Firefox no longer installs a directory under /Applications, just a single executable file named Firefox, unlike every other app in the universe.

Thanks, anyway

No love there, I created a virgin profile, set it as default and restarted Firefox and got the same behavior, it re-installed Firefox. I find it unlikely the problem is with my profile, since I am syncing the profile across multiple Macs, but this problem only occurs on the machine I used to create my Firefox account. This whole problem started with Sync; for years I kept my profile on an external drive that I physically moved between machines, but somewhere in the 60+ range of releases, Firefox started acting unstable and looked like it was being optimized to work with Sync, so I joined the parade. It sure looks to me like a permissions problem, but I can't find where anything is anymore. Firefox no longer installs a directory under /Applications, just a single executable file named Firefox, unlike every other app in the universe. Thanks, anyway
Pomohlo vám to?
Citácia
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 riešení 40084 odpovedí

dpn7 said

I find it unlikely the problem is with my profile, since I am syncing the profile across multiple Macs, but this problem only occurs on the machine I used to create my Firefox account. This whole problem started with Sync; for years I kept my profile on an external drive that I physically moved between machines, but somewhere in the 60+ range of releases, Firefox started acting unstable and looked like it was being optimized to work with Sync, so I joined the parade.

That is part of your problem! There were changes made in Firefox 67 / 68 where the profiles.ini file and how it 'relates' to the local Profiles on each device.

I wonder if Firefox is creating a new Profile on that Mac; what with you needing to reinstall it each time - ??

Just a SWAG as a long time Firefox user - starting in Aug 2002.

Sorry I do 'do Mac's' and I have having a hard enough time relating to the changes made in the Windows OS's with Fx 68 Profiles.

''dpn7 [[#answer-1243470|said]]'' <blockquote> I find it unlikely the problem is with my profile, since I am syncing the profile across multiple Macs, but this problem only occurs on the machine I used to create my Firefox account. '''This whole problem started with Sync; for years I kept my profile on an external drive that I physically moved between machines, but somewhere in the 60+ range of releases, Firefox started acting unstable and looked like it was being optimized to work with Sync''', so I joined the parade. </blockquote> That is part of your problem! There were changes made in Firefox 67 / 68 where the profiles.ini file and how it 'relates' to the local Profiles on each device. I wonder if Firefox is creating a new Profile on that Mac; what with you needing to reinstall it each time - ?? Just a '''SWAG''' as a long time Firefox user - ''starting in Aug 2002.'' ''Sorry I do 'do Mac's' and I have having a hard enough time relating to the changes made in the Windows OS's with Fx 68 Profiles.''
Pomohlo vám to?
Citácia

Autor otázky

Yup, new profile every time it's re-installed. Always correctly synced. And I am on a Mac.

Yup, new profile every time it's re-installed. Always correctly synced. And I am on a Mac.
Pomohlo vám to?
Citácia
Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.