Search Support

How do I stop Firefox Quantum from using Yahoo search when I type something in the address bar?

  • 3 odpovede
  • 1 má tento problém
  • 46 zobrazení
  • Posledná odpoveď od cor-el

more options

I am using Firefox Quantum and when I type something in the address bar Yahoo searches pop up. There are obviously many other people with the same problem as I have seen this same issue brought up multiple times when I have researched this problem. I have looked at the answers provided in the various forums etc. and none have provided an answer that works for me. I have done the "about:config", "about:preferences#search", gone in and deleted or inactivated all add ons, etc. and either the expected response such as looking for the "keyword.url" is not there or does not work. If this can't be fixed I am going to stop using Firefox all together as this Yahoo search thing is SO annoying. I would think that with this being a common problem the help sites for Mozilla/Firefox would have the answer readily available. Furthermore, just my two cents worth, but I think it stinks that either Yahoo or some other associated program hijacks the address bar and changes the search from Google, which is what I had set up, to Yahoo without a warning or even without asking if I would like this. The results that Yahoo search produces are very inadequate.

Vybrané riešenie

It sounds like you have a third party program that has taken over your search engine, home page, and/or the default new tab page. Fortunately, this can be remedied easily:

  1. Click the menu button fx57menu and choose Add-ons.
  2. In the Add-ons Manager tab, select the Extensions panel.
  3. Select the toolbar you wish to remove.
  4. Click the Remove button.
  5. Click "Restart now" if it pops up. Your tabs will be saved and restored after the restart.

For further information, please read Remove a toolbar that has taken over your Firefox search or home page.

Did this fix the problem? Please let us know!

Čítať túto odpoveď v kontexte 👍 1

All Replies (3)

more options

Vybrané riešenie

It sounds like you have a third party program that has taken over your search engine, home page, and/or the default new tab page. Fortunately, this can be remedied easily:

  1. Click the menu button fx57menu and choose Add-ons.
  2. In the Add-ons Manager tab, select the Extensions panel.
  3. Select the toolbar you wish to remove.
  4. Click the Remove button.
  5. Click "Restart now" if it pops up. Your tabs will be saved and restored after the restart.

For further information, please read Remove a toolbar that has taken over your Firefox search or home page.

Did this fix the problem? Please let us know!

more options

Wesley,

  Thank you so much! This was so simple and it worked. I don't know why I had not run across this solution before. Again, thanks.
more options

You may want to remove all three extensions that show in the System Details list next to your question if you didn't do this (only one appears as active).

Maybe also do a malware scan on your Mac just to be sure.