X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Firefox Location bar issue with new version

Pridané

With the newest Firefox, when I type in the address of where I want to go, the bar drops down and gives me all kinds of search and suggestions...I DON'T WANT THIS. I know where I want to go. How can I get rid of this area. See photo.

With the newest Firefox, when I type in the address of where I want to go, the bar drops down and gives me all kinds of search and suggestions...I DON'T WANT THIS. I know where I want to go. How can I get rid of this area. See photo.
Priložené obrázky
cor-el
  • Top 10 Contributor
  • Moderator
17475 riešení 157940 odpovedí

Did you check the settings in "Options/Preferences -> Search" for the address bar?

Did you check the settings in "Options/Preferences -> Search" for the address bar?
McCoy
  • Top 10 Contributor
534 riešení 5035 odpovedí

Hello tpholt,

If you want to get rid of the bar, listing all available search engines, would you please do this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.urlbar.OneOffSearches

and set its value to false

Then close and restart Firefox.

Note: that preference was disabled, but works again today.


In case you also don't want to see any search suggestions, in addtition to cor-el's post :

Got to Options => Privacy & Security => under Address Bar : uncheck all options.

Hello tpholt, If you want to get rid of the bar, listing all available search engines, would you please do this : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''browser.urlbar.OneOffSearches''' and set its value to '''false''' Then close and restart Firefox. '''Note''': that preference was disabled, but works again today. -------------------------------------------------------------------------------------------- In case you also don't want to see any search suggestions, in addtition to cor-el's post : Got to Options => Privacy & Security => under Address Bar : uncheck all options.

Užitočné odpovede

I've done both of these, and the search engines line is no longer listed, but I still get a drop down bar that shows the exact same text as I am typing into the URL Bar, only this line has the Magnifying Glass on it (it's the blue highlighted line in the screenshot above). How do I get rid of this? There's no need for Firefox to show me the exact same text twice (one in the actual URL Bar and once in this drop down bar).

Tony

I've done both of these, and the search engines line is no longer listed, but I still get a drop down bar that shows the exact same text as I am typing into the URL Bar, only this line has the Magnifying Glass on it (it's the blue highlighted line in the screenshot above). How do I get rid of this? There's no need for Firefox to show me the exact same text twice (one in the actual URL Bar and once in this drop down bar). Tony
McCoy
  • Top 10 Contributor
534 riešení 5035 odpovedí

tpholt said

I've done both of these, and the search engines line is no longer listed, but I still get a drop down bar that shows the exact same text as I am typing into the URL Bar, only this line has the Magnifying Glass on it (it's the blue highlighted line in the screenshot above). How do I get rid of this? There's no need for Firefox to show me the exact same text twice (one in the actual URL Bar and once in this drop down bar).

I know exactly what you mean, and I have not been able to find a way to disable that blue bar (clicking on it will make it disappear). I guess we'll have to live with it, unless someone knows of a way to disable it ......

''tpholt [[#answer-1194546|said]]'' <blockquote> I've done both of these, and the search engines line is no longer listed, but I still get a drop down bar that shows the exact same text as I am typing into the URL Bar, only this line has the Magnifying Glass on it (it's the blue highlighted line in the screenshot above). How do I get rid of this? There's no need for Firefox to show me the exact same text twice (one in the actual URL Bar and once in this drop down bar). </blockquote> I know exactly what you mean, and I have not been able to find a way to disable that blue bar (clicking on it will make it disappear). I guess we'll have to live with it, unless someone knows of a way to disable it ......
cor-el
  • Top 10 Contributor
  • Moderator
17475 riešení 157940 odpovedí

Try to set this pref to false on the about:config page.

  • keyword.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Try to set this pref to false on the <b>about:config</b> page. *keyword.enabled = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
McCoy
  • Top 10 Contributor
534 riešení 5035 odpovedí

Setting the value of the preference "browser.urlbar.unifiedcomplete" to "false" used to disable that blue bar, but that preference was removed some years ago .....

Also see : https://www.askvg.com/tip-remove-search-with-google-and-visit-website-options-from-firefox-addressbar-results/

Setting the value of the preference "browser.urlbar.unifiedcomplete" to "false" used to disable that blue bar, but that preference was removed some years ago ..... Also see : https://www.askvg.com/tip-remove-search-with-google-and-visit-website-options-from-firefox-addressbar-results/

Autor otázky

cor-el said

Try to set this pref to false on the about:config page.
  • keyword.enabled = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Tried this, but no luck. Thanks, though, for the info.

Tony

''cor-el [[#answer-1194571|said]]'' <blockquote> Try to set this pref to false on the <b>about:config</b> page. *keyword.enabled = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config </blockquote> Tried this, but no luck. Thanks, though, for the info. Tony

Autor otázky

McCoy said

Setting the value of the preference "browser.urlbar.unifiedcomplete" to "false" used to disable that blue bar, but that preference was removed some years ago ..... Also see : https://www.askvg.com/tip-remove-search-with-google-and-visit-website-options-from-firefox-addressbar-results/

Up until this newest version, which just installed this week, I did not have this issue, so it's something that's changed with this newest version.

Tony

''McCoy [[#answer-1194584|said]]'' <blockquote> Setting the value of the preference "browser.urlbar.unifiedcomplete" to "false" used to disable that blue bar, but that preference was removed some years ago ..... Also see : https://www.askvg.com/tip-remove-search-with-google-and-visit-website-options-from-firefox-addressbar-results/ </blockquote> Up until this newest version, which just installed this week, I did not have this issue, so it's something that's changed with this newest version. Tony
McCoy
  • Top 10 Contributor
534 riešení 5035 odpovedí

tpholt said

Up until this newest version, which just installed this week, I did not have this issue, so it's something that's changed with this newest version.

You may not have noticed it before, or rather : maybe it never bothered you before, but that blue bar has been there for years ......

Trying to find 'proof' (in addition to the article I gave you a link to) I found this thread : https://support.mozilla.org/en-US/questions/1185142 (see the Chosen Solution, and scroll down to "the blue bar".... )

Like I mentioned before : when that blue bar appears, just click on it, and it will disappear.

''tpholt [[#answer-1194598|said]]'' <blockquote> Up until this newest version, which just installed this week, I did not have this issue, so it's something that's changed with this newest version. </blockquote> You may not have noticed it before, or rather : maybe it never bothered you before, but that blue bar has been there for years ...... Trying to find 'proof' (in addition to the article I gave you a link to) I found this thread : https://support.mozilla.org/en-US/questions/1185142 (see the Chosen Solution, and scroll down to "the blue bar".... ) Like I mentioned before : when that blue bar appears, just click on it, and it will disappear.
cor-el
  • Top 10 Contributor
  • Moderator
17475 riešení 157940 odpovedí

Add code to the userChrome.css file below the default @namespace line.

You can use one of these. The first code hides all the results in the drop-down list. The second code only hides the visit and search results.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* hide all results*/
#PopupAutoCompleteRichResult {
 display:none!important;
}

/* hide search and visit results */
#PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="searchengine"],
#PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="visiturl"]{
display:none!important;
}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css *https://www.userchrome.org/how-create-userchrome-css.html You can use one of these. The first code hides all the results in the drop-down list. The second code only hides the visit and search results. <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* hide all results*/ #PopupAutoCompleteRichResult { display:none!important; } /* hide search and visit results */ #PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="searchengine"], #PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="visiturl"]{ display:none!important; } </nowiki></pre> ----- It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted. In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named <i>userChrome.css.txt</i>. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as". You need to close and restart Firefox when you create or modify the userChrome.css file.