Search Support

"select device" does not show in rdm

  • 7 odpovedí
  • 1 má tento problém
  • 94 zobrazení
  • Posledná odpoveď od cor-el

more options

Firefox 64.0 on Windows 10. When RDM is invoked, the box where you can select a device is NOT SHOWING.

I saw one post where it was suggested to open Browser Control, and there are errors shown. I just do not know what they mean or how to proceed.

Can anyone help? TIA! André

The message shown is:

[2018-12-11T18:26:21.995Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/gb4hho3chcad4bp5um2eouhyhrmdr496/httpsscan background.js:34:9 [2018-12-11T18:26:22.036Z] Request status: 2 background.js:34:9 [2018-12-11T18:26:22.040Z] Request status: 3 background.js:34:9 [2018-12-11T18:26:22.042Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:9 [2018-12-11T18:26:22.043Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:9 Use of nsIFile in content process is deprecated. NetUtil.jsm:266:12 [2018-12-11T18:26:23.954Z] Details: {"requestId":"1809","url":"https://www.mozilla.org/media/css/BUNDLES/protocol-core.cc4e6306808b.css","originUrl":"https://www.mozilla.org/en-US/","documentUrl":"https://www.mozilla.org/en-US/","method":"GET","type":"stylesheet","timeStamp":1544552783952,"frameId":0,"parentFrameId":-1,"proxyInfo":null,"ip":null,"frameAncestors":[],"tabId":1} background.js:34:9 [2018-12-11T18:26:23.957Z] requestId: 1809 background.js:34:9 uncaught exception: 2147500033 browser.xml:1048:13 [Exception... "Method not implemented'Method not implemented' when calling method: [nsIWebNavigation::sessionHistory]" nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)" location: "JS frame :: chrome://global/content/bindings/browser.xml :: construct :: line 1048" data: no] construct chrome://global/content/bindings/browser.xml:1048:13 start resource://devtools/client/responsive.html/browser/tunnel.js:179:7 InterpretGeneratorResume self-hosted:1255:8 next self-hosted:1210:9 start resource://devtools/client/responsive.html/browser/swap.js:217:13 InterpretGeneratorResume self-hosted:1255:8 next self-hosted:1210:9 [2018-12-11T18:26:32.996Z] Details: {"requestId":"1810","url":"https://www.mozilla.org/favicon.ico","originUrl":"https://www.mozilla.org/en-US/","documentUrl":"https://www.mozilla.org/en-US/","method":"GET","type":"image","timeStamp":1544552792969,"frameId":0,"parentFrameId":-1,"proxyInfo":null,"ip":null,"frameAncestors":[],"tabId":1} background.js:34:9 [2018-12-11T18:26:33.008Z] requestId: 1810 background.js:34:9 [2018-12-11T18:26:33.099Z] Details: {"requestId":"1811","url":"https://www.mozilla.org/media/img/favicon/favicon-196x196.c80e6abe0767.png","originUrl":"https://www.mozilla.org/en-US/","documentUrl":"https://www.mozilla.org/en-US/","method":"GET","type":"image","timeStamp":1544552793080,"frameId":0,"parentFrameId":-1,"proxyInfo":null,"ip":null,"frameAncestors":[],"tabId":1} background.js:34:9 [2018-12-11T18:26:33.099Z] Details: {"requestId":"1812","url":"https://www.mozilla.org/media/img/favicon.d4f1f46b91f4.ico","originUrl":"https://www.mozilla.org/en-US/","documentUrl":"https://www.mozilla.org/en-US/","method":"GET","type":"image","timeStamp":1544552793082,"frameId":0,"parentFrameId":-1,"proxyInfo":null,"ip":null,"frameAncestors":[],"tabId":1} background.js:34:9 this.nativeTab.linkedBrowser is null ext-browser.js:765 [2018-12-11T18:26:33.391Z] requestId: 1811 background.js:34:9 [2018-12-11T18:26:33.392Z] requestId: 1812 background.js:34:9 this.nativeTab.linkedBrowser is null ext-browser.js:765 [2018-12-11T18:26:51.997Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/gb4hho3chcad4bp5um2eouhyhrmdr496/httpsscan background.js:34:9 [2018-12-11T18:26:52.039Z] Request status: 2 background.js:34:9 [2018-12-11T18:26:52.042Z] Request status: 3 background.js:34:9 [2018-12-11T18:26:52.042Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:9 [2018-12-11T18:26:52.042Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:9 [2018-12-11T18:27:22.000Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/gb4hho3chcad4bp5um2eouhyhrmdr496/httpsscan background.js:34:9 [2018-12-11T18:27:22.013Z] Request status: 2 background.js:34:9 [2018-12-11T18:27:22.015Z] Request status: 3 background.js:34:9 [2018-12-11T18:27:22.015Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:9 [2018-12-11T18:27:22.015Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:9 [2018-12-11T18:27:52.002Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/gb4hho3chcad4bp5um2eouhyhrmdr496/httpsscan background.js:34:9 [2018-12-11T18:27:52.023Z] Request status: 2 background.js:34:9 [2018-12-11T18:27:52.024Z] Request status: 3 background.js:34:9 [2018-12-11T18:27:52.025Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:9 [2018-12-11T18:27:52.025Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:9

Vybrané riešenie

You're welcome.

No need to feel stupid. There are lots of weird things in Firefox when you make a window smaller, so sometimes I just press F11 to switch to full screen mode.

Čítať túto odpoveď v kontexte 👍 1

All Replies (7)

more options

Hi Andre4:

You mean "Responsive Design Mode" in Firefox Dev Tools right? If so, please ask at stackoverflow.com and tag it 'firefox'. Unfortunately we don't have Firefox developer support expertise here just Firefox user support.

Cheers!

...Roland

more options

I invited Andre4 to a screen sharing session, and I'll give an update here once we are done.

more options

I see a Responsive selector in the top left corner where I can select devices.

Don't you see this button?

more options

Hi cor-el,

No, I don't see that box. I found an old post on the internet somewhere that stated that in about:config both browser.tabs.remote.autostart should be set to 'true', which the are. So obviously that is not the solution here.

more options

Some buttons including the Responsive button disappear when I make the window smaller. If your window is as small as the screenshot shows then make the window wider like in my above screenshot. Compare this screenshot with the one i posted above.

Upravil(a) cor-el dňa

more options

Yes! Thank you cor-el! Man, I feel stupd, right now =D

more options

Vybrané riešenie

You're welcome.

No need to feel stupid. There are lots of weird things in Firefox when you make a window smaller, so sometimes I just press F11 to switch to full screen mode.