X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

How stop video autoplay?

Pridané

After a recent update to version 63.0, videos with maximum audio automatically start. This problem is especially acute with CNN.com. I will not tolerate this problem and either must find away to immediately prevent it or, undesirably, switch to another browser.

How do I stop video's from automatically starting?

Thank you.

After a recent update to version 63.0, videos with maximum audio automatically start. This problem is especially acute with CNN.com. I will not tolerate this problem and either must find away to immediately prevent it or, undesirably, switch to another browser. How do I stop video's from automatically starting? Thank you.

Ďalšie informácie o systéme

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Viac informácií

jscher2000
  • Top 10 Contributor
8785 riešení 71851 odpovedí

Užitočné odpovede

Hi Barryng, these hidden settings have evolved in preparation for being added to the Permissions section of the Preferences page in a later release. For now, you'll still need to use about:config.

The old media.autoplay.enabled preference has been replaced by several new ones (you may see it, but Firefox ignores it). Please give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • Some people suggest you also: Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

I'm sure we'll learn more about the interaction of these various preferences and what sites can bypass them as more users begin to run Firefox 63.

Hi Barryng, these hidden settings have evolved in preparation for being added to the Permissions section of the Preferences page in a later release. For now, you'll still need to use about:config. The old '''media.autoplay.enabled''' preference has been replaced by several new ones (you may see it, but Firefox ignores it). Please give this a try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered To set your preferred behavior: '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' * ''Some people suggest you also:'' Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false => ''Does that work for you?'' '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true '''''Allow autoplay by default''''' (default for Release) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset) I'm sure we'll learn more about the interaction of these various preferences and what sites can bypass them as more users begin to run Firefox 63.