Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My bookmark toolabar disappeared (Sep 2018)

  • 6 odpovedí
  • 6 má tento problém
  • 1075 zobrazení
  • Posledná odpoveď od DS-NZ

more options

Recently I lost my bookmark toolbar. I tried the customize fix suggested in other thread but there is no bookmark toolbar item to drag up. So I tried reset but did not help. Strange thing is if I open up a private window my toolbar is there

Vybrané riešenie

While I appreciate the suggestions , none of them worked, and most of them were tried already.

I did a full restart of Firefox , it installed an update, and my bookmark toolbar is back, I hope it stays

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (6)

more options

Another thing, when I restart Firefox I see the toolbar for a split second and then it vanishes. Also starting in safe mode does not help

more options

Did you verify via customization mode that "Bookmarks Toolbar Items" is positioned on the Bookmarks Toolbar?

If that isn't the case then click the Restore Defaults button.


There might be a problem with the places.sqlite database.

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

  • use "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page
    in case errors are reported close and restart Firefox and retry

See also:

If "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page cannot repair places.sqlite then remove all places.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options
more options

cor-el said

Did you verify via customization mode that "Bookmarks Toolbar Items" is positioned on the Bookmarks Toolbar? If that isn't the case then click the Restore Defaults button.

There might be a problem with the places.sqlite database.

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

  • use "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page
    in case errors are reported close and restart Firefox and retry

See also:

If "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page cannot repair places.sqlite then remove all places.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

As I mentioned, I followed older posts and have tried this already

more options

Vybrané riešenie

While I appreciate the suggestions , none of them worked, and most of them were tried already.

I did a full restart of Firefox , it installed an update, and my bookmark toolbar is back, I hope it stays

Upravil(a) jmsnyc dňa

more options

I have come across this issue several times now, and tried many of the solutions others have posted - full re-installation, refreshing, disabling and re-enabling the Bookmarks Toolbar, etc.

I just had the same issue appear again, where Firefox would load up with no Bookmarks Toolbar showing, yet the selections were all in place indicating that it should be visible.

The super-simple fix I found, in my last case, was simply to create a new window (ctrl+n). And there, in the new windows, was my well-packed Bookmarks Toolbar.

The issue was caused because I had the option set to "Restore previous session", and the last window I closed had a script in it that prevented the toolbars appearing, as it was a pop-up from some website. Creating the new window and closing that last fixed the issue straight away.

Hopefully this quick fix may help some others out of this ridiculously recurring conundrum.