Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

the new firefox opens new windows instead of tabs in one browser window and I hate it. I want my tabs back for easy access!

  • 3 odpovede
  • 3 majú tento problém
  • 76 zobrazení
  • Posledná odpoveď od jscher2000

more options

Firefox upgraded and now instead of a tab system, I have all these stupid windows open. I want tabs in one browser window for easy access. I hate this but don't want to downgrade to an older version. How do I get the tabs back? the only time I actually see the tabs is when I go to "customize." As soon as I close that, the tabs disappear and I'm back to open windows.

Všetky odpovede (3)

more options

Separate Security Issue, please update your Flash 28.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 31.0.0.108 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Hi, that is not a feature or a improvement it means you have a corrupted file.

Please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:

then

Please let us know if this solved your issue or if need further assistance.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Hi Sam_1956, I haven't noticed any change in Firefox's behavior related to opening links for years. However, if you were using Tab Mix Plus or another add-on that modified how links work, the normal built-in behavior might not be what you want. Let's go through Firefox's options:

(1) Links that websites have coded to open in a new window

Firefox normally will divert these to a new tab instead. There's a checkbox for that on the Options page. To check on that:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Tabs section and make sure the box is checked for "Open links in tabs instead of new windows" --

However, there are some exceptions. I'll describe the details further down in this reply.

(2) Links that websites didn't code specially

These should open in the same tab, not a new window, not a new tab. Sounds like these are not a problem for you.


Now... Firefox does make exceptions to the "divert to tab" setting in some cases:

Dialog Window: Firefox may not be able to open a new tab in certain kinds of pop-up windows. Typically you would recognize these as "dialog" style because most of the toolbar is missing and you do not have a tabs bar. I don't have a workaround for this situation, but these should be rare.

Scripted Popup: If it's a normal window, there may be a script attached to the link. To force scripts to launch new windows in a new tab, you may need to modify a setting. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

  • 3 = divert new window to a new tab (default) <= This should already be set; if it's not, right-click > Reset to restore the default
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

  • 0 = apply the setting under (A) to ALL new windows (even script windows) <= Try this one
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default) <= this should already be set; if it's not, right-click > Reset to restore the default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Does that help with the problem links?