Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Twitter browser notifications "unsupported" in Firefox?

  • 2 odpovede
  • 1 má tento problém
  • 37 zobrazení
  • Posledná odpoveď od Shadow110

more options

According to Twitter's help center:

"A web notification is a pop-up that appears within your web browser to notify you about what’s happening on Twitter when you’re on twitter.com and logged in to your account. If you’re using Chrome or Firefox you can also turn on browser notifications, which enables you to receive notifications as they happen, regardless of whether you’re on twitter.com."

However, when I enter Twitter's web notifications settings, I get the following message:

"Browser notifications are unsupported. This browser doesn't support web notifications."

I've done some research, and found a post on the Mozilla support forums suggesting I change my settings for popups and notifications. I've manually set to allow Twitter (http and https domains) for both of those, but I still get the same message from the settings page. I've also set dom.webnotifications.serviceworker.enabled and dom.webnotifications.enabled as "true". Browser notifications do work for other websites.

Všetky odpovede (2)

more options

Hi, several things all related, some are for turning off, reverse it :

WEBSITE PUSH NOTIFICATIONS

Websites can ask you to accept several different kinds of communications and updates:

  • Desktop notifications - if allowed, the site can send notifications for Firefox to display in the lower corner of your screen until you close the last tab for a site.
  • Web push notifications - if allowed, the site can send desktop notifications for Firefox to display in the lower corner of your screen even after the last tab for the site is closed (until you exit Firefox).
  • Web push updates - if allowed, the site can send Firefox updates in the background, which presumably is more efficient that forcibly refreshing a page or having a script in the page keep checking for updates. This push feature is NOT a desktop notification, but Firefox may use the notification permission panel, which I hope will be changed in the future since that's a bit confusing.

Site-Specific Permissions/Blocks

If the drop-panel is not available or does not work for you, while viewing the site where you want to modify a previously given permission, you can use the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click (on Mac, Ctrl+click) a blank area of the page and choose View Page Info > Permissions

(menu bar) Tools menu > Page Info > Permissions or click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Session Do Not Disturb

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content

Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box. This is for your current session only.

All-Site Persistent Disable

There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

(5) To also disable BACKGROUND UPDATES, double-click the dom.push.enabled preference to switch its value from true to false -- but that may block actually useful services from sites you trust, so I don't recommend it at this point. (Note: you need to edit the text in the filter box above the list to display this preference.)

Troubleshooting: Site-Specific Permissions Are Forgotten?

Whether you enter a site permission through a drop-panel or the Page Info dialog, Firefox should remember your choice. If you are losing site-specific permissions, one possible reason is if Firefox is set to "Clear history" when it closes on the Options/Preferences page.

If you use that setting, check to the right of it for a Settings button. Click that, and make sure that "Site Preferences" is not checked -- when that's checked, you'll lose all your Allow/Block settings every time you close Firefox.

Troubleshooting: Pages still display a permission dialog

Website scripts can display pre-permission dialogs even if Firefox ultimately won't allow the services. This is beyond the control of Firefox, but possibly could be tamped down with add-ons.

GEO TRACKING __________________

What is Firefox asking you about trackers? That wording is not familiar.

Do you mean sites that want you to share your location? If you do not want Firefox asking you when it gets that kind of request from a site, you can set Firefox to Block location access by default. Then if you know a site wants precise location and you WANT to share with that site, you can set a site exception.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste geo and pause while the list is filtered

(3) Double-click the permissions.default.geo preference and enter the value for the desired default behavior:

  • 0 = Always Ask (default)
  • 1 = Allow
  • 2 = Block

A site-specific exception can be established using either (A) the Page Info dialog, while you are on the site, or (B) the Settings dialog on the Options page.

Permissions panel of the Page Info dialog

While you're on the site, you can call that up using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Near the top, you'll find "Access Your Location" and you can uncheck the "Use default" box and select the permission you prefer.

Settings dialog

I suggest adding an exception through the Page Info method first so you can see the pattern for entering sites here. Then:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type locat and Firefox should filter to the "Permissions" section. Click the Settings button next to Location.

more options

Hi, a couple of your adblockers may suspend your work. Privacy Badger & uBlock Origin

To find out  : TEST in Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

  • Your Security Software could also be stopping this, please check you Firewall Logs for any information