Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Show Bookmarks first in urldropdown and then history and google suggestion.

  • 5 odpovedí
  • 2 majú tento problém
  • 515 zobrazení
  • Posledná odpoveď od Tarun Boyella

more options

I am using Latest Firefox Quantum 60.0.1. I have hundreds of bookmark links.

When I type something in address bar .. the suggestion which come in url bar dropdown is kind of jumbled ... I get 2 or 3 suggestions from Bookmark first and then next few lines are history, good suggestions and then I get bookmarks again .. so I have to scroll down the url dropdown bar when I type in something to check the bookmark links matching my search keyword ...

I would like to know if there is a way to have firefox first load bookmarks which match the keyword search and then the history and good suggestions. Do we have to tweak some settings in about:config or is there a custom userchrome,css code which I can use. I am already using userchrome.css for other customizations.

Let me know on this.

I am using Latest Firefox Quantum 60.0.1. I have hundreds of bookmark links. When I type something in address bar .. the suggestion which come in url bar dropdown is kind of jumbled ... I get 2 or 3 suggestions from Bookmark first and then next few lines are history, good suggestions and then I get bookmarks again .. so I have to scroll down the url dropdown bar when I type in something to check the bookmark links matching my search keyword ... I would like to know if there is a way to have firefox first load bookmarks which match the keyword search and then the history and good suggestions. Do we have to tweak some settings in about:config or is there a custom userchrome,css code which I can use. I am already using userchrome.css for other customizations. Let me know on this.

Vybrané riešenie

It's normal for bookmark, history, and open tab suggestions to get mixed together based on the computed frecency rating. There is an about:config setting to determine where search engine suggestions appear (above vs. below), but I'm not aware of any setting to detangle bookmarks, history, and open tabs.

While you can use CSS to regroup the items visually, the underlying order is not changed, so when you down arrow, the bar skips around. If you use the mouse, that may not be annoying to you...

  /* switch tab, then bookmarks, then history */
  #PopupAutoCompleteRichResult .autocomplete-richlistitem[type="switchtab"]{
    -moz-box-ordinal-group: 2;
  }
  #PopupAutoCompleteRichResult .autocomplete-richlistitem[type="bookmark"]{
    -moz-box-ordinal-group: 3;
  }
  #PopupAutoCompleteRichResult .autocomplete-richlistitem[type="favicon"]{
    -moz-box-ordinal-group: 4;
  }
Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (5)

more options

Hi, please pull your userchrome.css folder out and try Firefox with out please. I suspect the behaviour is from userChrome and some code Firefox does not like. If you have had the code since before version 60 I suggest you look for updated code.

Let us know if that fixed the issue.

more options

Vybrané riešenie

It's normal for bookmark, history, and open tab suggestions to get mixed together based on the computed frecency rating. There is an about:config setting to determine where search engine suggestions appear (above vs. below), but I'm not aware of any setting to detangle bookmarks, history, and open tabs.

While you can use CSS to regroup the items visually, the underlying order is not changed, so when you down arrow, the bar skips around. If you use the mouse, that may not be annoying to you...

  /* switch tab, then bookmarks, then history */
  #PopupAutoCompleteRichResult .autocomplete-richlistitem[type="switchtab"]{
    -moz-box-ordinal-group: 2;
  }
  #PopupAutoCompleteRichResult .autocomplete-richlistitem[type="bookmark"]{
    -moz-box-ordinal-group: 3;
  }
  #PopupAutoCompleteRichResult .autocomplete-richlistitem[type="favicon"]{
    -moz-box-ordinal-group: 4;
  }
more options

Hi, Thanks for the response.

Adding the entries suggested to userchrome.css definitely helped.

One issue I have is .. the suggestion which come from Google are showing a ahead of the Bookmarks. For e.g. if I type "known" keyword I want my bookmarks to show first, Instead I see google suggestions like "known traveler" etc and then my bookmarks which have "known" keyword grouped. Is there a way to change this behavior?

I tried setting 1,2,3 for switchtab, bookmark and favicon .. that did not help.

more options

To move the search suggestions lower, there's a checkbox on the Options/Preferences page in Firefox 60:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Search. In the "Default Search Engine" section, look for this item and uncheck the box:

Show search suggestions ahead of browsing history in address bar results

Does that fix it?

more options

Thanks!! That solves my issue.