Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

navigation arrows show in fullscreen videos

  • 10 odpovedí
  • 1 má tento problém
  • 344 zobrazení
  • Posledná odpoveď od HonoredShadow

more options

This happens on Steam videos and Youtube. I think it happens elsewhere too. This has been happening for 6 months or more.

If I have Firefox maximised and watch a video in YouTube and then double click on the video and it goes full-screen (not browser F11 full-screen) then I see the arrows in the first picture in the video window. This happens on Steam vids when full-screen also.

If I then make Firefox go full-screen mode (F11) then double click on a YouTube (or Steam) video to make it full screen I see no navigation arrows.

Any idea how to fix this?

I have tried disabling all the add-ons and restarting but still does it.

Thanks for any help.

Priložené obrázky

Vybrané riešenie

I think that rule was meant for F11 fullscreen and not media fullscreen, but it may be affecting both.

Try hiding that userChrome.css file from Firefox by renaming it to

userChromeOLD.css

At the next startup, Firefox won't see it and you probably won't miss it.

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (10)

more options

Hmm, those look like icons from the tabs bar: the left scrolling button (<) overlaid with the new tab (+) followed by the right scrolling button (>) overlaid with the all tabs button (v). Collapsed into a jumble as though someone yanked the tabs out and left the buttons. Bizarre.

Obviously the entire tab bar should be hidden in video fullscreen. So, what's going on here...

Do the buttons actually do anything?

If you move that tab to a new window before fullscreening the video, do you see any difference?

Normally I would suspect a custom style rule in a userChrome.css file that modifies the appearance of the tabs bar. However, if you tested in Firefox's Safe Mode and it still happened, then that's probably not it.

Puzzled.

more options

Thank you so much for the reply!

Yes they are the buttons you mentioned. They don't do anything when in video full-screen (not FF F11).

I moved a video like you said to a new windows and same thing happens.

I did not test in safe mode. I just disabled all add-ons manually and restarted manually. Will try that now and edit this post...

EDIT: I clicked top right 3 lines icon and clicked restart with addons disabled. When FF restarted it asked me if I would like to go into safemode which I did and the issue is gone. But if I disable the addons manually and restart but NOT in safemode I see the arrows again.

Upravil(a) HonoredShadow dňa

more options

Other effects of safe mode:

(1) Disable Firefox from using hardware acceleration

This can be manually changed on the Options/Preferences page to test it specifically. See: Firefox's performance settings.

(2) Disable userChrome.css and userContent.css modifications

You need to set these up manually, so you probably would remember if you have any. If you're not sure, you can check via the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Do you have a folder named chrome here? If not, then no need to check further.

If you do have a chrome folder, double-click into that and check whether you have a userChrome.css file (the .css is hidden by default, so you might not see the extension).

more options

I disabled hardware acceleration and restarted with addons enabled and still see the arrows. Put the acceleration settings back to default.

I found the chrome folder and it does have a userChrome.css file but I did not set that up or put it there.

EDIT: I moved the Chrome folder with the userChrome.css to my desktop so I can move it back again no problem, restared FF and still have addons enabled and amazingly the arrows are gone in video fullscreen (not FF F11).

I could share the userChrome if it's safe to do so? If it's not tell me to remove below:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* full screen toolbars */

  1. navigator-toolbox[inFullscreen] toolbar:not([collapsed="true"]) {
  visibility:visible!important;

}

Upravil(a) HonoredShadow dňa

more options

Vybrané riešenie

I think that rule was meant for F11 fullscreen and not media fullscreen, but it may be affecting both.

Try hiding that userChrome.css file from Firefox by renaming it to

userChromeOLD.css

At the next startup, Firefox won't see it and you probably won't miss it.

more options

I will put back the folder and rename as you say.

Thank you so much for your help. That has been a bain for what seems like an age!

As a side question, do you know how I can see the Windows taskbar to slide up to be visible when FF is in F11 full-screen? Would be great if I could be in full-screen to get back screen space but still be able to slide the Windows taskbar up if I mouse down there. Atm I have the Windows taskbar to slide up in non full-screen see.

Thanks again!

more options

I think using a Beta release should be only for testing purpose not everyday usage. Your listing say FF60beta.

more options

I don't think the fact that the version of FF I'm using caused this issue. I had this issue in non beta version until I tried the beta to see if it would fix the issue, which it did not.

more options

HonoredShadow said

As a side question, do you know how I can see the Windows taskbar to slide up to be visible when FF is in F11 full-screen? Would be great if I could be in full-screen to get back screen space but still be able to slide the Windows taskbar up if I mouse down there. Atm I have the Windows taskbar to slide up in non full-screen see.

I don't think full screen has a feature to show the Windows Taskbar; everything outside of Firefox is covered. I don't think an add-on could change that. Maybe an external program could do it with a hotkey, sort of like "picture-in-picture"?

more options

Oh well. Worth asking!

Thank you so much for your help. Will mark this as solved. Take care Mr jscher2000 ;)