X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Bksp key doesn't work, only on Facebook and only with Firefox :(

Pridané

After the last Firefox update, when I clicked on bkspace, it would take me back to the previous webpage. Happened on both Firefox and Chrome (laptop with Win10, all current/updated, as well as flash). Following (from 2012) Mozilla community support instructions, went into about:config and dbl clicked on browser.backspace_action and changed value from 0 to 2. This stopped the problem everywhere but Firefox on Facebook (I make sure cursor is flashing in a text box, trying to post, comment on another post or typing in messenger). The backspace key does nothing, just sits there. I type a lot...and trying to correct typos is a nightmare! I don't know if this is Firefox related, or Facebook. Have reported it to Facebook every day, but thats like beating my head against a wall, ugh! Help!?!

After the last Firefox update, when I clicked on bkspace, it would take me back to the previous webpage. Happened on both Firefox and Chrome (laptop with Win10, all current/updated, as well as flash). Following (from 2012) Mozilla community support instructions, went into about:config and dbl clicked on browser.backspace_action and changed value from 0 to 2. This stopped the problem everywhere but Firefox on Facebook (I make sure cursor is flashing in a text box, trying to post, comment on another post or typing in messenger). The backspace key does nothing, just sits there. I type a lot...and trying to correct typos is a nightmare! I don't know if this is Firefox related, or Facebook. Have reported it to Facebook every day, but thats like beating my head against a wall, ugh! Help!?!

Vybrané riešenie

Hi KateyKate, I was recently reminded of a permissions bug related to the Backspace and Delete keys. Could you check this setting:

General Setting

Since you only have the problem on one site, this probably isn't customized, but just in case:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste shortc and pause while the list is filtered

(3) If the permissions.default.shortcuts preference is bolded and "modified" or "user set" to some value other than zero, right-click > Reset to restore the default value

Site-Specific Setting

While you are on Facebook, call up the Permissions panel of the Page Info dialog using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to the "Override Keyboard Shortcuts" permission and make sure it has "Use default" checked.

If you made any changes, did that help?

Čítať túto odpoveď v kontexte 1

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • Shockwave Flash 29.0 r0

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

Viac informácií

Tonnes
  • Locale Leader
246 riešení 1454 odpovedí

Regardless of the browser.backspace_action setting, you can check to see if an add-on is responsible by running Firefox in Safe Mode or disabling them one by one. Also see this question. Perhaps this thread may be helpful too.

Regardless of the browser.backspace_action setting, you can check to see if an add-on is responsible by running Firefox in [[Troubleshoot Firefox issues using Safe Mode|Safe Mode]] or disabling them one by one. Also see [/questions/1066651 this question]. Perhaps [https://www.facebook.com/help/community/question/?id=321470511381618 this thread] may be helpful too.

Autor otázky

Thanks for the reply...the only extensions I have are Adblock Plus, Ebates cashback button and Honey. I've had all three for over a year with no prior issues. I did disable each of them and tried text in Facebook...backspace still did nothing :(

Thanks for the reply...the only extensions I have are Adblock Plus, Ebates cashback button and Honey. I've had all three for over a year with no prior issues. I did disable each of them and tried text in Facebook...backspace still did nothing :(
Shadow110 1072 riešení 14836 odpovedí

Hi, please try in SAFE MODE as it does a few things more than just disable.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Hi, please try in SAFE MODE as it does a few things more than just disable. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ?

Autor otázky

Thanks for the help, I tried Firefox in safe mode, still no bksp key :(

Thanks for the help, I tried Firefox in safe mode, still no bksp key :(
jscher2000
  • Top 10 Contributor
8695 riešení 71066 odpovedí

Could you double-check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste CLIPB and pause while the list is filtered

(3) If the dom.event.clipboardevents.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

If you changed that, any improvement?

(Users have reported problems pasting and editing comments on FB when that setting is customized.)

Could you double-check this setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''CLIPB''' and pause while the list is filtered (3) If the '''dom.event.clipboardevents.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true If you changed that, any improvement? (Users have reported problems pasting and editing comments on FB when that setting is customized.)

Autor otázky

Hi jscher, thanks for the suggestion :) I followed your instructions and when I checked dom.event.cipboardevents.enabled, it was already set at true: "default boolean true" Not sure if this matters, the bksp key does nothing when I'm typing in a messenger box, commenting on a post or creating a post...nothing pasted or edited. I did just try to edit a comment I'd made previously, then tried pasting a link and hit bksp....neither worked, cursor didn't move :(. This seems like such a small thing, but I do a lot of typing and am surprised at just how much I use bksp for typos! :(

Hi jscher, thanks for the suggestion :) I followed your instructions and when I checked dom.event.cipboardevents.enabled, it was already set at true: "default boolean true" Not sure if this matters, the bksp key does nothing when I'm typing in a messenger box, commenting on a post or creating a post...nothing pasted or edited. I did just try to edit a comment I'd made previously, then tried pasting a link and hit bksp....neither worked, cursor didn't move :(. This seems like such a small thing, but I do a lot of typing and am surprised at just how much I use bksp for typos! :(
Murphy 20 riešení 264 odpovedí

Hi KateyKate,

Would you check this pref on the about:config page :

browser.backspace_action

(Type in the search bar browser.backspace)

The default value should be set to 0 (= zero)

Hi KateyKate, Would you check this pref on the '''about:config''' page : '''browser.backspace_action''' (Type in the search bar '''browser.backspace''') The default value should be set to '''0''' (= zero)

Autor otázky

Hi Murphy :), thanks for the suggestion. I mentioned changing the value from 0 to 2 in my original question above...at 0 hitting the bksp key backed up the webpage to the previous one, and it occurred on both Firefox and Chrome. When I changed it to 2, the bksp key worked as it used to, simply backing up one space, everywhere I tried it on Chrome, and everywhere except in "text mode" on Facebook using Firefox. The instructions I followed from here were from 2012...that was the most recent answer I could find at the time...I should try changing it back to 0 again? :)

Hi Murphy :), thanks for the suggestion. I mentioned changing the value from 0 to 2 in my original question above...at 0 hitting the bksp key backed up the webpage to the previous one, and it occurred on both Firefox and Chrome. When I changed it to 2, the bksp key worked as it used to, simply backing up one space, everywhere I tried it on Chrome, and everywhere except in "text mode" on Facebook using Firefox. The instructions I followed from here were from 2012...that was the most recent answer I could find at the time...I should try changing it back to 0 again? :)
Murphy 20 riešení 264 odpovedí

KateyKate said

Hi Murphy :), thanks for the suggestion. I mentioned changing the value from 0 to 2 in my original question above...

Oops - I missed that .....

I hate it when that happens - my apologies  !

''KateyKate [[#answer-1108482|said]]'' <blockquote> Hi Murphy :), thanks for the suggestion. I mentioned changing the value from 0 to 2 in my original question above... </blockquote> Oops - I missed that ..... I hate it when that happens - my apologies !
jscher2000
  • Top 10 Contributor
8695 riešení 71066 odpovedí

Is this some obscure setting we can't think of? I hate when that happens. To try with uncustomized settings, we often suggest:

New Profile Test

This takes about 3 minutes, plus the time to test Facebook.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like May2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. If Firefox asks you to sign in or activate extensions it found, ignore those suggestions so we can get a clean test.

Does the backspace key work any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

Is this some obscure setting we can't think of? I hate when that happens. To try with uncustomized settings, we often suggest: '''New Profile Test''' This takes about 3 minutes, plus the time to test Facebook. Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Click the Create a New Profile button, then click Next. Assign a name like May2018, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Set as default profile''' button below that profile, then scroll back up and click the '''Restart normally''' button. (There are some other buttons, but please ignore them.) Firefox should exit and then start up using the new profile, which will just look brand new. If Firefox asks you to sign in or activate extensions it found, ignore those suggestions so we can get a clean test. ''Does the backspace key work any better in the new profile?'' When you are done with the experiment, open the about:profiles page again, click the '''Set as default profile''' button for your normal profile, then click the '''Restart normally''' button to get back to it.

Autor otázky

Lol no worries, Murphy....I'm actually surprised I even remembered that! :) Jscher, I'm off to try the profile thingie..eek!

Lol no worries, Murphy....I'm actually surprised I even remembered that! :) Jscher, I'm off to try the profile thingie..eek!

Autor otázky

Jscher...I knew it would only be a matter of time before I panicked and likely didn't do things as instructed..lol!

I created the new profile and clicked set as default, then clicked restart normally. The page that opened had MSN all over it, with none of my toolbar shortcuts, lol just freaked me out not seeing all of my crutches. I was able to get to the facebook login page, but I realized without logging in, I wouldn't be able to get to the "text" boxes (create post, messenger, comments, etc) without logging into FB. I did try typing in the "name" box for FB login, and was able to bksp, it did work there! Thinking I needed to get back here to let you know, I changed the orig profile back to default, clicked restart normally then clicked start in new browser. If I've managed to confuse you as much as I have myself....I guess all this random babble should simply be: can't get to the "test areas" of Facebook using the new profile without logging in (instructions said to ignore?), bksp key did work on new profile in the login boxes, but now that I'm back on the original profile, bksp doesn't work. Whatta mess I've made! If I can sign in to FB under the new profile, do I need to create another new one before trying that? I'm so sorry for the mass confusion...but its what I do best :(

Jscher...I knew it would only be a matter of time before I panicked and likely didn't do things as instructed..lol! I created the new profile and clicked set as default, then clicked restart normally. The page that opened had MSN all over it, with none of my toolbar shortcuts, lol just freaked me out not seeing all of my crutches. I was able to get to the facebook login page, but I realized without logging in, I wouldn't be able to get to the "text" boxes (create post, messenger, comments, etc) without logging into FB. I did try typing in the "name" box for FB login, and was able to bksp, it did work there! Thinking I needed to get back here to let you know, I changed the orig profile back to default, clicked restart normally then clicked start in new browser. If I've managed to confuse you as much as I have myself....I guess all this random babble should simply be: can't get to the "test areas" of Facebook using the new profile without logging in (instructions said to ignore?), bksp key did work on new profile in the login boxes, but now that I'm back on the original profile, bksp doesn't work. Whatta mess I've made! If I can sign in to FB under the new profile, do I need to create another new one before trying that? I'm so sorry for the mass confusion...but its what I do best :(
jscher2000
  • Top 10 Contributor
8695 riešení 71066 odpovedí

Sorry for the confusion, I meant if Firefox suggested you create or log into a Firefox Account, to skip that. It's normal not to be able to do much in Facebook if you don't log in, and you can return to the May2018 profile and log into FB.

Probably the reason for all the MSN stuff was that Firefox grabbed it from Internet Explorer. So... not a mess, still on track.

Sorry for the confusion, I meant if Firefox suggested you create or log into a Firefox Account, to skip that. It's normal not to be able to do much in Facebook if you don't log in, and you can return to the May2018 profile and log into FB. Probably the reason for all the MSN stuff was that Firefox grabbed it from Internet Explorer. So... not a mess, still on track.

Autor otázky

No worries, jscher, thanks for your patience :). I switched back to the new profile and didn't even have to log in to Facebook, panic caused me to save the login and when I entered www.facebook.com, it opened my home page in FB, ready to roll! Not sure if its good or bad news, but while in the new profile, the bksp key came back, working perfectly to backspace one space as needed! I'm afraid to hear whats next...lol!

Just curious...when about:profiles opened, there was my default profile, along with a Root Directory and Local Directory listed...do I even want to know what those are about, or is the world in general safer with me not knowing?  :)

No worries, jscher, thanks for your patience :). I switched back to the new profile and didn't even have to log in to Facebook, panic caused me to save the login and when I entered www.facebook.com, it opened my home page in FB, ready to roll! Not sure if its good or bad news, but while in the new profile, the bksp key came back, working perfectly to backspace one space as needed! I'm afraid to hear whats next...lol! Just curious...when about:profiles opened, there was my default profile, along with a Root Directory and Local Directory listed...do I even want to know what those are about, or is the world in general safer with me not knowing? :)
jscher2000
  • Top 10 Contributor
8695 riešení 71066 odpovedí

Since the new profile works normally with Facebook, there's probably a setting or some site data in the old profile that causes the problem. But what setting or data... that is the mystery.

Firefox profiles have two folders: the root folder has the valuable stuff like bookmarks and passwords, the local folder has temporary files like cache. You don't need to go in there when Firefox is working normally unless you want to back something up.

Since the new profile works normally with Facebook, there's probably a setting or some site data in the old profile that causes the problem. But what setting or data... that is the mystery. Firefox profiles have two folders: the root folder has the valuable stuff like bookmarks and passwords, the local folder has temporary files like cache. You don't need to go in there when Firefox is working normally unless you want to back something up.

Autor otázky

Thanks, jscher...I'm not too worried about what exactly causes the problem, unless I need to know in order to fix it....or, is there a fix? I'm imagining going back to the very beginning...with nothing I've added or fixed or changed..nooooo? lol I'll do whatever it takes, this is driving me craaaaazy!

Thanks, jscher...I'm not too worried about what exactly causes the problem, unless I need to know in order to fix it....or, is there a fix? I'm imagining going back to the very beginning...with nothing I've added or fixed or changed..nooooo? lol I'll do whatever it takes, this is driving me craaaaazy!
jscher2000
  • Top 10 Contributor
8695 riešení 71066 odpovedí

Okay, let's review the case history:

In your regular profile, you have this terrible choice:

  • Keep the default backspace action -- should only go "Back" when not in an editing field -- but it goes Back when working in editing fields
  • Kill the default backspace action, but then you can't use backspace in FB editing fields

In the new profile, the default backspace action works as designed.

Is that correct?

So something is affecting how Firefox works with editing fields in your regular profile. But that something is not an add-on, or Safe Mode would have restored normal behavior. What is the something...

Could you try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste forms and pause while the list is filtered

Any modified settings here? You can right-click > Copy and then paste into a reply to share the current setting.

(3) In the search box above the list, type or paste edit and pause while the list is filtered

Any modified settings here?

(4) In the search box above the list, type or paste key and pause while the list is filtered

Any modified settings here?

Okay, let's review the case history: In your regular profile, you have this terrible choice: * Keep the default backspace action -- should only go "Back" when not in an editing field -- but it goes Back when working in editing fields * Kill the default backspace action, but then you can't use backspace in FB editing fields In the new profile, the default backspace action works as designed. Is that correct? So ''something'' is affecting how Firefox works with editing fields in your regular profile. But that something is not an add-on, or Safe Mode would have restored normal behavior. What is the something... Could you try this: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''forms''' and pause while the list is filtered ''Any modified settings here?'' You can right-click > Copy and then paste into a reply to share the current setting. (3) In the search box above the list, type or paste '''edit''' and pause while the list is filtered ''Any modified settings here?'' (4) In the search box above the list, type or paste '''key''' and pause while the list is filtered ''Any modified settings here?''

Autor otázky

Hello Jscher...I apologize for the delay in getting back to you, back and trying to focus..lol.

Regular profile - 1st option. I'm not sure I understand the explanation, but bksp does nothing in Facebook using Firefox after editing the value from 0 to 2 in about:config. Outside of editing functions on FB, bksp does nothing, it also does nothing inside of editing functions. On Chrome, bksp does not take me back to the previous webpage (I can live with that!), and works as designed while creating or commenting on a post. (is that the answer you were looking for?) Off to try your suggestions now, thanks!

Hello Jscher...I apologize for the delay in getting back to you, back and trying to focus..lol. Regular profile - 1st option. I'm not sure I understand the explanation, but bksp does nothing in Facebook using Firefox after editing the value from 0 to 2 in about:config. Outside of editing functions on FB, bksp does nothing, it also does nothing inside of editing functions. On Chrome, bksp does not take me back to the previous webpage (I can live with that!), and works as designed while creating or commenting on a post. (is that the answer you were looking for?) Off to try your suggestions now, thanks!

Autor otázky

Ok, under Forms, this is the only line that is modified: dom.forms.autocomplete.formautofill;true part of the line that didn't copy: modified boolean true

Edit: the only modified line in this group: pref.downloads.disable_button.edit_actions;false part of the line that didn't copy: modified boolean false

Key: two modified lines: extensions.adblockplus.recentReports;[{"site":"www.picmonkey.com","reportURL":"https://reports.adblockplus.org/1e4e40c5-e5b7-4986-91d2-7f494a9d65c6","time":1455668374082}] part of the line that didn't copy: modified string and: ui.osk.debug.keyboardDisplayReason;IKPOS: Touch screen not found. part of the line that didn't copy: modified string

You likely know the headings for the words that weren't included when I copied the lines, but just in case, Status and Type.

I think thats all of them, thanks so much for your help!

Ok, under Forms, this is the only line that is modified: dom.forms.autocomplete.formautofill;true part of the line that didn't copy: modified boolean true Edit: the only modified line in this group: pref.downloads.disable_button.edit_actions;false part of the line that didn't copy: modified boolean false Key: two modified lines: extensions.adblockplus.recentReports;[{"site":"www.picmonkey.com","reportURL":"https://reports.adblockplus.org/1e4e40c5-e5b7-4986-91d2-7f494a9d65c6","time":1455668374082}] part of the line that didn't copy: modified string and: ui.osk.debug.keyboardDisplayReason;IKPOS: Touch screen not found. part of the line that didn't copy: modified string You likely know the headings for the words that weren't included when I copied the lines, but just in case, Status and Type. I think thats all of them, thanks so much for your help!
jscher2000
  • Top 10 Contributor
8695 riešení 71066 odpovedí

Hi KateyKate:

dom.forms.autocomplete.formautofill -- mine is true, too, so that by itself probably doesn't cause this problem

pref.downloads.disable_button.edit_actions -- mine is false, too, so that by itself probably doesn't cause this problem

extensions.adblockplus.recentReports -- I double that ABP causes the problem or it would be affecting a lot of people here on the forum

ui.osk.debug.keyboardDisplayReason = IKPOS: Touch screen not found -- "osk" refers to an on-screen keyboard.

Do you have a tablet or a touchscreen? That sometimes confuses Firefox. To make sure Firefox isn't try to use an on-screen keyboard you could disable that feature:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste osk and pause while the list is filtered

(3) Double-click the ui.osk.enabled preference to switch the value from true to false

That might not help; it could be something else altogether that just is not coming to mind.

You might consider using the Refresh feature -- removes add-ons and custom settings -- or selectively moving data files to the new (working) profile.

Hi KateyKate: dom.forms.autocomplete.formautofill -- mine is true, too, so that by itself probably doesn't cause this problem pref.downloads.disable_button.edit_actions -- mine is false, too, so that by itself probably doesn't cause this problem extensions.adblockplus.recentReports -- I double that ABP causes the problem or it would be affecting a lot of people here on the forum ui.osk.debug.keyboardDisplayReason = IKPOS: Touch screen not found -- "osk" refers to an on-screen keyboard. Do you have a tablet or a touchscreen? That sometimes confuses Firefox. To make sure Firefox isn't try to use an on-screen keyboard you could disable that feature: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''osk''' and pause while the list is filtered (3) Double-click the '''ui.osk.enabled''' preference to switch the value from true to false That might not help; it could be something else altogether that just is not coming to mind. You might consider using the Refresh feature -- removes add-ons and custom settings -- or selectively moving data files to the new (working) profile.