Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

email link will not open in firefox

  • 9 odpovedí
  • 1 má tento problém
  • 21 zobrazení
  • Posledná odpoveď od FredMcD

more options

I use Thunderbird. I checked and Thunderbird is designated in my mailto action.

Today I clicked on the same email, clicked on the same link, and it opened in FireFox.

When I first got the email and it would not open in FireFox I right clicked on the link, clicked on "Copy Link Location" and pasted it to open the link.

Can you tell me what is going on?

This is not the first time this has occurred.

Všetky odpovede (9)

more options

Windows may lose the default browser setting for opening URLs in emails after an update. Therefor try changing your default browser to another browser in Windows, then restore Firefox to be the default browser. Restart Thunderbird if needed. Also see Hyperlinks in Messages Not Working.

Remember this is not a matter of the mailto action, but the default browser for your OS.

more options

Another is that the link is not a real link, or not recognized as such.

more options

Today the same link opened in FireFox from the email it would not open from the other day.

more options

Start Thunderbird in Safe Mode {web link} Is the problem still there?

Upravil(a) FredMcD dňa

more options

Let me make sure you understand.

I have FireFox and Thunderbird.

I received an email that had a link. When I clicked on the link nothing happened. This has occurred before with other emails.

I copied the link and inserted into FireFox. The web page opened. In the web page there was a link for a coupon. When I clicked on the link in FireFox nothing happened. This has also happened before.

I then inserted the link, from Thunderbird into Internet Explorer, the web page opened. I clicked on the web page link, for the coupon, and it opened. I printed the coupon from Internet Explorer.

I still have the email. I opened the email this morning, clicked on the email link, the web page opened in FireFox, I clicked on the coupon link in FireFox, and the coupon was displayed.

My question is why did it not work the day I received the email and why did it work today?

I am just highlighting one web page. This has occurred on others.

My ISP provider provides internet, phone, and cable TV. I had a voice mail I wanted to download.

I opened the ISP's web page, clicked on the voice mail and it did not download. I did the same thing in Internet Explorer and it worked.

Today I tried the same thing with FireFox again. The same voice mail that would not open earlier opened today.

more options

Please provide feedback on helper suggestions and reply to their questions rather than (or in addition to) repeating something doesn’t work, or they may lose interest in helping out here.

Did you switch default browsers twice, and if you did, did it help each time, even for a short while?

more options

If you will tell me where "helper suggestions" is located I use that. I got an email and I clicked on "This doesn't solve my problem". I thought that was the correct link. I am clicking on a link that is labeled "Post Reply".

I never did switch default browsers.

FireFox is my default browser. I opened Internet Explorer and pasted the URL that I copied from Thunderbird.

Unless you consider manually opening Internet Explorer from a link as switching default browsers I never switched.

more options

Helper suggestions are responses like these asking you to take some steps or to have a look at a support article. These emails are not sent to the helpers, nor to others, so it’s useful to follow up here.

Try switching default browsers twice, as your OS just seems to forget it. Copying and pasting a link should always work and provides no info. In case switching default browsers does not help, uninstall and reinstall Firefox from www.mozilla.org/firefox/all. You should not lose any settings.

more options

Tonnes said

Try switching default browsers twice

What Tonnes means is; Open Windows Internet Explorer. Have it declared as the default browser, But turn off the option to check this when the browser opens (If you want).

Now do the same thing using Firefox.

https://support.mozilla.org/en-US/kb/how-make-web-links-open-firefox-default

https://support.mozilla.org/en-US/kb/setting-firefox-default-browser-does-not-work