Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 59 breaks password manager

  • 6 odpovedí
  • 2 majú tento problém
  • 331 zobrazení
  • Posledná odpoveď od Tonnes

more options

Firefox 59 shows no saved passwords and no master password. When I try to add a master password it reports that I can't. Rolling back to Firefox 57 solves the problem. Fedora 27

Upravil(a) sotirone dňa

Vybrané riešenie

Good find. The file stores the security module configuration. In addition to pkcs11.txt, the secmod.db file may need to be deleted too. Required files should be created or retrieved automatically when needed. Fwiw, the issue may be related to a change in the database format.

Other questions that may be useful: one, two

More info: here and here.

Also see Profiles - Where Firefox stores your bookmarks, passwords and other user data.

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (6)

more options

I’m afraid you are suffering this bug that’s currently being worked on.

You should be able to work around it by toggling the security.enterprise_roots.enabled preference to false in about:config in case it is set to true, if your system or environment allows it.

If the issue occurs on Windows and on another machine (since the user agent for your question reports 57 Beta on Linux), note that this could happen if you have AVG installed, in which case disabling both its Web Shield and Email Shield may help (see the bug).

more options

Tonnes said

I’m afraid you are suffering this bug that’s currently being worked on. You should be able to work around it by toggling the security.enterprise_roots.enabled preference to false in about:config in case it is set to true, if your system or environment allows it. If the issue occurs on Windows and on another machine (since the user agent for your question reports 57 Beta on Linux), note that this could happen if you have AVG installed, in which case disabling both its Web Shield and Email Shield may help (see the bug).

Nope, I already had security.enterprise_roots.enabled set to false and cycling it does not change anything. It doesn't ask me for the master password at all. The 57 beta is correct as I made this post after downgrading.

Upravil(a) sotirone dňa

more options

sotirone said

Firefox 59 shows no saved passwords and no master password. When I try to add a master password it reports that I can't. Rolling back to Firefox 57 solves the problem. Fedora 27

Nothing wrong on my side of FF59.0.1 it saves my passwords and even ask me to save it. I don't use master password that would invite to much sticky fingers at home to go to sites they shouldn't go to.

more options

Can you reproduce this in 59.0.2 release, as well as in a new and clean profile? If you don’t want to add and test an additional profile, at least try Firefox’s Safe Mode or disable all add-ons one by one.

You could also try to delete the files cert8.db and cert9.db in your current profile folder and see if both the prompt and viewing work as expected from then on.

Note that this will remove any stored passwords so make sure to create a backup of your profile folder first, or create/add an additional one and copy the current profile’s contents over there (overwriting existing files) to test this with that specific new profile (or just write down / copy the credentials and paste them digitally).

more options

Tonnes said

Can you reproduce this in 59.0.2 release, as well as in a new and clean profile? If you don’t want to add and test an additional profile, at least try Firefox’s Safe Mode or disable all add-ons one by one. You could also try to delete the files cert8.db and cert9.db in your current profile folder and see if both the prompt and viewing work as expected from then on. Note that this will remove any stored passwords so make sure to create a backup of your profile folder first, or create/add an additional one and copy the current profile’s contents over there (overwriting existing files) to test this with that specific new profile (or just write down / copy the credentials and paste them digitally).

There is no 59.0.2 available yet for Fedora. After some experimenting with a new profile, I found that deleting the file pkcs11.txt fixes the problem. What is that file and should I delete it or not?

more options

Vybrané riešenie

Good find. The file stores the security module configuration. In addition to pkcs11.txt, the secmod.db file may need to be deleted too. Required files should be created or retrieved automatically when needed. Fwiw, the issue may be related to a change in the database format.

Other questions that may be useful: one, two

More info: here and here.

Also see Profiles - Where Firefox stores your bookmarks, passwords and other user data.