Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

How to force all searches to go to default search engine?

  • 4 odpovede
  • 2 majú tento problém
  • 32 zobrazení
  • Posledná odpoveď od ithinkihaveacat

more options

If I type `amazon [some word]` in the address bar and hit return, Firefox uses the Amazon site search engine, instead of Google. For example, if I type `amazon associates`, I get redirected to `https://www.amazon.co.uk/s/ref=nb_sb_noss?url=search-alias%3Daps&field-keywords=associates`. (See attachment.)

Other searches without the `amazon` prefix work as expected--I get the Google search results.

How can I force Firefox to always use Google, without exception? Google is set as my default search engine.

If I type `amazon [some word]` in the address bar and hit return, Firefox uses the Amazon site search engine, instead of Google. For example, if I type `amazon associates`, I get redirected to `https://www.amazon.co.uk/s/ref=nb_sb_noss?url=search-alias%3Daps&field-keywords=associates`. (See attachment.) Other searches without the `amazon` prefix work as expected--I get the Google search results. How can I force Firefox to always use Google, without exception? Google is set as my default search engine.
Priložené obrázky

Vybrané riešenie

hm, then the only explanation left afaik is that you may have a bookmark with the amazon keyword somewhere in your library that performs this search...

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (4)

more options

hi, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an (amazon) addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

That didn't help unfortunately. I actually don't have any add-ons installed, just a theme. I do use Firefox sync.

more options

Vybrané riešenie

hm, then the only explanation left afaik is that you may have a bookmark with the amazon keyword somewhere in your library that performs this search...

more options

Ah, you're right! Search through my bookmarks for "amazon" turned up one with the keyword "amazon"; deleting it fixed my problem--thanks!

I think this is exactly the same problem as https://support.mozilla.org/en-US/questions/1066931 BTW (didn't find it in my previous search) however it doesn't seem possible to link this question to that one, or post an answer there.