Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

unable to register service worker

  • 6 odpovedí
  • 2 majú tento problém
  • 1101 zobrazení
  • Posledná odpoveď od nosthertus

more options

I am developing a web application that requires the use of service worker from firebase messaging, before updating to firefox quantum version this was working fine, localhost was the url for testing and i also saw the correct results on the production url site, just after doing the update for quantum this stopped working and i don't quite know why it isn't working as firebase only throws a messaging saying that it is unable to register.

OS: Linux Debian/Ubuntu 16.04 x64 Browser: Firefox quantum 57.0 (64-bit)

Vybrané riešenie

After long sessions of tests, i have concluded that the reason why the service worker was failing might be due to some corrupted file when the browser was updated.

I have verified this conclusion and it is like i said, i formatted my desktop (needed it long ago anyways) and set all the updates to be triggered after fresh installation, then i tried if the service worker was functional on "localhost" like it used to before update and it is now functional again.

Probably the distro did not test something for updating the browser which might be the cause the service worker was not even able to be installed so thanks for your help anways

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (6)

more options

Hello, do you have an error code or something?

more options

smorele said

Hello, do you have an error code or something?

No, this works on Chrome, and it was working before quantum update

more options

See also the about:serviceworkers page and the Browser Console for error messages.

more options

cor-el said

See also the about:serviceworkers page and the Browser Console for error messages.

I have checked for the error messages and i get the error displayed in the attached image, the service worker file was not modified since i started having this issue. Again everything was working fine before the Quantum update and it works fine on latest version of Chrome.

I've forgotten to add information regarding to the system i am using in case this might be relevant to this error.

OS: Linux Debian/Ubuntu 16.04.1 x64 CPU: Intel I5-4440 3.10Ghz RAM: 8GB 1600Mhz

more options

Thanks for information complements. Have you tried to contact the Firebase community? You're maybe not alone having troubles in this same context. I googled a little and found some other issues like this one.

more options

Vybrané riešenie

After long sessions of tests, i have concluded that the reason why the service worker was failing might be due to some corrupted file when the browser was updated.

I have verified this conclusion and it is like i said, i formatted my desktop (needed it long ago anyways) and set all the updates to be triggered after fresh installation, then i tried if the service worker was functional on "localhost" like it used to before update and it is now functional again.

Probably the distro did not test something for updating the browser which might be the cause the service worker was not even able to be installed so thanks for your help anways