Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

No scroll bars. My FF version, 56.0.2 (64-bit)

  • 15 odpovedí
  • 1 má tento problém
  • 34 zobrazení
  • Posledná odpoveď od cor-el

more options

It appears the no scroll bar issue is web site specific. When I go to https://www.metart.com/ there are no scroll bars. I've also noticed that on other web sites, if I enter using an old version of the web site, I get no scroll bars as well.

Is this something I must contact each web site to correct this?

edit: unlinkified

It appears the no scroll bar issue is web site specific. When I go to https://www.metart<i></i>.com/ there are no scroll bars. I've also noticed that on other web sites, if I enter using an old version of the web site, I get no scroll bars as well. Is this something I must contact each web site to correct this? edit: unlinkified

Upravil(a) philipp dňa

Vybrané riešenie

dave47 said

I have another Mac computer I've not upgraded to the latest macOS. That computer is still running OS Sierra v 10.12.6. The scroll bars work fine in FireFox with that OS.

Aha, more search terms (10.13 and "High Sierra"). There is a bug on file which should be fixed in Firefox 57 that sounds like it is this problem: Firefox scrollbar has no thumb on some pages (on macOS 10.13?). Its impact is described as "Pages with a dark background will fail to show a scrollbar thumb." Is that were you notice the problem?

Firefox 57 is scheduled for release on November 14th, but usually there is a slow drip of automatic updates during the first several days to check for showstopper bugs, so if you do not get it right away, don't panic, that's normal. While you could jump ahead by installing Firefox Beta, I guess it depends on whether this issue is enough of a problem for you.

https://www.mozilla.org/firefox/channel/desktop/

Note: Beta is regenerated a regular intervals, so there's a reasonable chance the change is in the current "b12" version.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (15)

more options

I checked the link you posted and had no problem. Are you talking about Vertical or Horizontal scrolls?

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

more options

This did not solve the problem. After I performed your suggestions and found they did not help, I did the following:

  • Checked to see if problem occurred while using Safari, web site functioned as is should, (scroll bars present and working).
  • I opened FireFox using a second computer which is also using version 56.0.2, The web site has same problem, (no scroll bars).
  • Both computers are MacBook Pro-Retina. One computer is Mid 2012, the other is Mid 2015. Both computers are running macOS High Sierra, version 10.13.
  • I performed the same tests on a third computer, a MacBook, (the small 12" Early 2016), again, running macOS High Sierra V10.13. The results are the same, no scroll bars on the web site using FF 56.0.2, Safari is fine.
more options

Unfortunately, I do not have a Mac to test with.

Some sites have a responsive design that changes layout as you zoom or resize the window. If you make any change like that, do any scroll bars appear? (If so, perhaps a script in the site not properly measuring the screen in Firefox to realize that scroll bars are needed before getting that extra kick in the pants.)

more options

Hi, I tried resizing in every direction I could think of but still no scroll bars.

I am going to contact the site support and explain what's happening and see if they have had other complaints over this issue.

It is now Friday evening and their tech support is off for the weekend so it will probably some time next week before I hear back from them.

I will get back to you when I hear from them.

more options

Can you check on this page if there is a way to update your Video Card : https://support.amd.com/en-us/download

When you talk to them please point out that they have 25 errors on their homepage and some have to do with resizing. They are not following W3c.org (World Wide Web Consortium) that set standards for Browsers and web pages. Below are the errors in HTML : https://validator.w3.org/nu/?doc=https%3A%2F%2Fwww.metart.com%2F 84 CSS Errors : https://jigsaw.w3.org/css-validator/validator?uri=https%3A%2F%2Fwww.metart.com%2F&profile=css3&usermedium=all&warning=1&vextwarning=&lang=en

I would say this is why your having issues with the site.

Please let us know if this solved your issue or if need further assistance.

more options

@ dave47 :

This is a public forum   -   remove that link   !

And   never   post anything like this here again   !

Ever   !

Upravil(a) Happy112 dňa

more options

didn't seem to stop others from your support people from trying to help with the problem.

more options

"dave47 said

didn't seem to stop others from your support people from trying to help with the problem.

You say in your original post :

" I've also noticed that on other web sites "

Could you provide a link to one of those websites or are they in the
'same category'  ? In which case : don't, please.

Maybe wait till you hear from their tech support  ?

Upravil(a) Happy112 dňa

more options

jscher2000 said

Unfortunately, I do not have a Mac to test with. Some sites have a responsive design that changes layout as you zoom or resize the window. If you make any change like that, do any scroll bars appear? (If so, perhaps a script in the site not properly measuring the screen in Firefox to realize that scroll bars are needed before getting that extra kick in the pants.)

Hi jscher2000,

I've learned something else about this problem. I have another Mac computer I've not upgraded to the latest macOS. That computer is still running OS Sierra v 10.12.6. The scroll bars work fine in FireFox with that OS.

more options

Vybrané riešenie

dave47 said

I have another Mac computer I've not upgraded to the latest macOS. That computer is still running OS Sierra v 10.12.6. The scroll bars work fine in FireFox with that OS.

Aha, more search terms (10.13 and "High Sierra"). There is a bug on file which should be fixed in Firefox 57 that sounds like it is this problem: Firefox scrollbar has no thumb on some pages (on macOS 10.13?). Its impact is described as "Pages with a dark background will fail to show a scrollbar thumb." Is that were you notice the problem?

Firefox 57 is scheduled for release on November 14th, but usually there is a slow drip of automatic updates during the first several days to check for showstopper bugs, so if you do not get it right away, don't panic, that's normal. While you could jump ahead by installing Firefox Beta, I guess it depends on whether this issue is enough of a problem for you.

https://www.mozilla.org/firefox/channel/desktop/

Note: Beta is regenerated a regular intervals, so there's a reasonable chance the change is in the current "b12" version.

more options

Aha! It looks like you may have something there.

The main site has a dark window and I don't see a way to change it.

But, there are other sites on that network that have a white window and those do have scroll bars.

Other sites on the same network, that have dark windows, do not have scroll bars.

I will wait for FireFox 57. Thanks

more options

FredMcD said

I checked the link you posted and had no problem.

I had no (technical  !) problem with that link either - scrollbar was present.

more options

I think at least touchpad, or mouse wheel, or "magic mouse stroking" should still scroll the page, even if you can't see where you are vertically.

I wonder if this can be fixed "after the fact" when the page loads and you notice the problem? As a test, you could try a script to override a problem page's background color to light gray and see whether that helps. To perform the experiment, you could try this script in Firefox's Web Console:

var s=document.createElement('style'); s.appendChild(document.createTextNode('html,body{background-color:#ddd!important; background-image:none !important}')); document.body.appendChild(s);

What that does is (A) create a new style element (tag), (B) add a style rule that assigns a light background color and removes any background image, then (C) add the new element at the end of the document body. Because it is marked !important, it should override the built-in rules.

To run a script in the Web Console -- and of course, only run scripts you trust -- you can open the Web Console in the lower part of the tab using either:

  • "3-bar" menu button > Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
  • (Mac) Command+Alt+k ; (Windows) Ctrl+Shift+k

Then paste the script in the line at the bottom (next to the » character) and press Return to execute it. Any change?

Any effect is temporary until you reload the page.

more options

Hi,

I did notice scrolling still worked even without a "handle". That was what alerted me to the problem.

As for your temporary fix, that kind of fooling around is beyond me. I am certain I would make an error somewhere and mess up everything. I'm sure what you are saying would give it a temp fix but I'm afraid to try it.

I am satisfied waiting for V57.

Thanks

Thanks

more options

See also:

  • bug 1408701 - Firefox scrollbar has no thumb on some pages (on macOS 10.13?)

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)