Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

jpost.com freezes up using Firefox

  • 21 odpovedí
  • 1 má tento problém
  • 59 zobrazení
  • Posledná odpoveď od jeffreywilens

more options

Using Firefox 43.0.4 but this problem was present in earlier versions. When I read an article on the jpost.com website, once I start reading the comments section, Firefox inevitably locks up (usually after a minute or few minutes). Then Firefox eventually crashes unless the process is killed first by the user.

Microsoft Edge does not have this problem.

All Replies (20)

more options

Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.


Do you have NVidia’s network access manager or Forceware Network Manager software installed? Disable / remove it. https://support.mozilla.org/en-US/kb/connectivity-crashing-firefox-43-update

more options

Fred. No issues with plugins.

I do have Nvidia Control Panel but I'm not familiar with the other Nvidia products you mention.

Anyway, the problem is only on the jpost.com website and only when you start scrolling through comments. Do you have the same problem on your end?

more options

No, but I only checked one page. Do you have the problem with all pages?

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

I started Firefox in safe mode. Other websites worked fine, but when I went to JPOST.COM, the page would not even load. It was worse than before. Task Manager showed 15% CPU usage for over 2 minutes before I killed the process.

There is definitely a problem with this website. Did you try to read through the comments section, that usually triggers the hang.

more options

I've called the big guys to help you. Good luck.

more options

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

I created a new profile and also use a different computer to access the same web page and various articles. While all attempts experienced some sluggish performance because of the many ads (the kind that slide open and shut, pop up, etc.), the main problem with crashing was not repeated.

So I assume something in my profile is corrupted. But how do I know what to add back or keep? It is likely that bookmarks and favorites are okay to move over? I can just reinstall plug-ins, etc.

more options

Also would Adblock plus be the source of the problem?

more options

AdBlock Blocks ads and pop-ups. Sometimes it can go too far.

Load the web page. After the page is loaded, click the down arrow next to the AdBlock icon. Now select Disable on <web site>.

more options

Disabling AdBlock did not help. It does not appear that is the source of the problem but rather something in my Firefox profile.

more options

Follow Cor-el's instructions to create a new profile; https://support.mozilla.org/en-US/questions/1105559#answer-833314

Use it As Is. Is there any problem?

more options

No, as I posted above, there is no problem with a virgin profile. I just need to figure what to move over from my old profile.

more options

Warning ! ! Only Copy the files you are told. We will avoid anything that might be the cause of your problems. Here is the list of files;

cookies: Do not bother. Cookies will be created when you return to the web site. However, you will have to log in everywhere.

extensions(add-ons): it would be better to download them fresh. +++++++++++++++++++++++++++++++++++++++++++++++++ key3.db and logins.json: These are the Password files.

persdict.dat: custom dictionary – words you added to the dictionary

mimeTypes.rdf: What to do with what type of file.

places.sqlite: History and Bookmarks.

prefs.js: Your settings. Note, this may be contaminated.

cert8.db: Stores all your security certificate settings and any SSL certificates you have imported into Firefox. If removed, the file will be replaced. +++++++++++++++++++++++++++++++++++++++++++++++++ Copy these files from the old to the new. You will get a message about the files already exist. Choose to over-write for each file.

more options

Well I created a new profile. I only transferred over (overwriting) memeTypes.rdf and places.sqlite.

I reinstalled my extensions. One of them is for Dragon Naturally Speaking. Could that be the problem?

In any event, I went to jpost.com and was reading some comments when Firefox froze up. The task manager showed Firefox was rapidly using RAM at 15-20% CPU usage, when it got to 3 GB of RAM (I have 16 GB) I ended the task.

All of this is with the new profile.

more options

jeffreywilens said

One of them is for Dragon Naturally Speaking. Could that be the problem?

You can test this by disabling it or any other suspects.

more options

Disabling Dragon has helped but not entirely. Before disabling, scrolling through an article and comments on jpost.com, the Memory usage would climb steadily to above 1 GB and higher with constant 15% CPU usage. Eventually the page locks up entirely.

Disable Dragon, the lockup seems to have gone away and memory usage and CPU usage are way down, but still high. A normal web page like Yahoo or Mozilla support shows 1-2% CPU usage and often less than 1%. Firefox stays around 450MB. But going to jpost.com CPU stays around 6-8% and 600-700 MB RAM.

So there is obviously something running on the jpost webpages (maybe some kind of script) that is causing unnaturally high CPU usage and memory usage.

more options

There are LOTS of pictures, and a player.

more options

So you conclude it is the website to blame.

more options

Not really. But I have an idea to try.

This is not a cure, but should let the web page load without crashing.

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

more options

Try to copy one or two file at the time to see if that helps to identify the culprit.

On pages with a lot of links this might be a problem with the history (places.sqlite).

You can copy files like these to the current Firefox profile folder to recover specific data.

  • bookmarks and history: places.sqlite
  • bookmark backups: JSON backups in the bookmarkbackups folder
  • SQLite files like cookies.sqlite (cookies) and formhistory.sqlite (saved form data)
  • logins.json and key3.db (decryption key) for Passwords saved in the Password Manager
  • cert8.db and possibly cert_override.txt for (intermediate) certificates stored in the Certificate Manager
  • persdict.dat for words you added to the spelling checker dictionary
  • permissions.sqlite and possibly content-prefs.sqlite for Permissions and Site Preferences
  • sessionstore.js for open tabs and pinned tabs and tab groups
  1. 1
  2. 2