Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Extension are in C:\Users\xxx\Profiles but not in firefox

  • 16 odpovedí
  • 18 má tento problém
  • 431 zobrazení
  • Posledná odpoveď od cor-el

more options

In C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Profiles there is one profile (qanl58lx.default) and my extensions is in the profile folder, but in Firefox options/extensions there are none. This has been going on for some time, but suddently 2 days ago a window for every extension showed up and asked for updating, which was done, and now extensions were shown inOptions/extensoins. But today they are all gone again. I have scanned for malware and there are none.

Whats wrong?

Všetky odpovede (16)

more options

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

more options

Hi Fred

I was a little early with my satisfaction. Your trick helped, but a few days later the problem was the same - the extensions are in the Firefox profile folder, but is not present in Firefox options/extensions.

How do I get Firefox to look in the profile folder?


Kjeld Marslew

more options

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

As a test, disable your protection programs.

more options

What security software do you have?

Do you have any security software or cleanup software that might be causing this?

more options

I have been using AVG Free for many years now and I use CCCleaner once a month for several years. I have never had the problem before. I have made no changes in my extentions. The problem seem to start after last Firefox update

more options


Navn: Firefox Version: 42.0 Build-ID: 20151029151421 Opdateringskanal: release User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 Multiproces-vinduer: 0/1 (standard: false) Fejlsikret tilstand: false

Fejlrapporter for de seneste 3 døgn

Alle fejlrapporter



Adapter-beskrivelse: Intel(R) HD Graphics 4600 Adapter-drivere: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32 Adapter-RAM: Unknown Asynkron panorering/zoom: ingen DirectWrite aktiveret: false (6.3.9600.17999) Driver-dato: 3-16-2015 Driver-version: Enhedsidentifikation: 0x0412 GPU #2 aktiv: false Producentidentifikation: 0x8086 Subsys-identifikation: 40161297 Understøtter H264-afkodning i hardware: false Vinduer med GPU-grafikacceleration: 0/1 Basic (OMTC) WebGL Rendering: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0) windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Vigtige ændrede indstillinger

accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.hashstats_reported: 1 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 browser.download.folderList: 2 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 7 browser.search.openintab: true browser.search.useDBForOrder: true browser.sessionstore.resume_from_crash: false browser.sessionstore.upgradeBackup.latestBuildID: 20151029151421 browser.startup.homepage: https://www.google.dk/ browser.startup.homepage_override.buildID: 20151029151421 browser.startup.homepage_override.mstone: 42.0 browser.tabs.warnOnClose: false dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 42.0 font.internaluseonly.changed: false gfx.direct2d.disabled: true gfx.direct3d.last_used_feature_level_idx: 0 gfx.driver-init.appVersion: 41.0.2 gfx.driver-init.deviceID: 0x0412 gfx.driver-init.driverVersion: gfx.driver-init.feature-d2d: false gfx.driver-init.feature-d3d11: true gfx.driver-init.status: 2 keyword.URL: https://dk.search.yahoo.com/search?fr=greentree_ff1&ei=utf-8&ilc=12&type=926458&p= layers.acceleration.disabled: true media.gmp-eme-adobe.abi: x86-msvc media.gmp-eme-adobe.lastUpdate: 1446942056 media.gmp-eme-adobe.version: 15 media.gmp-gmpopenh264.lastUpdate: 1432120531 media.gmp-gmpopenh264.version: 1.4 media.gmp-manager.buildID: 20151029151421 media.gmp-manager.lastCheck: 1447597511 media.hardware-video-decoding.failed: false network.auth.allow-subresource-auth: 2 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1447448582 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.fdf,application/vnd.adobe.xfdf,application/vnd.adobe.xdp+xml plugin.importedState: true plugin.state.java: 0 plugin.state.npdeployjava: 0 plugin.state.npqtplugin: 0 print.printer_EPSON_Stylus_DX7400_Series.print_bgcolor: false print.printer_EPSON_Stylus_DX7400_Series.print_bgimages: false print.printer_EPSON_Stylus_DX7400_Series.print_colorspace: print.printer_EPSON_Stylus_DX7400_Series.print_command: print.printer_EPSON_Stylus_DX7400_Series.print_downloadfonts: false print.printer_EPSON_Stylus_DX7400_Series.print_duplex: -127 print.printer_EPSON_Stylus_DX7400_Series.print_edge_bottom: 0 print.printer_EPSON_Stylus_DX7400_Series.print_edge_left: 0 print.printer_EPSON_Stylus_DX7400_Series.print_edge_right: 0 print.printer_EPSON_Stylus_DX7400_Series.print_edge_top: 0 print.printer_EPSON_Stylus_DX7400_Series.print_evenpages: true print.printer_EPSON_Stylus_DX7400_Series.print_footercenter: print.printer_EPSON_Stylus_DX7400_Series.print_footerleft: &PT print.printer_EPSON_Stylus_DX7400_Series.print_footerright: &D print.printer_EPSON_Stylus_DX7400_Series.print_headercenter: print.printer_EPSON_Stylus_DX7400_Series.print_headerleft: &T print.printer_EPSON_Stylus_DX7400_Series.print_headerright: &U print.printer_EPSON_Stylus_DX7400_Series.print_in_color: true print.printer_EPSON_Stylus_DX7400_Series.print_margin_bottom: 0.5 print.printer_EPSON_Stylus_DX7400_Series.print_margin_left: 0.5 print.printer_EPSON_Stylus_DX7400_Series.print_margin_right: 0.5 print.printer_EPSON_Stylus_DX7400_Series.print_margin_top: 0.5 print.printer_EPSON_Stylus_DX7400_Series.print_oddpages: true print.printer_EPSON_Stylus_DX7400_Series.print_orientation: 0 print.printer_EPSON_Stylus_DX7400_Series.print_page_delay: 50 print.printer_EPSON_Stylus_DX7400_Series.print_paper_data: 9 print.printer_EPSON_Stylus_DX7400_Series.print_paper_height: 297,00 print.printer_EPSON_Stylus_DX7400_Series.print_paper_name: print.printer_EPSON_Stylus_DX7400_Series.print_paper_size_type: 0 print.printer_EPSON_Stylus_DX7400_Series.print_paper_size_unit: 1 print.printer_EPSON_Stylus_DX7400_Series.print_paper_width: 210,00 print.printer_EPSON_Stylus_DX7400_Series.print_plex_name: print.printer_EPSON_Stylus_DX7400_Series.print_resolution: 105 print.printer_EPSON_Stylus_DX7400_Series.print_resolution_name: print.printer_EPSON_Stylus_DX7400_Series.print_reversed: false print.printer_EPSON_Stylus_DX7400_Series.print_scaling: 1,00 print.printer_EPSON_Stylus_DX7400_Series.print_shrink_to_fit: true print.printer_EPSON_Stylus_DX7400_Series.print_to_file: false print.printer_EPSON_Stylus_DX7400_Series.print_unwriteable_margin_bottom: 0 print.printer_EPSON_Stylus_DX7400_Series.print_unwriteable_margin_left: 0 print.printer_EPSON_Stylus_DX7400_Series.print_unwriteable_margin_right: 0 print.printer_EPSON_Stylus_DX7400_Series.print_unwriteable_margin_top: 0 print.printer_EPSON_XP-810_Series_(FAX).print_bgcolor: false print.printer_EPSON_XP-810_Series_(FAX).print_bgimages: false print.printer_EPSON_XP-810_Series_(FAX).print_colorspace: print.printer_EPSON_XP-810_Series_(FAX).print_command: print.printer_EPSON_XP-810_Series_(FAX).print_downloadfonts: false print.printer_EPSON_XP-810_Series_(FAX).print_duplex: -127 print.printer_EPSON_XP-810_Series_(FAX).print_edge_bottom: 0 print.printer_EPSON_XP-810_Series_(FAX).print_edge_left: 0 print.printer_EPSON_XP-810_Series_(FAX).print_edge_right: 0 print.printer_EPSON_XP-810_Series_(FAX).print_edge_top: 0 print.printer_EPSON_XP-810_Series_(FAX).print_evenpages: true print.printer_EPSON_XP-810_Series_(FAX).print_footercenter: print.printer_EPSON_XP-810_Series_(FAX).print_footerleft: &PT print.printer_EPSON_XP-810_Series_(FAX).print_footerright: &D print.printer_EPSON_XP-810_Series_(FAX).print_headercenter: print.printer_EPSON_XP-810_Series_(FAX).print_headerleft: &T print.printer_EPSON_XP-810_Series_(FAX).print_headerright: &U print.printer_EPSON_XP-810_Series_(FAX).print_in_color: true print.printer_EPSON_XP-810_Series_(FAX).print_margin_bottom: 0.5 print.printer_EPSON_XP-810_Series_(FAX).print_margin_left: 0.5 print.printer_EPSON_XP-810_Series_(FAX).print_margin_right: 0.5 print.printer_EPSON_XP-810_Series_(FAX).print_margin_top: 0.5 print.printer_EPSON_XP-810_Series_(FAX).print_oddpages: true print.printer_EPSON_XP-810_Series_(FAX).print_orientation: 0 print.printer_EPSON_XP-810_Series_(FAX).print_page_delay: 50 print.printer_EPSON_XP-810_Series_(FAX).print_paper_data: 9 print.printer_EPSON_XP-810_Series_(FAX).print_paper_height: 297,00 print.printer_EPSON_XP-810_Series_(FAX).print_paper_name: print.printer_EPSON_XP-810_Series_(FAX).print_paper_size_type: 0 print.printer_EPSON_XP-810_Series_(FAX).print_paper_size_unit: 1 print.printer_EPSON_XP-810_Series_(FAX).print_paper_width: 210,00 print.printer_EPSON_XP-810_Series_(FAX).print_plex_name: print.printer_EPSON_XP-810_Series_(FAX).print_resolution: 105 print.printer_EPSON_XP-810_Series_(FAX).print_resolution_name: print.printer_EPSON_XP-810_Series_(FAX).print_reversed: false print.printer_EPSON_XP-810_Series_(FAX).print_scaling: 1,00 print.printer_EPSON_XP-810_Series_(FAX).print_shrink_to_fit: true print.printer_EPSON_XP-810_Series_(FAX).print_to_file: false print.printer_EPSON_XP-810_Series_(FAX).print_unwriteable_margin_bottom: 0 print.printer_EPSON_XP-810_Series_(FAX).print_unwriteable_margin_left: 0 print.printer_EPSON_XP-810_Series_(FAX).print_unwriteable_margin_right: 0 print.printer_EPSON_XP-810_Series_(FAX).print_unwriteable_margin_top: 0 print.printer_Foxit_Reader_PDF_Printer.print_bgcolor: false print.printer_Foxit_Reader_PDF_Printer.print_bgimages: false print.printer_Foxit_Reader_PDF_Printer.print_colorspace: print.printer_Foxit_Reader_PDF_Printer.print_command: print.printer_Foxit_Reader_PDF_Printer.print_downloadfonts: false print.printer_Foxit_Reader_PDF_Printer.print_duplex: -127 print.printer_Foxit_Reader_PDF_Printer.print_edge_bottom: 0 print.printer_Foxit_Reader_PDF_Printer.print_edge_left: 0 print.printer_Foxit_Reader_PDF_Printer.print_edge_right: 0 print.printer_Foxit_Reader_PDF_Printer.print_edge_top: 0 print.printer_Foxit_Reader_PDF_Printer.print_evenpages: true print.printer_Foxit_Reader_PDF_Printer.print_in_color: true print.printer_Foxit_Reader_PDF_Printer.print_margin_bottom: 0.5

more options

FredMcD said

As a test, disable your protection programs.
more options

Hi Fred

I tried to disable AVG, SuperAntiSpyware and MalwareBytes, but it didn't solve the problem.

Can I try other things?

more options

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.

I've called the big guys to help you. Good luck.

more options

Several people have reported the same behavior this week: Add-ons page not showing installed extensions, removing the extension files fixed the problem temporarily but the problem returned.

There must be some shared problem among the threads, but we haven't figured it out yet. At least one other user also had CCleaner, but wasn't running it intentionally at the time the problem occurred.

Do you use Firefox Sync to share extensions with another installation of Firefox?

more options

No, I don't use Firefox sync. I use CCleaner as well, but only controlled (no automatic). As I wrote, the problem started after last Firefox up-date. I hope you can find the broken link between the folder and Firefox.

As it appears to be a problem that are processed, please let me know, if I shall push the solve button or leave it open.

more options

Download Firefox For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.

Look for, and rename any Mozilla or Firefox folders by adding .old to them.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.

more options

Another user saved the renamed files and then when the problem recurred, compared them. The notable difference was that BetterPrivacy was missing from the corrupted files. Do you use BetterPrivacy (clears Flash cookies)?

There is a bug in BetterPrivacy on Firefox 42. It's mentioned here:

Sorry, BetterPrivacy currently is incompatible with FF 42. We are working on a fix. Please disable on FF 42 - otherwise please disable this option: 'Prevent the Firefox.....'. until a fix is available. Thank you!


If the BetterPrivacy extension reappears after rebuilding the settings files, you might want to remove it, in case this is triggering the problem somehow.

more options

You can also try to remove the addons.json and compatibility.ini files.

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

Upravil(a) cor-el dňa

more options


Now, several months later, I have erased the program, cleared my reg.base, installed the latest Firefox, updated to Windows 10... and still my adds are missing inside Firefox. What the hell can I do?

more options

What security software do you have?

It is possible that there is a problem with files in the profile folder that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "3-bar Menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this didn't help then delete Add-ons.json and possibly prefs.js in case there is a problem with preferences.

You can use this button to go to the current Firefox profile folder:

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.