Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Yahoo makes Firefox suck, I am getting sick of it how can it work better?

  • 12 odpovedí
  • 2 majú tento problém
  • 63 zobrazení
  • Posledná odpoveď od finbarr

more options

I have tried everything, including the stuff I read on the forums, but Yahoo keeps preventing me from following links on search results. If I type the address manually I still get that stupid yahoo page, this does not happen with Safari. I am not a fan of Safari but I do not like Firefox when it doesn't work and this is happening more and more. Also I am having trouble uploading a screenshot here, what's up with that? My internet connection is fine.

Všetky odpovede (12)

more options

I am even getting rerouted to the same dumb Yahoo error page when I load perfectly valid websites (e.g. rugbyworldcup.com/fixtures). Sometimes it goes here first: http://cdn.pulselive.com/dynamic/client/irb/static/i/sprites/nginx-logo.png before going here: https://search.yahoo.com/yhs/errorhandler?hspart=gt&hsimp=yhse-gt&q=cdn.pulselive.com%2Fdynamic%2Fclient%2Firb%2Fstatic%2Fi%2Fsprites%2Fnginx-logo&type=808263 Again, this doesn't happen with Safari, so I am using Safari, which I do not enjoy

more options

Hi, first try running the add-on SearchReset, which should reset your search, home and new tab page to default.

I suspect that may not help, so if not, try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

If that doesn't throw anything up, have a look in the Add-ons Manager (Cmd + Shift + A) and look for anything Yahoo related - if you see anything suspect, try disabling it.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

more options

none of this is doing anything but temporarily make the problem go away, why is this happening? is yahoo some sort of sacred cow that can't be pushed out of firefox? I have had enough of this problem amd so will no longer use firefox. too bad, it has for years been my favourite browser by far, now it is a daily headache

more options

Add some other search engine to the browser like: DuckDuckGo or Google. Them set it as the default search engine. Finally remove yahoo from the browser. I am not sure about it. But do try it once.

more options

I have done that but still it goes back to yahoo so I deleted firefox

more options

If a real solution is one day discovered or developped then I will be happy to start using firefox again. Anyone want to write a yahoo blocking app?

more options
more options

Yes I found and eliminated malware, re-installed firefox, deleted yahoo as a search engine, then restarted firefox and it opened on yahoo, even though I had see the duck as my default search engine and homepage. This version of firefox just doesn't work, and it doesn't work because of yahoo. what's wrong with the folk at mozilla, they used to care about their users?

more options

Update your Flash Player Version 19.0.0.185
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Hi finbarr, Firefox is designed to let you choose your preferred home page and search engine and have that remembered permanently.

What you experienced is characteristic of Spigot and Conduit software, particularly an extension called Searchme that seems to have infected a lot of Mac users in the past several months. And there may be others.

If you take a very close look at the link you posted earlier (in this post: https://support.mozilla.org/questions/1084419#answer-783274), you will notice an unusual "Learn More" link near the top of the page where you can find some information about one of these culprits (it has uninstallation information for Internet Explorer, which doesn't apply to your system, but you see how they do it).

more options

Actually the best answer so far but sadly not a solution to the problem, at least not for me, so I'll just keep using Safari for now until I can find something better