Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Can't install add-ons that're hosted outside of AMO

  • 1 odpoveď
  • 9 má tento problém
  • 19 zobrazení
  • Posledná odpoveď od Zeird

more options

I can't install any add-on that's hosted outside of AMO nor in Firefox for Android 40.0.3, neither in Firefox Beta for Android 41.

What I think should happen: I download signed .xpi-file (it saves automatically to sdcard), then open it with Firefox and Firefox should ask me if I want to install this add-on.

What really happens: an add-on is downloaded, but when I open it's .xpi-file with Firefox - nothing happens. Firefox just shows me a blank screen (see the screenshot).

My friend has this issue too.

It seems like a regression bug (because I could install add-ons hosted outside of AMO with no issues in earlier versions), but I'm not entirely sure.

So my question is: should I file a bug on Bugzilla or is there a way to install add-ons hosted outside of AMO to Firefox for Android and it's just me doing something wrong?

My phone has Android v2.3.5.

UPDATE: apparently, I can't install add-ons from local files, but can do from some certain sites. My add-on (which I have problem with) is hosted on Github, and I can't install it for reason unknown.

UPDATE2: it seems like add-ons can be installed from Github if it's not just a file (because Github changed Content-Disposition of at least certain raw file types from "inline" to "attachment"), but a binary attachment of a "release".

I can't install any add-on that's hosted outside of AMO nor in Firefox for Android 40.0.3, neither in Firefox Beta for Android 41. What I think should happen: I download signed .xpi-file (it saves automatically to sdcard), then open it with Firefox and Firefox should ask me if I want to install this add-on. What really happens: an add-on is downloaded, but when I open it's .xpi-file with Firefox - nothing happens. Firefox just shows me a blank screen (see the screenshot). My friend has this issue too. It seems like a regression bug (because I could install add-ons hosted outside of AMO with no issues in earlier versions), but I'm not entirely sure. So my question is: should I file a bug on Bugzilla or is there a way to install add-ons hosted outside of AMO to Firefox for Android and it's just me doing something wrong? My phone has Android v2.3.5. UPDATE: apparently, I can't install add-ons from local files, but can do from some certain sites. My add-on (which I have problem with) is hosted on Github, and I can't install it for reason unknown. UPDATE2: it seems like add-ons can be installed from Github if it's not just a file (because Github changed Content-Disposition of at least certain raw file types from "inline" to "attachment"), but a binary attachment of a "release".
Priložené obrázky

Upravil(a) Zeird dňa

Vybrané riešenie

Apparently I've found a workaround for this problem, so this question doesn't require an answer anymore.

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (1)

more options

Vybrané riešenie

Apparently I've found a workaround for this problem, so this question doesn't require an answer anymore.