X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Is there a solution for Firefox running with a white screen (no text or graphics) in Ubuntu 12.04?

Pridané

After receiving the upgrade to Firefox 40.0.2 only a white screen is displayed. It is not possible to change Firefox settings from the opening page because no text or graphics are displayed. This happened on two computers, an emachines T3624 and a Gateway-2000. I have tried a complete removal and new install using Synaptic Package Manager. I am writing this from the Chrome browser.

After receiving the upgrade to Firefox 40.0.2 only a white screen is displayed. It is not possible to change Firefox settings from the opening page because no text or graphics are displayed. This happened on two computers, an emachines T3624 and a Gateway-2000. I have tried a complete removal and new install using Synaptic Package Manager. I am writing this from the Chrome browser.

Vybrané riešenie

I tried creating a user.js file in the Firefox profile folder and adding the line: user_pref("gfx.xrender.enabled", false); That did not solve the blank white screen problem. I then tried disabling the prefs.js file and user.js files by renameing them. That worked. When I restarted Firefox, a new prefs.js was generated. The old prefs.js file which causes a white screen has the user_pref("gfx.xrender.enabled", false); line in it. The new prefs.js does not have user_pref("gfx.xrender.enabled", false); in it.

So, I found the prefs.js file, in the other machine with the same problem and commented out the user_pref("gfx.xrender.enabled", false); line. (I suppose removing that line would also work.) Firefox now works on the second machine and no longer launches with a blank white screen.

Čítať túto odpoveď v kontexte 0

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

The ones that come with the standard Ubuntu distribution. I can not see them because of the all-white screen.

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.155 Safari/537.36

Viac informácií

cor-el
  • Top 10 Contributor
  • Moderator
17668 riešení 159825 odpovedí

Try to toggle gfx.xrender.enabled on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Try to toggle gfx.xrender.enabled on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Autor otázky

Because of the white screen problem, I can not see or access the location/address bar. I would include a screen shot but, the Add Images box does not seem to accept the .png file. Anyway, all that will display is a blank white screen with only the top bar visible. Can the Mozilla about:config page be accessed through Terminal?

Because of the white screen problem, I can not see or access the location/address bar. I would include a screen shot but, the Add Images box does not seem to accept the .png file. Anyway, all that will display is a blank white screen with only the top bar visible. Can the Mozilla about:config page be accessed through Terminal?
cor-el
  • Top 10 Contributor
  • Moderator
17668 riešení 159825 odpovedí

You can create a user.js file in the Firefox profile folder and add this line to the file.

  • user_pref("gfx.xrender.enabled", false);

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can create a user.js file in the Firefox profile folder and add this line to the file. *user_pref("gfx.xrender.enabled", false); *http://kb.mozillazine.org/Profile_folder_-_Firefox *~/.mozilla/firefox/&lt;profile&gt;/ ---- The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

Autor otázky

I don't think this system has a Firefox profile folder. It does have a file named profiles.ini. Should I create a profile folder and put the user.js file in it or put the user_pref("gfx.xrender.enabled", false); line in the profiles.ini file?

Or, should I put only the part within parenthesis in the profiles.ini file as: gfx.xrender.enabled, false in the file? The path is ~/.mozilla/firefox/profiles.ini

There is an actual folder at ~/.mozilla/firefox/i7e2nj4a.default Is that the profile folder? Thank you for the help but I think I need additional directions.

I don't think this system has a Firefox profile folder. It does have a file named profiles.ini. Should I create a profile folder and put the user.js file in it or put the user_pref("gfx.xrender.enabled", false); line in the profiles.ini file? Or, should I put only the part within parenthesis in the profiles.ini file as: gfx.xrender.enabled, false in the file? The path is ~/.mozilla/firefox/profiles.ini There is an actual folder at ~/.mozilla/firefox/i7e2nj4a.default Is that the profile folder? Thank you for the help but I think I need additional directions.
cor-el
  • Top 10 Contributor
  • Moderator
17668 riešení 159825 odpovedí

Užitočné odpovede

Yes, ~/.mozilla/firefox/i7e2nj4a.default is a Firefox profile folder. profiles.ini should be one level up in ~/.mozilla/firefox/

There is also a second location used in ~/.cache/mozilla/firefox/ for other files You need to locate the profiles.ini file or use the Profile Manager to create a new profile.

Yes, ~/.mozilla/firefox/i7e2nj4a.default is a Firefox profile folder. profiles.ini should be one level up in ~/.mozilla/firefox/ There is also a second location used in ~/.cache/mozilla/firefox/ for other files You need to locate the profiles.ini file or use the Profile Manager to create a new profile. *http://kb.mozillazine.org/Profile_folder_-_Firefox

Vybrané riešenie

I tried creating a user.js file in the Firefox profile folder and adding the line: user_pref("gfx.xrender.enabled", false); That did not solve the blank white screen problem. I then tried disabling the prefs.js file and user.js files by renameing them. That worked. When I restarted Firefox, a new prefs.js was generated. The old prefs.js file which causes a white screen has the user_pref("gfx.xrender.enabled", false); line in it. The new prefs.js does not have user_pref("gfx.xrender.enabled", false); in it.

So, I found the prefs.js file, in the other machine with the same problem and commented out the user_pref("gfx.xrender.enabled", false); line. (I suppose removing that line would also work.) Firefox now works on the second machine and no longer launches with a blank white screen.

I tried creating a user.js file in the Firefox profile folder and adding the line: user_pref("gfx.xrender.enabled", false); That did not solve the blank white screen problem. I then tried disabling the prefs.js file and user.js files by renameing them. That worked. When I restarted Firefox, a new prefs.js was generated. The old prefs.js file which causes a white screen has the user_pref("gfx.xrender.enabled", false); line in it. The new prefs.js does not have user_pref("gfx.xrender.enabled", false); in it. So, I found the prefs.js file, in the other machine with the same problem and commented out the user_pref("gfx.xrender.enabled", false); line. (I suppose removing that line would also work.) Firefox now works on the second machine and no longer launches with a blank white screen.

Upravil(a) whiteout dňa