Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube only loads text, can't play any video anywhere (on other sites).

  • 11 odpovedí
  • 2 majú tento problém
  • 6134 zobrazení
  • Posledná odpoveď od samerg789

more options

This suddenly started for no real reason that I know of.

Whenever I go to youtube, the images don't load, and the video itself doesn't work at all. It says "This video is not available" . This is how it looks like: http://imgur.com/a/3tnpP first picture is the homepage, second one is a random video. I can guess that it has nothing to do with the new flash crisis that's happening because it's been going on for a while.

Please help me with this problem, because i really really dont know what to do and i've got nothing more to share. Willing to answer any questions. Thanks :)

Vybrané riešenie

I'm posting this in case somebody has the same problem as me. It's not exactly a solution but it will work for now.

First, download Minitube. It's not free but it has 20 days trial and you can delete and re-install when it's finished.

When you've done that, look for the video you want on the app. It will work there but the playback is terrible (if you have a link, then search for the part of the link beginning with watch?v= till the end). If it's a long video, you should watch it on your browser by doing so:

Within the app, while it's open and active, press Ctrl+U. Then go to your browser and paste the URL. Now you have the video playing for you! This worked on Firefox, but it will probably work on chrome and other browsers. I.E doesn't work (surprise surprise) it will ask you to download it rather than stream it immediately.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (11)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

Have you noticed any issues lately with secure certificate errors? You often get an unstyled page on a site if you made an exception for an untrusted certificate but the site uses multiple additional services or a content distribution network because the exception only applies to the address in the address bar.

If that sounds like it could be the explanation, please click the padlock (or gray warning triangle) icon in the address bar, then More Information, the View Certificate. I have attached a copy of the normal YouTube certificate information, with boxes around two areas. What do you see in those areas, anything different?

more options

FredMcD said

Many site issues can be caused by corrupt cookies or cache.
  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.
Type about:preferences<Enter> in the address bar.
  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.
If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration. Poke around safe web sites. Are there any problems? Then restart.

Hi, thanks for your reply. It didn't help me however. I tried both things but I still get the same problem, as expected, because I got a fresh install of Firefox and the same problem persists. It even occurs on I.E (didn't get to try Chrome because similar things happen when I go to the download website). I'm starting to think the problem is with my PC because on other devices on the same network it works just fine, but no matter what way of access is on my computer it doesn't work.

more options

jscher2000 said

Have you noticed any issues lately with secure certificate errors? You often get an unstyled page on a site if you made an exception for an untrusted certificate but the site uses multiple additional services or a content distribution network because the exception only applies to the address in the address bar. If that sounds like it could be the explanation, please click the padlock (or gray warning triangle) icon in the address bar, then More Information, the View Certificate. I have attached a copy of the normal YouTube certificate information, with boxes around two areas. What do you see in those areas, anything different?

I have, actually, on multiple occasions! I had to add them to an exception list (or something like that) to be able to access multiple websites. I had a clean install of Firefox multiple times but this doesn't seem to fix the problem; moreover, I get this same problem on I.E. I honestly think this is the problem. Here's what my certificate windows thingies look like http://gyazo.com/b0edab372e655b3d49a910f28e58b011 . Is there any way to reset them?

more options

Hi samerg789, that certificate for YouTube looks like the real thing, so it's a little puzzling why Firefox required you to make an exception. Perhaps this is somehow intermittent?

If you go into the Certificate Viewer and view the exception you saved, is it identical or do you notice any differences? To check that:

"3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab

Here, click "View Certificates" and in the dialog that pops up, activate the Servers tab. You can ignore the ones that list * as the server address and look for any related to google.com or youtube.com. If you select one, you can view its details and see whether it lists any other Issuer or Certificate Hierarchy information that might help track down the issue.


Also, while you're in the Advanced Options, could you check for any unusual connection settings? That's here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab

Click the "Settings" button and in the dialog that pops up, the default is "Use system proxy settings" but you also could try "No proxy" to see whether that makes any difference.


When you say the problem affects IE, do you mean it also has unstyled YouTube pages?

Can you open one of the style sheets for the home page in either browser:

https://s.ytimg.com/yts/cssbin/www-pageframe-2x-vflY4zPER.css

(Note: it's normal for that page to be a wall of text.)

more options

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

more options

FredMcD said

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

There doesn't seem to be anything wrong with the time. Time zone and everything.

jscher2000 said

Hi samerg789, that certificate for YouTube looks like the real thing, so it's a little puzzling why Firefox required you to make an exception. Perhaps this is somehow intermittent? If you go into the Certificate Viewer and view the exception you saved, is it identical or do you notice any differences? To check that: "3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab Here, click "View Certificates" and in the dialog that pops up, activate the Servers tab. You can ignore the ones that list * as the server address and look for any related to google.com or youtube.com. If you select one, you can view its details and see whether it lists any other Issuer or Certificate Hierarchy information that might help track down the issue.

Also, while you're in the Advanced Options, could you check for any unusual connection settings? That's here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab

Click the "Settings" button and in the dialog that pops up, the default is "Use system proxy settings" but you also could try "No proxy" to see whether that makes any difference.


When you say the problem affects IE, do you mean it also has unstyled YouTube pages?

Can you open one of the style sheets for the home page in either browser:

https://s.ytimg.com/yts/cssbin/www-pageframe-2x-vflY4zPER.css

(Note: it's normal for that page to be a wall of text.)

Hey, thanks for bearing with me all this time. I've checked the certificates from the preferences and they're identical to the one i see when i visit the website, except for Period of Validity &Fingerprints (Here's a picture of the two sides.

No proxy makes no difference, unfortunately. I've set it back to what it was before.

This last part is interesting. I clicked on the link, and lo and behold, This Connection is Untrusted! What I don't understand is why won't a clean install (using further methods ‒ Revo Uninstaller Pro ‒ to get an extra clean installation) won't work. That's all I've got. Thanks again.

Edit: what I see when I go to that link on I.E http://gyazo.com/8f6e5684c014c1ba1fb080ed1c64efcb

Upravil(a) samerg789 dňa

more options

Also wanna add that yes, it's the same exact problem on I.E and Vivaldi browser.

more options

Since IE also seems to be affected the same way, there appears to be something at the system level that is interfering with secure connections. When you expand the error in IE, can you see more information about the claimed "different website's address"?

Do you use any security software that filters your web connections? Usually if it's avast, ESET, BitDefender or Kaspersky, there is evidence in the certificate dialog, but maybe it's something else?

Do you use any special connection method such as a proxy or Tor?

more options

I think so too, that it's a system problem. When I go to the website on I.E and visit the webpage, I get "This page cannot be displayed" error.

I don't have an antivirus, but I do have Malwarebytes Anti-Malware. With or without it, the same thing happens.

Nothing like that either. I have Hamachi but I don't thing it has anything to do with this problem.

Honestly, there doesn't seem to be anything I could do about it. I just gotta avoid YouTube videos, wherever they may be, until July 29th. That's when Windows 10 rolls out; I plan on doing a clean install for the computer and see if that fixes everything; I'll let you know if it still persists, otherwise it's fixed.

Thank you for bearing with me all this time, jscher2000. Really appreciate all the help you've given me. :)

more options

Vybrané riešenie

I'm posting this in case somebody has the same problem as me. It's not exactly a solution but it will work for now.

First, download Minitube. It's not free but it has 20 days trial and you can delete and re-install when it's finished.

When you've done that, look for the video you want on the app. It will work there but the playback is terrible (if you have a link, then search for the part of the link beginning with watch?v= till the end). If it's a long video, you should watch it on your browser by doing so:

Within the app, while it's open and active, press Ctrl+U. Then go to your browser and paste the URL. Now you have the video playing for you! This worked on Firefox, but it will probably work on chrome and other browsers. I.E doesn't work (surprise surprise) it will ask you to download it rather than stream it immediately.