Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Internet randomly stopped working on firefox for no reason

  • 5 odpovedí
  • 2 majú tento problém
  • 1 zobrazenie
  • Posledná odpoveď od FredMcD

more options

The question isn't even an exaggeration. I was browsing like normal, doing nothing that I don't always do anyway. There were no updates to any of my extensions or add ons (though I don't know when firefox last updated itself) I close the browser and go do something else. Come back and when I try to load anything in firefox it says it isn't connected to the internet.

Thing is... I'm typing from that same computer. My internet is completely fine. It's not blocked by any firewall or proxy - it never has been. Firefox decided it just doesn't want to work anymore and this is incredibly annoying. Though I prefer using SeaMonkey (Which works) I need Lightbeam for a site I often go to and that's only in firefox.

I've started it in safe mode as well as refreshed it.

Všetky odpovede (5)

more options

You have several issues.

1) Turn On Your Firewall ! ! ! Mal-ware is always out there

2) Update all of your Adobe.com programs. They are out of date.

3) And so is Firefox; https://support.mozilla.org/en-US/kb/update-firefox-latest-version


Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use No Proxy. If there is a problem, then try System Proxy.


Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

Firefox was up to date. It was at 38.0.5 (I believe 38, is because that is the version SeaMonkey is running from) I also don't like updating adobe every other day which is why those are out of date. I do run a firewall and norton. Somehow, though, I managed to turn Norton off turning it on again allowed Firefox to work again. Which is strange. Any insight onto that? I do plan on looking into alternative virus protection sometimes soon so it would be pretty nice to not have my browser dependent on one particular one.

more options

Wolf said

Firefox was up to date. It was at 38.0.5

Your System Details says; Windows 7 - Firefox 36.0

I do run a firewall and norton. Somehow, though, I managed to turn Norton off turning it on again allowed Firefox to work again

Sometimes Norton causes problems. Let's check it out.

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Look for the Norton add-on, and disable it. After, restart Firefox.

more options

Again... I use seamonkey. Seamonkey runs on 36. My firefox is, and has been, on 38. The system details are reading 36 because Seamonkey is the browser that I am posting on. However if you click More System Details it will say there as well that I'm running off of 38.

Also, the norton toolbar has been disabled for a long time. So that shouldn't be causing an issue.

I'm just going to suppose the issue lies in the Norton antivirus itself. Though I'm unsure what it could have done to effect only firefox.

more options

The Norton toolbar is not Norton. It is an extra feature for the browsers protection. Disabling the toolbar does not stop the main program.

==============================

https://support.mozilla.org/en-US/questions/1048938 Firefox takes two minutes plus to load, apparent clash with Norton Internet Security

Norton showed where to exclude things from Autoprotect Open Norton Administrative Settings. Under Performance Monitoring, find Program Exclusions. To its far right, press the Configure + link.

You will have to add each program one at a time from the Mozilla Firefox and Mozilla Maintenance Service<Windows> folders..