Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox loads very slowly, other browsers run fine

  • 2 odpovede
  • 6 má tento problém
  • 43 zobrazení
  • Posledná odpoveď od Drathe

more options

Firefox has been loading webpages very slowly, whereas any other browser I use will load them much faster. I can even start loading a page in Firefox, open a different browser, load the same web page, see that it gets fully loaded in the second browser, close that browser, and swtich back to Firefox, and Firefox will not have the page visibly loaded yet. It is for this reason that I know the problem is not with my internet connection.

I use Firefox on my Windows 8 computer with no problems - it is actually one of the fastest browsers that I've used; I'm having a problem with it on a Windows 7 computer. I've tried several other fixes I've found on this site - disabling add-ons, starting Firefox in safe mode, clearing the cache, and enabling hardware acceleration. None of these have helped speed up Firefox. I'm no sure what else I could do at this point.

Všetky odpovede (2)

more options

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to install for Firefox and the plugin-container process and the updater process.


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Unfortunatly, this doesn't seem to have fixed my problem. I tried a new profile, and I actually didn't have a Firewall running at the time at all, so it's not possible that it is blocking Firefox.