Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

how do I disable the debugger/developer tools

  • 5 odpovedí
  • 2 majú tento problém
  • 1509 zobrazení
  • Posledná odpoveď od masonje

more options

I'm running Firefox in a kiosk mode and have most all the lockPref setting I need except for one. I just ran across the a key sequence (Ctrl+Shif+s on accident) that brings up the debugger/developer tools. I need to run that off since it's a locked down kiosk.

Many thanks!

I'm running Firefox in a kiosk mode and have most all the lockPref setting I need except for one. I just ran across the a key sequence (Ctrl+Shif+s on accident) that brings up the debugger/developer tools. I need to run that off since it's a locked down kiosk. Many thanks!

Vybrané riešenie

Found it. Asked our TC vendor to give us a hand. devtools.webconsole.enabled to false did it! It just disables the webconsole all together to none of those tools are accessible.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (5)

more options

Do you want to try reviewing the preferences in about:config and flipping all the ones with "enabled" in the name to false?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste devt and pause while the list is filtered

(3) Double-click the devtools.*.enabled preferences to toggle them from true to false and see whether that takes care of it.

more options

Thanks for the reply jscher2000, but no go. Ctrl+Shif+s still brings up the debug tools.

Upravil(a) masonje dňa

more options

I think you might have to modify a program file or use an extension to kill those keyboard shortcuts.

For example, keyconfig: http://forums.mozillazine.org/viewtopic.php?t=72994

(That one is completely different than an extension named Key Config on the add-ons site.)

more options

Note that there are a lot more devtools that each have their own shortcut key. It may not be easy to disable this shortcut key (#key_jsdebugger) as that is one of shortcut keys in a separate folder (#devtoolsKeyset)

more options

Vybrané riešenie

Found it. Asked our TC vendor to give us a hand. devtools.webconsole.enabled to false did it! It just disables the webconsole all together to none of those tools are accessible.

Upravil(a) masonje dňa