Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 29.0.1 tab "x" close button no displaying on any tabs

  • 12 odpovedí
  • 17 má tento problém
  • 3686 zobrazení
  • Posledná odpoveď od nikoh

more options

Hi I just upgraded to version 29. Unfortunately my tabs have lost the x close button on the tab. I can click where it should be to close them but I would prefer to just have it displayed.

I have reset firefox as well as going through my ad ons nothing has helped

any ideas?

Vybrané riešenie

It was a skin for windows 7 that prevented me from viewing the X. I uninstalled it and now it works well!

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (12)

more options

Maybe a false value?
In the URL window type "about:config" (without the ").
Say Yes to the warning.
In the search part there, type browser.tabs.closeButtons
That line should appear now and it should have an integer value of 1
If not, double click that line and give it a value of 1.
That is the default value to show the X-button on each tab.
If it has already the value of 1, then I do not know how to fix. Maybe someone else.

Upravil(a) meegja dňa

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with preferences.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

more options

Nah Its not that I checked that, and no help....

more options

Hello,

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not run Firefox's uninstaller or use a third party remover as part of this process, because that could permanently delete your Firefox data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be recovered unless they have been backed up to an external device!

Please report back to see if this helped you!

Thank you.

more options

Alt+H+T > Reset Firefox

more options

You havent even read my problem when you decided to give me some advice thanks for that

more options

Hello nikoh ,

try a clean reinstall as i've suggested in my previous comment .

Upravil(a) user669794 dňa

more options

Did you try to disable hardware acceleration in Firefox?

Are you using the default theme?

Did you try another Windows theme to see if that has effect?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

more options

i am using a custom skin in windows 7 is that a possible problem?

more options

I just upgraded to Mozilla 32.0. Unfortunately my tabs have lost the "x" close button on the tab. I can click where it should be to close them but I would prefer to just have it displayed.

I have reset firefox, ... and followed the 29.0 suggestion -> set "browser.tabs.closeButtons" to 1.

"browser.tabs.closeButtons" does not exist in F 32.0!

any ideas?

more options

dcappitelli,

That's the problem with posting in someone else's thread, who asked a question about a different version of Firefox - prefs can disappear due to changes made in Firefox, as the one for "browser.tabs.closeButtons" did.

Please start your own thread - https://support.mozilla.org/en-US/questions/new - and install the Troubleshooter extension so we can see a listing of your "troubleshooting information". Just follow the prompts when you "ask a new question".

more options

Vybrané riešenie

It was a skin for windows 7 that prevented me from viewing the X. I uninstalled it and now it works well!