Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

What would cause mouse to scroll slowly on Web pages but normally on text documents?

  • 5 replies
  • 9 have this problem
  • 370 views
  • Last reply by Skitz00

more options

I have an odd problem. I have a Logitech M305 mouse on another machine that is scrolling too slow on Web pages. I ordered a new mouse but today I noticed the old mouse scrolls normally on text documents, even if the text document is displayed in Firefox (such as the "about:config" page).

Normally, a page will scroll 3 lines for every click of the mouse scroll wheel. On Web pages this changes and it takes 3 clicks of the mouse wheel to get the page to scroll.

It is unsettling to move the mouse wheel and have nothing happen until the third click.

So the question is, what would make the mouse scroll wheel behave differently on Web pages and text pages, and how can I fix it?

BTW, this is a clean install of Windows 7 64-bit. I am using the exact same type of install right now on another machine with a Logitech M510 mouse and it scrolls normally on all pages.

Chosen solution

OK, final report on this issue. Yesterday, before installing the new M325 mouse I decided to uninstall the Logitech SetPoint software first. I wanted a fresh install of the mouse software to go with the new mouse.

To my surprise, after SetPoint was uninstalled the old M305 mouse scrolled normally on both text pages and Web pages. It appears something mysterious happened in the relationship between Firefox and the original SetPoint installation. Firefox does make some adjustments or updates of its own with regard to SetPoint just as it does for Add-Ons, I have seen it happen a couple of times before. /shrug

New mouse + SetPoint is running perfectly with FireFox now and the old M305 mouse + SetPoint is now running fine with an old XP Pro laptop, at least as long as the gimpy right-click button holds on.

Solution, in this case: Uninstall the Logitech SetPoint mouse software, then reinstall a fresh copy of it.

Read this answer in context 👍 1

All Replies (5)

more options

This could be a mouse issue. Have you tried contact Logitech?

more options

No, I didn't bother with Logitech because the right-click button is also getting balky on that mouse so I ordered a new mouse (M325) which just arrived today. I figured if the mouse is at fault the new mouse would solve both problems.

What got me wondering about a Firefox solution to the scrolling issue is that I need to move the mouse wheel exactly three clicks before the scrolling takes place. Never one, or two, always three clicks. And then I found the mouse to be scrolling normally in text documents, the odd scrolling only seems to occur on Web pages. The behavior is so definite and predictable I suspected a software setting of some sort.

I'll know in a couple of days when I get the chance to try the new mouse over on my friends machine. If hardware was the solution I'll come back here to report that.

more options

Chosen Solution

OK, final report on this issue. Yesterday, before installing the new M325 mouse I decided to uninstall the Logitech SetPoint software first. I wanted a fresh install of the mouse software to go with the new mouse.

To my surprise, after SetPoint was uninstalled the old M305 mouse scrolled normally on both text pages and Web pages. It appears something mysterious happened in the relationship between Firefox and the original SetPoint installation. Firefox does make some adjustments or updates of its own with regard to SetPoint just as it does for Add-Ons, I have seen it happen a couple of times before. /shrug

New mouse + SetPoint is running perfectly with FireFox now and the old M305 mouse + SetPoint is now running fine with an old XP Pro laptop, at least as long as the gimpy right-click button holds on.

Solution, in this case: Uninstall the Logitech SetPoint mouse software, then reinstall a fresh copy of it.

more options

I also had this problem in both Firefox and IE. I solved it by disabling the Logitech SetPoint extension. To solve the problem in IE, go to Manage add-ons and disable the Logitech SetPoint extension. It was already disabled in Chrome (Chrome didn't like the extension to begin with), so it wasn't necessary to manually disable it there.

more options

Doh! It didn't even dawn on me to check that. I didn't realize that a SetPoint extension had been installed, didn't know one was needed or even existed. And I don't know whose idea it was to install it, wasn't me. Good addition to this solution, thanks. Next time I have an issue with a Logitech mouse in Firefox I'll be checking the extension first.

Your comment caused me to check my installed extensions and I found two more I did not consciously install and both are about to get the deep six. Thanks again.