Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

any site with ".blogspot" does not load in any browser; other sites do; blogger.com loads

  • 5 replies
  • 22 have this problem
  • 1076 views
  • Last reply by jscher2000

more options

For the past 4 - 5 days, any blogsite with .blogspot.com does not load on any of my browsers - Firefox, Chrome, Internet Explorer. Doing a Google search lists that site's posts, and clicking on "Cached Copy" shows the cached site, but on trying to refresh to a recent page, or opening a link from the cached page to another .blogspot site fails. I can open www.blogger.com, log in to my blog, but on trying to see the blog, the same problem crops up. I have cleared the cache and cookies, but that has not resolved the issue. Neither has scanning for any malware or virus

All Replies (5)

more options

Can you see the page via a site like Google Translate with a random source language like fr or it?

It is possible that you are blocked from the server for some reason, so you may try to contact the site via email (e.g. webmaster@)

You can also try to reset (power off/on) the router.

more options

Thank you cor-el for your response, and yes it worked!

I am amazed, the blog site opened through the Google Translate link sent by you, and I could also open other .blogspot.com links after the blog opened through the translate page.

But on all these blog sites I found a common feature: where the "Followers" of the blogs should have been shown, there is a message "We're sorry...

This gadget is configured incorrectly. Webmaster hint: Please ensure that "Connect Settings - Home URL" matches the URL of this site" but no photos or links to the followers. Probably this may indicate the source of the problem - not in the browsers or in the user's computer but in the Blogger site itself.

Could you please explain the reasoning/mechanism of your suggestion to get the site to open through Google Translate?

Till the problem is finally resolved, will I have to continue doing it through Google Translate, or is there a possible fix for it?

I have also posted the problem at the blogger forums.

Sincerely, aksd

more options

You may still have to investigate if you aren't blocked by the blogspot.com server if it works via the Google translate site. If you use GT then Google accesses the website and sends the data to you after trying to translate the page, which isn't necessary because in this case it is already in English. If this work then something is preventing you from accessing the server directly. That can be a server block or you may be blocked otherwise (ISP or router or something on your computer or DNS issues).

more options

ever since I upgraded to 14.0.1 I cannot get on any of my blogger.com webpages. I have tried everything.. there is something SCREWED up with Firefox. Even after I wiped it out, and reinstalled 13.0, I still get the same problem.

more options

Hi Macwildstar, I posted in your other thread here: https://support.mozilla.org/en-US/questions/935515