Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Graphical problems on Surface Pro X (arm64)

  • 3 replies
  • 10 have this problem
  • 1 view
  • Last reply by Bundyo

more options

Using the arm64 version of Firefox on a Surface Pro X causes several graphical issues. These issues started either with a update of Firefox or drivers.

This topic has already been reported, please see here for more information and documentation: Reddit: https://www.reddit.com/r/firefox/comments/182iojx/firefox_arm64_graphical_problems_on_surface_pro_x/ Mozilla Connect: https://connect.mozilla.org/t5/discussions/firefox-arm64-graphical-problems-on-surface-pro-x/m-p/52086

What can be done to report this issue and help it getting fixed?

Using the arm64 version of Firefox on a Surface Pro X causes several graphical issues. These issues started either with a update of Firefox or drivers. This topic has already been reported, please see here for more information and documentation: Reddit: https://www.reddit.com/r/firefox/comments/182iojx/firefox_arm64_graphical_problems_on_surface_pro_x/ Mozilla Connect: https://connect.mozilla.org/t5/discussions/firefox-arm64-graphical-problems-on-surface-pro-x/m-p/52086 What can be done to report this issue and help it getting fixed?

Chosen solution

Rendering issues on Surface Pro X is currently tracked by Bug 1852440.

Try changing gfx.webrender.software to true in about:config then restart the browser.

Read this answer in context 👍 9

All Replies (3)

more options

Chosen Solution

Rendering issues on Surface Pro X is currently tracked by Bug 1852440.

Try changing gfx.webrender.software to true in about:config then restart the browser.

Helpful?

more options

Thank you, this worked for me!

Helpful?

more options

Seems the ANGLE renderer is causing these graphical glitches. After disabling gfx.webrender.force-angle and restarting Firefox, they seem gone.

P.S. On second check - this option also enables the software rendering.

P.S. After some more testing - software rendering with OpenGL works more fluid (scrolling doesn't stutter) than the D3D11 one.

Modified by Bundyo

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.