Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Videos auto-play (video AND audio) despite Block setting being on for both

  • 5 replies
  • 0 have this problem
  • 24 views
  • Last reply by cassidy.mt

more options

Going to any page on the ESPN.com site, videos are playing automatically - both video and audio - despite the fact that I have Firefox set to block both.

I am running Firefox 104.0.2 (latest version) on Windows 10.

Seems like the blocker is missing something, somehow. Anyone else see this?

Going to any page on the ESPN.com site, videos are playing automatically - both video and audio - despite the fact that I have Firefox set to block both. I am running Firefox 104.0.2 (latest version) on Windows 10. Seems like the blocker is missing something, somehow. Anyone else see this?

All Replies (5)

more options

I just scrolled down the entire homepage and nothing auto played for me on mac. Win 11 currently updating and will test in a few minutes.

Helpful?

more options

Same in W11, nothing auto plays. see screenshot


Edition Windows 11 Pro Insider Preview Version 22H2 Installed on ‎07-‎Sep-‎22 OS build 25193.1000 Experience Windows Feature Experience Pack 1000.25193.1000.0

Helpful?

more options

You can look at these prefs on the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.block-autoplay-until-in-foreground

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Helpful?

more options

cor-el said

You can look at these prefs on the about:config page to see what settings work for you to block autoplay.
  • media.autoplay.default = 5 [0:allow;1:blockAudible;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.block-autoplay-until-in-foreground
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Well I can see how these are set in my browser, but can you or someone tell me how they *should* be set to block any auto-play? Here are how mine look:

  • media.autoplay.default = 5
  • media.autoplay.blocking_policy = 0
  • media.autoplay.allow-extension-background-pages = true
  • media.autoplay.block-event.enabled = false
  • media.block-autoplay-until-in-foreground = true

I want to block any and all auto-play, ever. How should the above be set to achieve that? Thank you in advance!

Helpful?

more options

Anyone? Can someone tell me what the settings *should* be for those 5 (or any other) settings to make auto-play of video stop?

Seems like a design flaw that this needs to be chased down this way. What is the point of an auto-play blocker setting if you then have to manually fudge four other settings too?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.