Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

XULRunner error

  • 3 replies
  • 1 has this problem
  • 13 views
  • Last reply by Ewelina

more options

Dear Mozilla Community members,

For a while now I get sort of an error message some time after Windows start (every time): "XULRunner Could not determine any profile running in backgroundtask mode!"

I managed to find out that XULRunner is connected to Mozilla but I haven't found any info about this particular message so far, therefore, I would appreciate your help solving this issue.

Thank you in advance.

Kind regards, Ewelina

Dear Mozilla Community members, For a while now I get sort of an error message some time after Windows start (every time): "XULRunner Could not determine any profile running in backgroundtask mode!" I managed to find out that XULRunner is connected to Mozilla but I haven't found any info about this particular message so far, therefore, I would appreciate your help solving this issue. Thank you in advance. Kind regards, Ewelina
Attached screenshots

All Replies (3)

more options

Yes, that's definitely our prompt. I guess it's connected with some background update task error.

See:

Try to open the Windows task scheduler and check your tasks in the Mozilla folder.

You can also run Firefox, enter about:config in the address bar and set app.update.background.enabled = false. It should disable the prompt after a while.

Helpful?

more options

How are you starting Firefox (command line in the shortcut) as this might be a problem if you do not launch Firefox with the profile that is set as Default=1 in profiles.ini ?

Helpful?

more options

TyDraniu said

Yes, that's definitely our prompt. I guess it's connected with some background update task error. See: Try to open the Windows task scheduler and check your tasks in the Mozilla folder. You can also run Firefox, enter about:config in the address bar and set app.update.background.enabled = false. It should disable the prompt after a while.

Thank you for your response. I tried the last one it and I will see in the next days if it works (the prompt shows once per day or so). I also viewed the tasks in the Task scheduler (please, find an image in the attachment) but I am clueless of what to do with it (just an average user).


cor-el said

How are you starting Firefox (command line in the shortcut) as this might be a problem if you do not launch Firefox with the profile that is set as Default=1 in profiles.ini ?

Thank you also for your input. I start Firefox just normally from the Start menu in Windows. I have no idea how to check which profile it actually uses. If the solution of TyDraniu turns out not to work after a few days, I can paste here the content of the profiles.ini, might it be useful.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.