Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I attempt to drag a site icon to the Bookmarks toolbar, I get circle with line.

  • 8 replies
  • 1 has this problem
  • 5 views
  • Last reply by Standard8

more options

My Firefox somehow crashed and REFRESH fails to work - tried it twice. I have NO plugins or addons.

I am trying to rebuild my Bookmarks Toolbar.

I used View to add the Bookmarks Toolbar and a blank line was inserted near top of dialog as expected.

When I try to drag the site icon from the URL area to the Bookmarks line/area, I get a circle with a line.

I have read, easily 25 posts on how to do this, including posts from folks who seem to be having the same problem, and I have not found my answer.

One "answer" that I frequently find has to do with the words "Bookmarks toolbar items".

I clicked the 3 horizontal bars on the top left. I scrolled down and clicked Customize. I dragged the Bookmarks icon up to the blank line for the Bookmarks Menu. Now the words "Bookmarks toolbar items" are shown in that line. I click Done at bottom right.

Once again I try to drag a site item to the Bookmarks toolbar, and I get the same result. I get circle with line.

Any help would be appreciated.

TIA, RP108

Firefox 61.0.1 Win7

My Firefox somehow crashed and REFRESH fails to work - tried it twice. I have NO plugins or addons. I am trying to rebuild my Bookmarks Toolbar. I used View to add the Bookmarks Toolbar and a blank line was inserted near top of dialog as expected. When I try to drag the site icon from the URL area to the Bookmarks line/area, I get a circle with a line. I have read, easily 25 posts on how to do this, including posts from folks who seem to be having the same problem, and I have not found my answer. One "answer" that I frequently find has to do with the words "Bookmarks toolbar items". I clicked the 3 horizontal bars on the top left. I scrolled down and clicked Customize. I dragged the Bookmarks icon up to the blank line for the Bookmarks Menu. Now the words "Bookmarks toolbar items" are shown in that line. I click Done at bottom right. Once again I try to drag a site item to the Bookmarks toolbar, and I get the same result. I get circle with line. Any help would be appreciated. TIA, RP108 Firefox 61.0.1 Win7

Chosen solution

Hi, can you try this:

  • Go to Help -> Troubleshooting Information
  • Scroll down to the "Places Database" section (near the bottom of the page).
  • Click the "Verify Integrity" button.
  • Temporarily copy the text it inserts.
  • Restart Firefox.

Then see if your toolbar comes back to life, and if you're able to put things on it or not.

If you can't please can you paste that output text into a response here so we can check the output.

Read this answer in context 👍 1

All Replies (8)

more options

Hi, what happens when you drag to the Bookmarks Menu then into the Bookmarks Toolbar Folder in the Menu ?

more options

Pkshadow said

Hi, what happens when you drag to the Bookmarks Menu then into the Bookmarks Toolbar Folder in the Menu ?

Hi Pkshadow,

Totally lost on what you are saying .... sorry.

Are you talking about when I have the Toolbar customization dialog open?

more options

If you are talking about the normal mode of operation (not the Customization dialog .....

In the area of the Bookmarks Menu, there is an icon that is a Star with a line underneath. I get the same response (circle with line) trying to drag the site icon from the URL area to there.

more options

Please provide a screenshot of the Firefox window when Customize mode is open.

And a 2nd screenshot of Firefox with Customize "Done" or not showing.


See this support article. How do I create a screenshot of my problem? It is best to use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed a maximum file size of 1 MB.

Then use the Browse .... button below the Post a Reply text box to upload the screenshot.

more options

Thank you for responding.

I have attached the 2 jpgs that you requested.

Again, Thanks.

more options

Chosen Solution

Hi, can you try this:

  • Go to Help -> Troubleshooting Information
  • Scroll down to the "Places Database" section (near the bottom of the page).
  • Click the "Verify Integrity" button.
  • Temporarily copy the text it inserts.
  • Restart Firefox.

Then see if your toolbar comes back to life, and if you're able to put things on it or not.

If you can't please can you paste that output text into a response here so we can check the output.

more options

Hi Standard8,

Thank you for the response. YES, that worked !

It was a bit weird, though. As I mentioned in the first part of this thread, Firefox lost all of Bookmarks, Tabs, Passwords, etc and REFRESH failed twice.

Now it's all back. My Bookmarks bar was jammed with the ones I have been trying to add since the crash PLUS all the old ones.

Anyway, I can add Bookmarks easily now.

I don;t have a clue what was going on but I thank you again for supplying the solution ... right on the money !

Best, RP

Just in case you want the data I copied for your study, here it is.

===========================

> Task: checkIntegrity + The database is sane > Task: invalidateCaches + The caches have been invalidated > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: vacuum + Initial database size is 30720KiB + The database has been vacuumed + Final database size is 30720KiB > Task: stats + Places.sqlite size is 30720KiB + Favicons.sqlite size is 19008KiB + pragma_user_version is 47 + pragma_page_size is 4096 + pragma_cache_size is -2048 + pragma_journal_mode is wal + pragma_synchronous is 1 + History can store a maximum of 158533 unique pages + Table moz_bookmarks has 181 records + Table moz_keywords has 0 records + Table sqlite_sequence has 1 records + Table moz_annos has 2360 records + Table moz_anno_attributes has 7 records + Table moz_items_annos has 129 records + Table moz_places has 59139 records + Table moz_historyvisits has 102310 records + Table moz_inputhistory has 24 records + Table moz_hosts has 5345 records + Table sqlite_stat1 has 17 records + Table moz_bookmarks_deleted has 5 records + Table moz_meta has 0 records + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_hosts_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_places_url_hashindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex + Index moz_bookmarks_guid_uniqueindex + Index moz_places_guid_uniqueindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_bookmarks_dateaddedindex > Task: _refreshUI


===========================
more options

Hi rp108,

I'm glad it worked.

I'm not sure what was up with you initially loosing a lot of things, that could have been some strange profile issue. I guess we'll never really know.

The toolbar issue is one we've seen before and would have probably fixed itself had you left Firefox idling in a bit (the integrity task you ran normally runs in the background once a day), though in Firefox 62, we've changed that particular self-fix to work on startup to avoid the potential confusion state.