Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fail to use Firefox after refresh Firefox in macOS

  • 7 replies
  • 5 have this problem
  • 117 views
  • Last reply by dgddy

more options

After I have refreshed Firefox in macOS, nono of the website is able to use and I get this message in the browser: Your connection is not secure **************************** The owner of www.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate.

Advance: www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. Error code: SEC_ERROR_UNKNOWN_ISSUER

****************************

Anyone can help?

After I have refreshed Firefox in macOS, nono of the website is able to use and I get this message in the browser: Your connection is not secure <nowiki>****************************</nowiki> The owner of www.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate. Advance: www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. Error code: SEC_ERROR_UNKNOWN_ISSUER <nowiki>****************************</nowiki> Anyone can help?

Modified by cor-el

Chosen solution

You can remove the checkmark for the main "Scan secured connections" setting to see if that has effect.

Read this answer in context 👍 0

All Replies (7)

more options

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites


  • uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN
  • configured their website improperly

How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

more options

Could you please provide more detail and check the the issuer of the certificate?

  • click the "Advanced" button show more detail
  • click the blue SEC_ERROR_UNKNOWN_ISSUER message to show the certificate chain
  • click "Copy text to clipboard" and paste the base64 certificate chain text in a reply

If you can't inspect the certificate chain that way then try these steps to inspect the certificate.

  • open the Server tab in the Certificate Manager
    • Options/Preferences -> Privacy & Security -> Certificates: View Certificates -> Servers: "Add Exception"
  • paste the URL of the website (https://xxx.xxx) in it's location field.

Let Firefox retrieve the certificate -> "Get Certificate"

  • click the "View" button and inspect the certificate

You can see detail like the issuer of the certificate and intermediate certificates in the Details tab.

more options

1. I use Avast but I can't find the same web shield setting as described. There is no HTTPS option. 2. The detail of "SEC_ERROR_UNKNOWN_ISSUER", I have already pressed the "Copy text to clipboard" and below already shown all content.

https://www.google.com.hk/?gfe_rd=cr&dcr=0&ei=yQ2eWoazLtShX6DfpKAM&gws_rd=ssl

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: false HTTP Public Key Pinning: true

Certificate chain:

Modified by dgddy

more options

That would be the last setting that shows in the first screenshot about "Scan secured connections".

more options

What should I do?

more options

Chosen Solution

You can remove the checkmark for the main "Scan secured connections" setting to see if that has effect.

more options

Finally, I did nothing and Firefox resumes to work. Thanks anyway and hope this post would help others.