Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

the add on cannot be downloaded because of a connection failure

  • 6 replies
  • 5 have this problem
  • 3 views
  • Last reply by jscher2000

more options

ever since i updated to v56 i keep getting this problem. no 3rd party addon can be downloaded because of this stupid connection failure. it was working fine before the update, now it's not working.

if you rec me to: https://support.mozilla.org/en-US/kb/unable-install-add-ons-extensions-or-themes?redirectlocale=en-US&redirectslug=Unable+to+install+add-ons

I've already tried them! Yes, I make another firefox profile, still doesnt work! I've added permissions, still doesnt work! Disable all AV/etc, still doesn't work

I know about the work around where you just download the add on and drag it to firefox. There are sites where just cant download it and drag, like trying to get amazon assistant etc.

All Replies (6)

more options

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

Forgot to mention, I already tried that.

more options

Can you think of any reason your Firefox would not want to follow this redirect?

Example: I clicked install on the "Page to PDF" extension. That called:

https://addons.mozilla.org/firefox/downloads/file/727903/page_to_pdf-1.0.0-an+fx-windows.xpi?src=dp-btn-primary

The server sent back a redirect to this address:

https://addons.cdn.mozilla.net/user-media/addons/839492/page_to_pdf-1.0.0-an+fx-windows.xpi?filehash=sha256%3A6dbe94e5450824e6f1f993eca4c4df6deae11a67b90456d20d41743fbbac29c6

Then I got the little panel on the address bar to allow the installation.

To see whether you get the first response and whether Firefox is able to get the second response, you can try this:

On the page where you want to install the add-on, open Firefox's Network Monitor in the lower part of the tab. Either:

  • "3-bar" menu button > Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

Then when you click the button, Firefox should show some activity as it sends the requests and receives the responses. (Example screenshot attached.)

more options

This is what I get when I try to install Ad Block Plus. Matter of fact, I cant install any add on from the site. Installing via Add On Manager is the only thing that works.

I've already unintalled/reinstalled Firefox

more options

It's interesting that the first line says the file is cached, so it sounds as though Firefox was able to retrieve it, but then you get a connection error? That's really strange.

If you right-click the first line and choose Open in New Tab, what happens?

more options

Another user with this problem indicated that the button on the "All Versions" page (there is a link lower on the add-on's page) worked. Does that fit with the problem you're having?

https://support.mozilla.org/questions/1183370