Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't copy-and-paste in Facebook comments

  • 18 replies
  • 31 have this problem
  • Last reply by jscher2000

more options

Suddenly, I am prevented from copy-and-paste in Facebook comments. What do I need to do?

All Replies (18)

more options


You seem to be running an really old version of Firefox, please upgrade to the latest version.

Go to: Help >> About Firefox >> It will start downloading the updates, wait until it finish and then restart Firefox.

For more help see:

Update Firefox to the latest release

more options

Thanks for irrelevant the suggestion.

more options

I don't think itz a issue related to browser, check if itz working ok in other browsers. otherwise we can find a solution to it  :)

more options

Did you already try the usual things?

  • Clear Firefox's cache
  • Remove saved Facebook cookies
  • Try Firefox in its Safe Mode to bypass possible extension issues

When you have a problem with one particular site that worked fine before, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then in the dialog that opens you can remove your Facebook cookies individually without affecting other sites.

Then try reloading the page. Does that help?

more options

And I'm sure you must know that version 18 is not secure; Mozilla discloses security flaws after each new release.

Is something holding you back from upgrading to Firefox 30? Please let us know so we can suggest solutions or workarounds.

more options

Tried all three of the options above (reloaded from server, cleared cookies, restarted in safe mode) -- none work.

Can still paste links using Chrome, so it's definitely Firefox related.

more options

Hi cjpalermo21, you mentioned pasting links. Could you describe your issue in more detail? For example, can you copy and paste text into Facebook comments, but not links? Or can you paste a link but Facebook doesn't do that thing where it creates a little preview from the link?

Also, the forum software closes threads after 6 months, and this one is close to that age, so you might want to start a new question. You can do that using the following link:

Scroll down past the suggestions if they aren't helpful to continue with the form.

more options

Hi jscher2000,

I can copy and paste text, but not links. When I try and paste, nothing shows up.

I also cannot get emoticons to show up either; but that's a little less important.

I will also start a new discussion, as per your recommendation.


more options

Do you have the Grammarly extension?


  • [/questions/1034172]] Why can't I use some keys when using Facebook with Grammarly enabled?
more options


Thanks ....

I don't have the Grammarly extension -- but, either way, I've restarted in safe mode, with no luck :(


more options

Do you get a pop-up that copy and paste is disabled or is it simply not working?

Is the clipboard cleared when you try to copy text when you previously put something on it elsewhere?

more options

Great questions!

No pop-up ... it simply doesn't work.

If I copy a link and try to paste into a Facebook comment box -- nothing pastes. However, if I then paste it elsewhere, it's still there (I can paste it) - so the link *is* definitely on the clipboard ....

more options

Does pasting work if you temporarily disable JavaScript by toggling the javascript.enabled pref to false on the about:config page after the page has finished loading?

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Ooh ... it doesn't like that at all.

I can't even open a comment box, and I can't see stories on the home page. Plus, there's a HUGE banner across the top *demanding* I enable javascript (maybe I imagined it as demanding). But, it does say to enable JS or switch to the mobile site.

more options

You should only disable JavaScript temporarily to check if that has effect on copy and paste once the page has finished loading and not all the time. Once you have checked this then you should toggle javascript.enabled to true with a double-click.

more options

I did :)

I was just letting you know what happened once I disabled it.

more options

Jscher Thanks for your thoughts about 18. But Mozilla, in its eagerness to be new and spare and compete with Chrome, has gone to stark for me.

I want my browser to look the way I want it, and I am unable to do so past this edition of Mozilla. The apps to go "classic" don't really go classic and I'm simply unwilling to go with constant reinvention demanded by Mozilla.

It's like living in a condo that needs new locks, so the management goes into your condo and rearranges the furniture and your closets and throws out some of your favorite clothes. I guess I will continue to resist changing the locks.

I appreciate your concern and keep trying new apps and ways to use an update version, but I can't deal with them!

more options

Hi PhineasBoggs, I agree that the Classic Theme Restorer doesn't automatically roll back the UI as far as some users would like. But if you go into the Options dialog*, you will find dozens of additional tweaks that in most cases will take care of it. Some customizations are a little more complicated, but many of the forum volunteers use CTR and can provide individual guidance.

Are you at least using Firefox 28 if you don't like Firefox 29 and higher?

For a more old-time experience, you might also consider the SeaMonkey project: (you can ignore the email component and just use the browser)

* CTR's Options dialog is available on the Add-ons page. Its options are not integrated into the main Firefox Options dialog.

Modified by jscher2000