Отображение вопросов с тегом: Показать все вопросы

Devtools Pseudoclass hover only working on first load

I'm working on developing something using Codepen and when I refresh either the pen itself or the browser completely the pseudoclass selector for `:hover` does not work. … (читать ещё)

I'm working on developing something using Codepen and when I refresh either the pen itself or the browser completely the pseudoclass selector for `:hover` does not work. It does on first page load when I open (or open and then close) the browser.

Example: I am trying to style a `
  • ` and it's child. I open the pseudoclass selector and check `:hover`. I have a setting to change the display from `display:none` to `diplay:inline-flex` on a child when the `li` is hovered. It does not do this if I refresh internally (in codepen) or if I refresh the browser itself. It works again once I close Firefox and reopen altogether. I am including two screenshots of the working and not working states. The first (firefox-devtools-bug1.png) shows working, and the second (firefox-devtools-bug2.png) shows the not-working state.
  • Задан chabuku 5 часов назад

    Последний ответ от chabuku 1 час назад

    HTML 5 Audio Not Working Properly on Firefox

    Certain sites like clyp, soundcloud, bandcamp, etc don't work on firefox yet, they work when I try them on Chrome. This issue of audio not playing correctly is becoming a… (читать ещё)

    Certain sites like clyp, soundcloud, bandcamp, etc don't work on firefox yet, they work when I try them on Chrome. This issue of audio not playing correctly is becoming an increasingly annoying issue for me as I have started school where listening to mp3 files on blackboard is part of the curriculum. None of them work on firefox and, I've had to email professors to reissue quizzes to me.

    Задан jothamgames 3 часа назад

    Последний ответ от jothamgames 38 минут назад

    'data:image' data links in page info. How to identify location/allow retrieval without turning off tracker blocking?

    One of the sites I regularly use (tesco.com) seems to have changed the way it gets thumbnail images of products, so that they no longer show up unless I turn off script b… (читать ещё)

    One of the sites I regularly use (tesco.com) seems to have changed the way it gets thumbnail images of products, so that they no longer show up unless I turn off script blocking for a whole page. (Once I've got one page working, it continues working for the other pages, even if scripts are 'blocked' on those!?)

    In the page info I see that the non showing images are only represented by 'data:image' followed by gif.64 and a long string of letters. I understand that this is an html link converted to data, but I don't know why, and have never seen this before. If I copy the 'link' into a new tab, it just goes to a black page. One time I did get a warning pop up from 'NoScript' that the page was doing some dodgy sort of call out, and 'did I want to disable it on this site'. I think it said the call out was to one of the Google sites, but I can't find any way to show this information when NoScript isn't warning me about it; and I can't seem to make 'NoScript' do the pop up every time I try to search with the data link: most times it just goes to the black page: only once or twice has it showed me the warning. I don't understand what's going on.  :/

    First time 'NoScript' gave the warning, I opted to 'allow this linking for this page', and the thumbnails then showed up, and the 'data:image' link info was replaced with a normal link to a jpg picture (odd because the data link had been prefixed 'gif;64' ?). I then wanted to know which script to enable for future use, but, when I disabled all the page scripts again, the thumbnails stayed there, and continued to work on the whole site: not just the current page!

    When I logged out, and came back to continue shopping later, whatever the setting was, had been lost, and I had to go through the rigmarole of allowing all scripts, to get the thumbnails to show, and then turning off all but the main domain permission afterwards.

    Can someone please explain what these data links are, and how to see where they are really aimed/what site a picture is actually on, before just letting them connect. And so how to allow just the exception that's needed to show the thumbnails.

    Sorry if this sounds dumb, but it's all new to me.

    Many thanks for any enlightenment.

    Задан Spamlet 1 день назад

    Последний ответ от Spamlet 28 минут назад

    godaddy login fails

    Using v.80.0.1 (according to FF/Help/About) on Win10-64bit. Cannot log into godaddy.com. Error message is "Yikes! Something went wrong. Please, try again later." Works … (читать ещё)

    Using v.80.0.1 (according to FF/Help/About) on Win10-64bit. Cannot log into godaddy.com. Error message is "Yikes! Something went wrong. Please, try again later." Works fine with Chrome, so have to believe it's in FF. Tried changing various settings in Options/Privacy& Security. Anyone else having issues, or better yet, a solution??

    Thanks in advance.

    Задан rickyo 3 часа назад

    Последний ответ от rickyo 45 минут назад

    How do I download Firefox v.80.01?

    I want to download/update to Firefox v.80.01 for Windows 64-bit, but every time I try to download anything at all, Firefox pushes 81.0 on me (just released today), which … (читать ещё)

    I want to download/update to Firefox v.80.01 for Windows 64-bit, but every time I try to download anything at all, Firefox pushes 81.0 on me (just released today), which I do NOT want. I'm running the latest "Extended Support" release (79.0 64-bit). I'm 80 and do NOT want to test software. Do I have to keep running v.79 if I don't want v.81, or can I download the version I want?

    How can I get Firefox v.80.01?

    Thanx, Anne F.

    Задан Manage Firefox 1 час назад

    Scroll bar disappears

    The scroll bar on the right of my screen disappears when I sign in to "The Guardian". This started within the last week. It works OK when I sign in to my other on line … (читать ещё)

    The scroll bar on the right of my screen disappears when I sign in to "The Guardian". This started within the last week. It works OK when I sign in to my other on line subscriptions (NY Times and Washington Post) and all other places I access. It works OK when I do a "Safe Mode" load of Firefox. I have explored the few Add-ons and Custom Settings but have not been able to determine the cause. I am having this problem on any of 4 different computers currently running Firefox 81.0 and Windows 10. Microsoft Edge is working OK if I use it.

    Any help would be appreciated.

    Jim

    Задан jdrolte 1 час назад

    Emails not filling out correctly in forms

    When I fill in blanks for emails on website forms, half the time Firefox tells me the email is not valid. These same websites are working fine in Chrome. This problem s… (читать ещё)

    When I fill in blanks for emails on website forms, half the time Firefox tells me the email is not valid. These same websites are working fine in Chrome. This problem started around 2 weeks ago for me.

    I have attached an image from Gradescope to show what I mean.

    Задан isleofnonconformity 1 день назад

    Последний ответ от isleofnonconformity 1 час назад

    Are javascript urls not supported when following links?

    I have a website, which has a simple script in the form of a javascript url that is supposed to redirect to a mailto address. This is, obviously, a simple attempt at prev… (читать ещё)

    I have a website, which has a simple script in the form of a javascript url that is supposed to redirect to a mailto address. This is, obviously, a simple attempt at preventing email harvesting/spamming. This link doesn't work as expected. The link opens in a new tab, but the link isn't parsed and handled. Works as expected on Microsoft Edge. Is this expected behavior? Is there a workaround?

    https://thejaka.com/

    Задан Thejaka 1 час назад

    Can't see OneTab icons on menu bar

    I love having OneTab, but suddenly both the icon that creates a list from my open tab (usually on the R side of the toolbar) and the icon that opens my lists (usually on … (читать ещё)

    I love having OneTab, but suddenly both the icon that creates a list from my open tab (usually on the R side of the toolbar) and the icon that opens my lists (usually on the L) are both gone. OneTab is still listed as an enabled add-on, and I've deleted and re-installed it multiple times, but the icons don't show up. I was once able to find "OneTab" on my add-ons list via the "hamburger" (not sure what to call it -- the three horizontal lines at the end of the toolbar), but it was the word only, no icon, and when I dragged it to the toolbar, nothing showed up. I LOVED using OneTab, and I miss it! How can I get it to show up?

    Задан sajudy2 2 часа назад

    Cannot sign in to some websites after cache is cleared. MS Edge signs in ok

    Could not go through process of changing my password for a bank website, called bank, it was suggested to clear my history and cache in Firefox, I did so. This allowed th… (читать ещё)

    Could not go through process of changing my password for a bank website, called bank, it was suggested to clear my history and cache in Firefox, I did so. This allowed the automated process of changing my password to process through ok. I could then not sign in to that website or another site with firefox. either auto sign in or manually entering my credentials. I can sign in to all my websites in MS Edge. Not in firefox. I have cleared my cache and the "Corrupt cache" file. also checked the error log and it is not being caused by a security certificate issue. Can anyone assist me? I would appreciate any help. It is not critical as I can sign in through a different browser and it is only happening on a couple websites but it is annoying. Thanks Art

    Задан aemessick 2 часа назад

    Duplicate "Save as Adobe PDF" menu items in Print > PDF

    I have Adobe Acrobat PRO DC installed. Under Print > PDF there are multiple menu items saying "Save as Adobe PDF". How do I edit this menu ('edit Menu' has no entrie… (читать ещё)

    I have Adobe Acrobat PRO DC installed. Under Print > PDF there are multiple menu items saying "Save as Adobe PDF". How do I edit this menu ('edit Menu' has no entries) so that it only has 1 option to select not 4 saying the same thing?

    I have fully reinstalled Acrobat and Firefox, after uninstalling with App Cleaner and Uninstaller... the 4 entries remain.

    I am using Firefox 78.3.0esr on MacOS 10.15.6 and the latest version on Acrobat PRO

    Thanks

    JS

    Задан jonnyspeed 5 часов назад

    Последний ответ от jonnyspeed 3 часа назад

    Disabling title bar makes Firefox slow

    Hello! I have recently installed Xubuntu Focal Fossa, and noticed that Firefox became slow along the way. At first, I didn't know what was the reason, but now, after havi… (читать ещё)

    Hello! I have recently installed Xubuntu Focal Fossa, and noticed that Firefox became slow along the way. At first, I didn't know what was the reason, but now, after having purged it and reinstalled it again for the second time, I am pretty sure that it is disabling the title bar which is causing the problem. Enabling it again and restarting the browser makes everything smooth once more. Is there a solution to this? Thank you very much!

    Задан realnameperson 4 часа назад

    no sound on Blitzortung.org

    When I view the blitzortung.org (live lightning map) website I do not hear any sounds associated with the lightning strikes. The normal sound is a very short duration "cl… (читать ещё)

    When I view the blitzortung.org (live lightning map) website I do not hear any sounds associated with the lightning strikes. The normal sound is a very short duration "click". The sound is present when using other browsers but I really hate using Chromium (don't like Google). I am running Debian Linus 10 and I nominally use Firefox ESR. I have downloaded the regular Firefox and the problem occurs with Firefox 80 as well as with ESR 68.12.0.

    By opening the PulseAudio mixer while the blitzortung site is opened I have observed that there is a brief flash of the AudioIPC server that coincides with the lightning strike "clicks". My guess is that the AudioIPC server response time is the issue.

    Is there any way to get around this issue.

    Sound works fine for every other web site.

    Задан jsamcr 9 часов назад

    Последний ответ от jsamcr 5 часов назад

    Firefox will not respond

    Issue:  Firefox installed fine, but when I try to access the internet through it nothing happens.    I enter Google on the address bar and got no response.   Chrome and E… (читать ещё)

    Issue:  Firefox installed fine, but when I try to access the internet through it nothing happens.   

    I enter Google on the address bar and got no response.   Chrome and Edge work fine only Firefox is unresponsive.   

    I have uninstalled it, reinstalled it, refreshed it noting makes it work!

    I miss my firefox!

    Thanks

    Задан Nodakman 2 дня назад

    Последний ответ от Nodakman 5 часов назад

    Urdu font is broken firefox (version 80) ubuntu 20.04

    Urdu words are broken on `Firefox` (`version 80`) and `ubuntu 20.04` on Facebook and main search window (They are alright in wikipedia). Chromium and Chrome are rendering… (читать ещё)

    Urdu words are broken on `Firefox` (`version 80`) and `ubuntu 20.04` on Facebook and main search window (They are alright in wikipedia). Chromium and Chrome are rendering them properly.

    I changed the font settings in firefox and selected the same fonts as they were in Chrome but it didn't solved my issue. I've also installed and used Nafees font package as indicated [here](https://askubuntu.com/a/542683/864585). It corrected the shape of characters but words are still broken. Similar [thread](https://forums.linuxmint.com/viewtopic.php?t=222388) on `linuxmint` forum provided an answer. It uses same fonts as that of chromium but there's an extra option of `"Text encoding for legacy content"` and uses Arabic in that. I can't find this option in my version of mozilla (I'm attaching picture of option available in my mozilla?


    Can someone please suggest a solution or can help me to find the option `"Text encoding for legacy content"`.


     [1]: https://i.stack.imgur.com/1tSdv.png
    

    Задан Naeem12 6 часов назад

    Firefox installation mistake - now won't instal

    I just got a new Mac. I've had Firefox on my old Mac for years. During installation on the new machine, I must have made a mistake/been too hasty. In the first instance… (читать ещё)

    I just got a new Mac. I've had Firefox on my old Mac for years.

    During installation on the new machine, I must have made a mistake/been too hasty.

    In the first instance, I dragged the Firefox icon into my Apps folder, but since it didn't appear in my list of applications, I tried to run it from the .dmg package directly.

    Since then, I realised I'm not supposed to do this. So I've deleted everything Firefox from my computer and restarted it several times.

    However, each time I now re-download the Firefox installer and go through the steps to instal it, the same thing happens: it only ever runs from the .dmg package. Whenever I delete the .dmg from my computer Firefox stops running.

    Can someone help? Thank you!

    Задан fabien.r.cante 6 часов назад

    Sharepoint error: NetworkError when attempting to fetch resource.

    Screenshot of error attached. Happens when I'm in Sharepoint and click on Conversations for Sharepoint group (screenshot attached) When I copy the url to another browser … (читать ещё)

    Screenshot of error attached. Happens when I'm in Sharepoint and click on Conversations for Sharepoint group (screenshot attached) When I copy the url to another browser it works fine. When I copy and paste into Firefox it still fails. I reset Firefox and it sometimes helps and allows me to click once, yet when I come back and click the link again I get the same error. Error details: TypeError: NetworkError when attempting to fetch resource. Troubleshoot issues with Microsoft SharePoint Foundation. Correlation ID: 12f77a9f-300c-b000-22aa-a5e92ccf8eaa Date and Time: 9/17/2020 11:12:12 AM

    I chose to add troubleshooting info or whatever yet I don't know if it added the version... I'm using 78.2.0esr (64-bit) and MacOS 10.14.6

    Задан Layne Staley 5 дней назад

    Последний ответ от Layne Staley 6 часов назад

    scroll in firefox is very slow or choppy .

    change firefox settings to Try setting these prefs in about:config general.smoothScroll.currentVelocityWeighting: 0 general.smoothScroll.stopDecelerationWeighting; 0.82 m… (читать ещё)

    change firefox settings to Try setting these prefs in about:config

    general.smoothScroll.currentVelocityWeighting: 0

    general.smoothScroll.stopDecelerationWeighting; 0.82

    mousewheel.min_line_scroll_amount: 60


    general.smoothScroll.mouseWheel.durationMaxMS = 100 general.smoothScroll.mouseWheel.durationMinMS = 100 general.smoothScroll.pages.durationMaxMS = 100 general.smoothScroll.pages.durationMinMS = 100 general.smoothScroll.pixels.durationMaxMS = 100 general.smoothScroll.pixels.durationMinMS = 100 general.smoothScroll.scrollbars.durationMaxMS = 100 general.smoothScroll.scrollbars.durationMinMS = 100 general.smoothScroll.stopDecelerationWeighting = 1

    Задан adhmomran 2 месяца назад

    Последний ответ от adhmomran 6 часов назад

    Logins and passwords not imported in Version 81

    To start off, I've never used the sync feature. Not that I think it won't work, I just haven't trusted the cloud enough yet. That being said, I know my logins and pass… (читать ещё)

    To start off, I've never used the sync feature. Not that I think it won't work, I just haven't trusted the cloud enough yet. That being said, I know my logins and passwords are stored in the "profile" in the appdata of mozilla firefox, on this local computer. To my knowledge, this information is stored in the "logins.json" file located in my default profile. Up until now, I have had no issues retrieving the information I need. However, after this morning, when Version 81 was installed, I visited a website where I needed a particular login. I normally have Firefox automatically populate this information, on this particular site. However, since that did not happen this time, I checked my "logins and passwords" page, only to find "No logins found" on the sidebar, and "No synced logins found" in the main space, with instructions on how to sync from other devices or import from other browsers. Since I have not had a login before (for Firefox), I created an account to see if I could import the information from a previous version. However, only other browsers were listed, and I can't sync from another device, as the information is stored on this machine. Creating an account has also allowed me to post here...

    I have opened the logins.json file with notepad, and the logins-backup.json file, and both are full of information. Of course it's not plain text, but the information is there. I can also open these files with Firefox, however, it doesn't recognize the file as the "logins and passwords" file, it just displays the encrypted information in a different (html?) format.

    Any advice on how I can import these 55+ logins and passwords without re-creating or changing each one of them? Thanks.

    Задан c.kurt 6 часов назад