Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Automatically stop unresponsive scripts

  • 5 ответов
  • 86 имеют эту проблему
  • 12214 просмотров
  • Последний ответ от VerizonSucks

more options

I regularly get a nonresponsive script, especially in a browser session that has been around for awhile. I find that if I end nonresponsive scripts, the browser remains stable. Heaven help me if I leave a browser window open for several hours, and return to the computer to find it tied up and it will take 15 minutes to respond to a mouse click or a keyboard entry until I can finally get Firefox shut down or forced to end.

I tried to use the "Always perform this action" check box and select to end the script. I figured if I choose that option it would always end a nonresponsive script when it's time for the box to appear.

I would prefer that over finding the computer tied up with a nonresponsive browser four hours later.

OS Windows XP SP3 and now Firefox 27.0.1

Gmail and YouTube seem to be two sites that are especially troublesome.

Все ответы (5)

more options

Hello,

See this help article:

So, you also can disable javascript when you leave, then you back you can active again.

to disable javascript go to about:config , search for javascript.enabled, to disablechange its value to false and to active change to true

Also:

more options

"Warning unrespnsive script" says nothing about how to apply my chosen action to stop any script that becomes nonresponsive, allowing responsive scripts to run

If I wanted to stop all JavaScript, I could just as easily go to Tools > Options > Content tab and remove the check mark from the box there. (I have done this before for one reason or another.) It beats searching through the about:config settings to accomplish this. Who knows what kind of damage I could cause by carelessly opening about:config!

But disabling all JavaScript is akin to throwing out the good with the bad, and akin to calling every person of "Fictionese" decent bad or stupid because I encountered one unpleasant person from "the Fiction Republic."

I do have YesScript installed so I could permanently block one web site from disabling my right-click context menu, but YesScript blocks the good scripts along with the one I want to block. That is a solution also akin to throwing the good out with the bad, though limited to the targeted site.

Getting back to the Unresponsive Script warning box:

Evidently, when I encounter this warning, and tell Firefox to always do this action, and tell it to stop the script, I am only taking action against one script. Presumably, then, each time I encounter a warning it is for yet another script.

It would be nice if I could apply that action to all scripts that become nonresponsive or unresponsive, and only when they become so. .

more options

Ditto on the script problem, I think. EVERY time I try to reopen a previous session (using Session Manager - why the hell this functionality is not built-in is beyond me) FF becomes Not Responding. If I let it sit for an hour, from time to time the Unresponsive Script box will pop up.

Also getting this error -- tried disabling Add-ons but I don't think its an add-on problem:

6/11/14 6:53:30 PM kernel Data/Stack execution not permitted: firefox[pid 6382] at virtual address 0x1189bc000, protections were read-write 6/11/14 6:53:31 PM kernel Data/Stack execution not permitted: firefox[pid 6382] at virtual address 0x1189bc000, protections were read-write 6/11/14 6:53:32 PM kernel Data/Stack execution not permitted: firefox[pid 6382] at virtual address 0x1189bc000, protections were read-write 6/11/14 6:53:33 PM kernel Data/Stack execution not permitted: firefox[pid 6382] at virtual address 0x1189bc000, protections were read-write 6/11/14 6:53:39 PM kernel Data/Stack execution not permitted: firefox[pid 6382] at virtual address 0x1189bc000, protections were read-write 6/11/14 6:53:40 PM kernel Data/Stack execution not permitted: firefox[pid 6382] at virtual address 0x1189bd000, protections were read-write

etc keeps repeating this error every second or few.

HOW can I make FF kill scripts automatically and QUICKLY ???

Using OSX 10.6.8 so some stuff that people say to disable etc is built in to the OS and not being updated by Apple anymore (it is Java? or Flash? )

Also seems to be worse since upgrading to FF 30.0 the other day. SO MANY PROBLEMS WITH FF -- wasting many HOURS of time.

more options

"Error happens when accessing certain websites"

BUT there is no way for me to know WHICH tab is giving the problem. The Unresponsive Script box does not TELL ME.

more options

"Note: If you have a large number of extensions, it may be quicker to enable more than one extension at a time. The method with the fewest number of restarts required is: Enable half the extensions in this list, then restart Firefox and test for the problem. "

That advice is fatuous. FF auto-stupidly RE-ORDERS the list of extensions, with active ones first. So there is no easy way to keep track of what you have done; which half of the active half is the half causing the problem...