Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Secure Connection Failed An error occurred during a connection to www.google.co.in.

  • 7 ответов
  • 15 имеют эту проблему
  • 1638 просмотров
  • Последний ответ от guigs

more options

Problem:-

Secure Connection Failed

An error occurred during a connection to www.google.co.in. SSL peer rejected a handshake message for unacceptable content. (Error code: ssl_error_illegal_parameter_alert)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.



I have tried every possible aspect provided by the Mozilla Firefox Support Team

These are the Steps followed:-

Check your SSL settings

   In the Location bar, type about:config and press Enter.
       The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page. 
   Type security.enable in the Search field.
       If both security.enable_ssl3 and security.enable_tls are set to true, skip to the next section.
       If both security.enable_ssl3 and security.enable_tls are set to false, double-click each of them to set it to true. 

Try to access a secure site again. If it still doesn't work, continue in the next section.


Check your proxy settings

Some computers are configured to access the Internet through a proxy.

   Click the menu button New Fx Menu and choose Options
   .
   Select the Advanced panel.
   Click the Network tab.
   Click Settings….
       If Manual proxy configuration is selected, you are using a manually configured proxy server. Verify that all protocols listed in the dialog box are pointing to the address of your proxy server. Contact your network administrator if you don't know this address.
       If Manual proxy configuration is not selected, this section does not apply. You can skip to the next section. 
   Make any changes, and click OK to close the Connection Settings window.
   Click OK to close the Options window . 

Try to access a secure site again. If it still doesn't work, continue in the next section.


Please suggest a proper solution as my 100 employees are suffering with it...

Изменено Viratthakur

Все ответы (7)

more options

Here Is the Image that i have attached which the 100 of my employees are facing what should we do its very critical...

more options

You can try to modify the security.tls.version.min and security.tls.version.max prefs to set which TLS versions are enabled.
You may have to close and restart Firefox after changing these prefs.

security.tls.version.min = 0
security.tls.version.max = 2
0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, 3 means TLS 1.2, etc.

Изменено cor-el

more options

This also did not resolve the issue.

Please i request the firefox team and the users of firefox to please give me the better solution to get rid of this....

Awaiting for your responses????????

more options

No problems here with the current Nightly (30) and Aurora (28) build (TLS 1.0 and TLS 1.2 enabled)

www.google.co.in: Connection Encrypted: High-grade Encryption (TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256, 128 bit keys)

What kind of connection do you use?
Are you connecting via a proxy or a direct connection?

You can try to log the connection.

more options

we are using direct connection behind a firewall, The interface is followed like this

Router->Firewall->Systems

more options

No Solution For this error???????????

more options

Hi Viratthakur,

I am sorry for the frustration, however we will do our best to help you investigate the issue. Please keep in mind, the Firefox version is a beta version that updates on a different cycle than Firefox 27.

In order to better understand the issue:

  • When did this start happening?
  • Are you using a nonstandard port for the ssl? is your default port 443?
  • Do all certificates utilize one dedicated ip?
  • If using Apache2 check your vhost config. Some users have reported changing <VirtualHost> to _default_ resolved the error.

Reference http://stackoverflow.com/questions/11.../ssl-error-rx-record-too-long-and-apache-ssl

  • Is the intermediate certificate at the server side (apache SSLCertificateChainFile)?
  • you can test the direct connection with no proxy (turning the proxy setting off on the computer's security settings)

We look forward to your reply.