Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

How do I get rid of the "This Connection is Untrusted" message?

  • 3 ответа
  • 484 имеют эту проблему
  • 27239 просмотров
  • Последний ответ от kgarner

more options

I have used my firefox browser for 1 1/2 without any problems. Now all the sites I go to give me the warning message that "This Connection is Untrusted." I can no longer access email or my university website to see my grades- nothing works. Even when I click that I understand the risks and verify the certificate, I can still only get so far- but it's never all the way to where I need to be. How can I get rid of this annoying problem?

Все ответы (3)

more options

One reason for having the problem on MANY secure sites is a problem with the date on your system. For example, it could be the correct month and day but the wrong year.

Another reason might be software on your system that is intercepting your secure communications so it can either filter them (for your protection) or steal your data. This is more commonly seen on Windows, but is worth checking.

Have you been adding exceptions for these sites? If so, could you look at some of the certificates to see whether there is any pattern?

Firefox menu > Preferences > Advanced > Certificates mini-tab > "View Certificates" button > Servers tab

So for example, you may find that the issuer is one of the following:

  • Security software vendor such as ESET or BitDefender
  • Sendori or FiddlerRoot
  • Other

If you do find a pattern, that may help identify the culprit.

more options

Are you on a Mac as the Question Details would suggest or on another platform?


You can also check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

Thanks jscher2000 and cor-el for your help! It turns out it was a date and time issue. I'm glad to say it's all fixed now! Thanks again!