X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Arrow keys occasionally not working in text boxes

Размещено

I have a recurring issue that's really annoying: my left/right arrow keys (including CTRL+arrow keys) occasionally and randomly fail to work when entering text in certain text boxes on certain websites. This never occurs in "simple" unformatted text boxes (Facebook, search boxes, this very box I'm typing in...), but unpredictably happens in more complex ones (WYSIWYG editors, new youtube comments...).

I have tried disabling all extensions and running Firefox in safe mode and this *seems* to have solved the problem, though I can't be sure and I can't isolate which extension it might be, since the issue happens at random: on the same website it will happen and then not happen.

I'm on Firefox 25.0, though I've had this issue for years with countless versions of Firefox.

The extensions I have installed and enabled:

Adblock plus Bamboo Feed Reader, Dimmer, Download Helper, Drag&Drop Zones, Flagfox, FlashVideo Downloader, Flashblock, Flashgot, Grab and Drag, MouseZoom, Status-4-Evar, Youtube High Definition

Thanks in advance for any help you may give me.

I have a recurring issue that's really annoying: my left/right arrow keys (including CTRL+arrow keys) occasionally and randomly fail to work when entering text in certain text boxes on certain websites. This never occurs in "simple" unformatted text boxes (Facebook, search boxes, this very box I'm typing in...), but unpredictably happens in more complex ones (WYSIWYG editors, new youtube comments...). I have tried disabling all extensions and running Firefox in safe mode and this *seems* to have solved the problem, though I can't be sure and I can't isolate which extension it might be, since the issue happens at random: on the same website it will happen and then not happen. I'm on Firefox 25.0, though I've had this issue for years with countless versions of Firefox. The extensions I have installed and enabled: Adblock plus Bamboo Feed Reader, Dimmer, Download Helper, Drag&Drop Zones, Flagfox, FlashVideo Downloader, Flashblock, Flashgot, Grab and Drag, MouseZoom, Status-4-Evar, Youtube High Definition Thanks in advance for any help you may give me.

Изменено Ghost81

Выбранное решение

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)


In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • default toolbar layout is used (localstore-safe.rdf)
  • Javascript JIT compilers are disabled (javascript.options.*jit)
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
Прочитайте этот ответ в контексте 1

Дополнительные сведения о системе

Установленные плагины

  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • 4.1.10329.0
  • VLC media player Web Plugin 2.0.0
  • DivX Plus Web Player version 2.2.0.52
  • Detector for the Onlive Game Client
  • DivX VOD Helper Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0

Дополнительная информация

Bittu 2 решений 35 ответов
Размещено

Полезный ответ

If this problem presists in other browsers or just occuring in Mozilla..?? Check it out & reply...

If this problem presists in other browsers or just occuring in Mozilla..?? Check it out & reply...
Размещено

Задавший вопрос

This only happens in Firefox. No other browser of any other software installed on my computer presents this issue.

This only happens in Firefox. No other browser of any other software installed on my computer presents this issue.
Bittu 2 решений 35 ответов
Размещено

You can do something like that... 1> Go to CONTROL PANEL 2> Network & Internet 3> Internet Options 4> Select ADVANCED 5> Restore advance settings...

You can do something like that... 1> Go to CONTROL PANEL 2> Network & Internet 3> Internet Options 4> Select ADVANCED 5> Restore advance settings...
Размещено

Задавший вопрос

Thank you for the reply, unfortunately that didn't work. I suspect those settings only apply to internet explorer.

Thank you for the reply, unfortunately that didn't work. I suspect those settings only apply to internet explorer.
Bittu 2 решений 35 ответов
Размещено

Полезный ответ

Can you upload some images (Screenshots) of it..??

Can you upload some images (Screenshots) of it..??
Bittu 2 решений 35 ответов
Размещено

Try it... Tools > Options > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages".. If above not works, You can press F7 or Fn+Windows key or F9+Windows key or f7+windows key or fn + F7 to toggle caret browsing on/off.

Try it... Tools > Options > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages".. If above not works, You can press F7 or Fn+Windows key or F9+Windows key or f7+windows key or fn + F7 to toggle caret browsing on/off.

Изменено Bittu

kraziekat7 0 решений 1 ответов
Размещено

Thank you so much! Since starting to use Mozilla Firefox my arrows have been of no use! It is great to get them to work right again! THANK YOU!

Thank you so much! Since starting to use Mozilla Firefox my arrows have been of no use! It is great to get them to work right again! THANK YOU!
Размещено

Задавший вопрос

Thanks for the replies, unfortunately it is not caret browsing. Also, uploading a screenshot would not help, as there is literally nothing to see: simply the left and right arrow randomly do not respond in some text boxes and a screenshot wouldn't show it.

Thanks for the replies, unfortunately it is not caret browsing. Also, uploading a screenshot would not help, as there is literally nothing to see: simply the left and right arrow randomly do not respond in some text boxes and a screenshot wouldn't show it.
cor-el
  • Top 10 Contributor
  • Moderator
17414 решений 157300 ответов
Размещено

Выбранное решение

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)


In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • default toolbar layout is used (localstore-safe.rdf)
  • Javascript JIT compilers are disabled (javascript.options.*jit)
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) ---- In Firefox Safe mode these changes are effective: *all extensions are disabled *default theme is used (no persona) *userChrome.css and userContent.css are ignored *default toolbar layout is used (localstore-safe.rdf) *Javascript JIT compilers are disabled (javascript.options.*jit) *hardware acceleration is disabled *plugins are not affected *preferences are not affected
Размещено

Задавший вопрос

cor-el: My first instinct was doing exactly what you said, unfortunately there is a problem: since the issue appears randomly (it may not show up for hours), the process of determining which extension (if any) is causing it would be massively time-consuming.

The same goes for safe mode: I would have to use the browser in safe mode for hours in order to know whether or not that excludes the problem.

I read somewhere on a really old thread that deleting a user file solved a similar issue, but that file doesn't seem to exist on newer Firefox builds.

'''cor-el:''' My first instinct was doing exactly what you said, unfortunately there is a problem: since the issue appears randomly (it may not show up for hours), the process of determining which extension (if any) is causing it would be massively time-consuming. The same goes for safe mode: I would have to use the browser in safe mode for hours in order to know whether or not that excludes the problem. I read somewhere on a really old thread that deleting a user file solved a similar issue, but that file doesn't seem to exist on newer Firefox builds.
Размещено

Задавший вопрос

I think I solved it: I performed a browser reset (Help>Troubleshooting Information>Reset Firefox), which deleted all extensions and preferences, and proceeded to use the browser in its "virgin" state for a whole day with no problems.

As suggested I then begun to add the extensions i suspected to be the issue and monitoring the browser for at least one hour after adding each one and I lucked out, I guess: the third extension (Bamboo Feed Reader) brought the issue back, which kills me as it's definitely the best feed reader available on Firefox and, but apparently my computer and my computer alone has problems with it.

I think I solved it: I performed a browser reset (Help>Troubleshooting Information>Reset Firefox), which deleted all extensions and preferences, and proceeded to use the browser in its "virgin" state for a whole day with no problems. As suggested I then begun to add the extensions i suspected to be the issue and monitoring the browser for at least one hour after adding each one and I lucked out, I guess: the third extension (Bamboo Feed Reader) brought the issue back, which kills me as it's definitely the best feed reader available on Firefox and, but apparently my computer and my computer alone has problems with it.